Home Linux Community Community Blogs Desktops GuitarPro6 on Fedora 64 bit

GuitarPro6 on Fedora 64 bit


Guitar Pro 6 on Fedora x64



After I've had a lot of trouble to get this working, I will show you the step by step guidance to run Guitar Pro 6 on a 64 bit version of Fedora (it should be almost the same on  all 64 bit versions of Linux though -> Notice, if you're using a x64 Debian based distribution, it's easier by using getlibs)




1.) First download the guitar pro 6 installer for linux from the website

2.) The downloaded file is in .deb container format (for Debian distributions). Simple extract the deb file, and open the extracted folder.

3.) You can find two tar.gz files inside of it: control.tar.gz and data.tar.gz as well as debian-binary. The only file which we need is data.tar.gz, so delete the other two files.

Extract the data.tar.gz file.

Corresponding Shell-Command: tar -xf data.tar.gz


4.) Open up the data folder - again you see two folders opt and usr. Open the opt folder and copy the GuitarPro6 folder inside of it to /opt/. (You need sudo rights to do this, so either you do it directly over the terminal, or you call nautilus with root privileges: sudo nautilus /opt)


Corresponding Shell-Command: sudo cp -R GuitarPro6 /opt/



Ok basically that's it, but Guitar Pro 6 doesn't start up yet. It needs some dependencies. So let's see which ones it needs. Open up a terminal and change the directory to /opt/GuitarPro6

Corresponding Shell-Command: cp /opt/GuitarPro6

6.) start the shell script by typing: sh It should give you the following output:

./GuitarPro: error while loading shared libraries: cannot open shared object file: No such file or directory


So we need all these dependencies (and we need the 32 bit Libraries!!!) So instead of let you find out each dependency after another here are the needed packages you have to install:






Corresponding Shell-command: sudo yum -y install libstdc++.i686 mesa-libGL.i686 alsa-lib.i686 portaudio.i686 pulseaudio-libs.i686 libXrender.i686 glib2.i686 freetype.i686 fontconfig.i686 libgnomeui.i686 gtk2-engines.i686


7.) We're almost done, there's one more problem: After installing these libs and trying to start guitarPro6 with sh the following error will occur:

./GuitarPro: /opt/GuitarPro6/./ version `ZLIB_1.2.3.3' not found (required by /usr/lib/


This means GuitarPro6 tries to use a wrong version of libz. The trick is to remove the libz lib in the GuitarPro6 folder and let GuitarPro use the libz version of the system.


sudo rm


After that GuitarPro6 should be able to start.

8.) Soundbank-Installation:

For some reasons (which I didn't find out yet) the soundbank installation doesn't work. However there's a workaround for this:




  1. Download the file Soundbanks.gpbank directly from the website and copy it to your GuitarPro6 folder (again you need root privileges to do this)

  2. Run sudo /opt/GuitarPro6/GPBankInstaller /opt/GuitarPro6/Soundbanks.gpbank /opt/GuitarPro6/Data/Soundbanks/

     (notice the blanks after each directory argument)

  1. It should sucessfully import it, doing it this way.



I hope everything worked out fine. You can also add a Desktop link to GuitarPro6 by adding a file in /usr/share/applications.



If you have questions you can ask here, I'll respond asap: This e-mail address is being protected from spambots. You need JavaScript enabled to view it


Buy me a beer :)






Subscribe to Comments Feed
  • zac Said:

    thanks a bunch, worked great for me on Fedora 17 64 Bit

  • Olivier Said:

    Hi Daniel Thanks for this tutorial but it didn't work on my fedora 18. After having installed all the packages, I still get an error [root@baloo GuitarPro6]# sh ./GuitarPro: error while loading shared libraries: cannot open shared object file: No such file or directory I tried to install openssl-libs.i86 but it was already installed. Any idea?

  • Olivier Said:

    I reply to myself as I found the solution :) ==> I read on multiple posts that I had to make symlinks to old lib versions. sudo ln -s /usr/lib/ /usr/lib/ sudo ln -s /lib/ /lib/ ==> But it didn't work : [root@baloo GuitarPro6]# sh ./GuitarPro: /lib/ version `OPENSSL_0.9.8' not found (required by ./GuitarPro) ==> I'm not sure that GP6 is able to work with libcrypto10 :( ==> So I downloaded the libcrypto package version 0.9.8 from and just extracted the and from the data.tar.gz packet and put it in the /opt/GuitarPro6 directory *and it worked*!

  • arpaterson Said:

    on fedora 20 i686 I had to put libssl0.9.8 libcrypto0.9.8 in /opt/GuitarPro6 and also had to put libpng12 there too. all taken from ubuntu saucy. i still see a lot of GTK warnings but don't know what im looking at. it seems to work, except i have no sound because i ahvent installed the rse banks or a midi synth.

  • arpaterson Said:

    the soundbank installer would not start until qt-x11.i686 (the 32bit version) and dependencies were installed. i then ran your command without thinking to try from the gui. it works and i have sound. thanks for your tips.

  • apaterson Said:

    also if you copy the contents usr/ directory from the extracted *.deb file to your own /usr it contains the .desktop file and pixmap so you get the correct icon.

  • gyro Said:

    I've been around since Redhat 3, before you could buy a disk.. not RHEL.. talking 1996 here haha, and I have to say, this is whats still wrong with linux... forks... too many forks... cmon people.. we'll never gain ground if Windoze guys just click setup. GP6 was made for Linux, great for them, but they made it for Ubuntu.... and anyone else has to figure out whats wrong, load the deps , etc....

  • Hamid Said:

    Thanks dude , it worked for me well . I just opened sound bank from the File/Open menu and it worked either

  • yoyo123 Said:

    All with install went OK. When started - there are few warnings, and I can load and listen to examples /opt/GuitarPro6/ Object::connect: No such signal PlaySettingsWidget::tuningChanged() in /home/build-linux/BuildMachine/workspace/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133 Object::connect: No such signal BankListWidget::tuningChanged() in /home/build-linux/BuildMachine/workspace/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133 Object::connect: (sender name: 'SearchTreeWidget') Object::connect: No such signal QWidget::tuningChanged() in /home/build-linux/BuildMachine/workspace/gp/Sources/GuitarPro/widgets/UniverseSubWidget.cpp:133 Object::connect: (sender name: 'TrackMidiProperties') but when I try to open file - it crashes Segmentation fault (core dumped)

Upcoming Linux Foundation Courses

  1. LFS201 Essentials of System Administration
    12 Jan » 30 Mar - Online Self-Paced
  2. LFS220 Linux System Administration
    18 May » 21 May - Virtual (GUARANTEED TO RUN)
  3. LFS230 Linux Network Management
    25 May » 28 May - Virtual

View All Upcoming Courses

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board