Community Blogs

Ubuntu netbook remix on a Lenovo T61

In order to check if the Ubuntu Netbook remix would be suitable for my wife parents I set myself to test it on a Virtual Machine or on laptop (which is running Karmic since Alpha one).

I started at There isn't an iso available to download, but an img file. This isn't surprising as the targeted hardwares (in many cases) have flash memory instead of hard drives. The image file is designed for Atom processors as they dominate the market (damn it).

So I turned on my Karmic laptop and set to search for the Ubuntu Netbook remix in one of the standard repo using apt-get and I found it, or them:  ubuntu-netbook-remix and ubuntu-netbook-remix-default-settings.

Before I installed the remix I decided to add Chinese language support in order to see what it will be like for my in-laws, if we ever get it installed for them.

I first installed ubuntu-netbook-remix-default-settings, rebooted but nothing had changed on my Gnome desktop (it must be default configuration files only). So I install the ubuntu-netbook-remix package and there I had it.

So, what about it? Well, not so much, but what did I expect ;).The main element of the netbook remix is the desktop applet which puts the Gnome menu on the desktop. And has a picture is better than a 1000 words, here's a set of screen shots:

 ubuntu-netbook-remix Gnome landing

You probably noticed that I elected to get all the default folder renamed to their Chinese translation. It looks okay with a screen definition of 1440x900 on a large screen or on 1024x768 VM but I'm not sure if it'd be the same on a 12" screen (the Chinese characters are a tad small for my liking on the 1024x768 resolution).

There are a few glitches or surprising elements for seasoned computer user: screen decoration are stripped off by the launcher, so there's no minimize, maximize (fine so far) or close button. And this is where it's a little weird to me. Do netbook have a hard button for closing windows, or do we expected users to go through the application provided standard menu?

Here's Firefox with the windows decoration off:

ubuntu-netbook-remix firefox

The next issue is with the netbook-launcher desktop application. It fades the menu icons when you move from one menu folder to the next, however on the VM as well as the T61 this doesn't always happen in a timely manner (it can take up to 5~6 seconds and sometime you need to click on the launcher to have the central pane refreshing the icons so you have the overlaid icons messing up before that).

Now I wasn't expecting everything to be 100% fine, or to suit my needs. At least I have seen it running and I think it could be a good option for my in-laws. And given this is just an add-in to a standard Ubuntu desktop this is pretty much risk free.

So let give the thumbs up to Ubuntu!

Note: The screen shots are taken from a fresh VM running Jaunty.


Distro comparison data

This is my lost message to Brian  Proffitt. I published it so it won't get lost. (My original message was marked as spam :( )


Hello Brian,


I think should provide more meta data about the different distros. I mentioned my idea in the comment section of the recent Distrowatch Weekly ( ). Caitlyn Martin liked the idea. I'll cut&paste&edit to safe time ;)


--snip comment #18--


Please provide more indepth comparison data for distros. For example I would like to know how long CentOS takes to provide the RHEL updates (I heard it sometimes takes months.) Or how fast distros patch security bugs. For how long distros provide updates and how many have been shipped. And maybe have an activity index for distros. Maybe just how many releases a year or how many releases so far etc. Those infos would really help to weed out the show offs from the hard workers IMNSHO. I think if somebody would be able to pull this off, then it's Ladislav (of DW fame) or the Linux Foundation (they employ gods). How about some nifty yum, apt, zypper,etc grabber/analyzer thingie? Encourage competition & quality! That would be really a great service and contribution to the distro world and FOSS. -- snip -- Caitlyn Martin liked the idea. -- snip comment #24 unedited-- #18: I like your suggestions. There is material for a number of articles there, some of which I don't exactly feel qualified to write. Maybe you'll inspire Ladislav or Chris to write an article or two on those topics. The only problem I see with comparisons is that with 500+ distros you have to be very selective in what you include and someone is always going to feel left out.


---- snip ----


I think this is a worthy long term goal and I think your supporting members would greatly benefit from such a comparison, because a lot of those 500 distros don't really support them with (security) updates and they do. So maybe they would even encourage this level of transparency and competition. If a hacked solution (grep apt, yum, zypper, security announces whatever) isn't desirable then maybe an open data format for publishing update/security/version data on the web so that it can be freely aggregated and analyzed would be a worthy goal. That would solve the problem with people feeling left out.


What do you think?


- Udo -


Slackware Linux Tip-of-the-day: xorg.conf setup

In Slackware the default setup has an unconfigured xorg.conf file (screen setup), this usually irritates newer users and causes many to use different ways to configure the xorg.conf file.  I have personally seen many new users with the misconception that they must manually configure the file, which leads to frustration and in some cases giving up on Slackware.

There are in fact many ways to configure that file and the use of those methods depends on your level of knowledge about your hardware. I will list them in simplest to most difficult order.

  1. Run xorgsetup, this is a simple menu driven configuration script that auto-detects most hardware and massively simplifies the installation.
  2. Run xorgconf, this is a CLI base script that asks questions about your hardware, it requires some knowledge to configure.
  3. You can also install the proprietary drivers for you video card which will auto-build the xorg.conf file for you and add some additional functionality.I highly recommend for new users to use xorgsetup to get their systems into a GUI for the first run.
  4. Manually edit the xorg.conf file, this will provide the most controlled setting but it also requires you to know all about your hardware and has a very high potential for user errors.


Fedora 11 quick review.

Friday I was asked to take a clients laptop home with me and do a wipe and load of the OS in my free time. As usual, windows was all jacked up to the point where it was just about unusable and they had already backup up their important stuff. I thought "what a great time to try the new version of Fedora that I just downloaded last week". Today is Sunday and I finally have some time to play around with it.

This is a very nice laptop by my standards. I don't play games on the computer, I have a PS3 for that. I use my computers for work and communication so I don't really need the latest and greatest. I believe that you don't need a Ferrari to go get groceries. This laptop is a Compaq 6710b. It's got a Centrino Duo 2.0 Ghz processor and has been upgraded to 4 gigs of RAM. PLENTY of power. The server that is hosting my domain right now has less resources than that.

Lets get started. I always like to choose the DVD installer if that's an option. I prefer to customize some of the software that will be installed before hand. I know a lot of techs who prefer to use the live CD and just to get a default group of packages so that they can quickly get up and running. I find that when I do that there is always some thing I wish was different. Plus I'm never in a hurry I always have another computer I can play on while I wait on the install to complete. This time I went ahead and went with the Gnome desktop environment for a couple of reasons. One reason is because I have found that many distros tend to concentrate on refining their main desktop environment, and even though they offer the others as an option they don't spend nearly as much time making them slick. Another reason is that its been a while since I did a Gnome install and this release is supposed to be an exceptional one.

The installation went very well. But then again so did Fedora 10 when I tried it so nothing new here. I went ahead and told it to use the entire disk and let it choose the partition layout. I chose not to install openoffice because it is rather large and I'm not going to leave Fedora on here for more than a few hours while I play around. The rest of the install went off without a hitch.

After the first boot I logged in a was greeted with the usual Gnome login sound meaning that my sound card was recognized correctly. First thing I noticed was that you can no longer just grab a panel and drag it to change locations. You now have to right click and goto properties and change the "orientation". I change mine to the bottom, its just more comfy to me. I actually don't remember if it was like this in F10 but it seems new to me. Next I clicked on the Network manager Icon and I see that it found my wireless network. I click to join, put in my passkey and just like that I'm on the Internet. Things are looking great so far, although I must say the default background image is not nearly as beautiful as the one in F10, but that can easily be changed. Next I fired up Firefox and added the Xmarks plugin to get my bookmarks and passwords. This is a fabulous extension that lets you sync your bookmarks and passwords across multiple computers. Great for a guy like me who uses so many different computers in different locations. I then went to adobe and download the .rpm version of flash and it installs very easily. I then goto a site that uses java, and that works out of the box as well. Then I remembered a strange Icon right above the password box when I logged in that I wanted to know what was, so I disabled SElinux and rebooted.

During the reboot I took the time to use the second hand of my watch and time the boot process. It took 27 seconds to bring me to the login prompt. Pretty darn fast. I now get the chance to see what the new Icon is. I click on it and it says I can login with the fingerprint reader! That's awesome. It even picked up the fingerprint reader out of the box. Linux has come so far! I played around with it for about another hour and was unable to find anything about it that I didn't like. This has got to be the best release of Fedora I have ever tried. I'm thinking I may install it again with KDE to see how they implemented that. You never know it might lure me away from Mandriva.


Puppy Linux 4.2.1 – wireless regression saga

Don't ignore Puppy GNU/Linux. Puppy is the best lightweight live CD linux distribution and comes with nearly every application and/or utility anyone would need. There is no reason not to at least give it a try as it is not at all necessary to even permanently install it to your hard drive. Further, Puppy Linux is the distribution where “everything works” more so that any other GNU/Linux distribution. Note that I intentionally avoided the popular “just works” term as several pieces require some configuration to work properly but puppy prompts the users and walks the user through the configuration process in a easy step by step process. Case in point, it literally took me months to get my Broadcom wireless working in Ubuntu 8.04 while Puppy 4.1.1 autodetected it and it was working with a few gui mouse clicks. It is a Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02) on an Acer Aspire 5100 laptop with a 2 Ghz 64 bit Turion AMD processor and 1 GB of RAM (running 64-bit Ubuntu Hardy.) How I finally got wireless working on Ubuntu was with ndiswrapper and wicd (I never was able to get wireless working with gnome network manager.) Since wireless was such a struggle with Ubuntu, I was amazed that it was so simple with Pupppy Linux 4.1.1 (and thought that Ubuntu could learn a thing or two from Puppy about hardware detection.) (Just in case anyone wonders why I stuck with Ubuntu when it took so long to get wireless working on my laptop, the reason is that this laptop is plugged into a wired ethernet cable 97% at home of the time and so I rarely actually had a need for wireless.)

Puppy Linux was first released in June 2003 by Barry Kauler and had pretty much been a one-man show until Mr. Kauler stepped aside for WhoDo (Warren Willson) to lead the development of Puppy 4.2. The screenshots of 4.2 released in Spring 2009 showed a more modern professional look to the distro which I found most appealing and was looking forward to trying. When I booted to it, it looked amazing!! The biggest drawback is that my Broadcom wireless no longer worked. It was not autodetected and would not install via the puppy connection wizard. It was autodetected as B43 pcmcia Broadcom B43 wireless driver under 4.1.1, so I tried that and I tried BCM43xx pci BCM43xx wireless driver (which actually seemed more appropriate for my card) but was successful with neither. The only other real drawback is that after saving settings and configurations following the first boot and creating the pupsave file, puppy would not allow the CD Rom drive to be unmounted following the subsequent boots. This renders that CD/DVD/reader/writer useless for reading / playing CDs/DVDs and or any burning activities of any kind. I didn't report the wireless issue as a bug as there was already a Broadcom wireless bug reported and it seemed that this bug report would cover my problem, too. (I somehow figured that the CD unmount problem must also have been reported, too.)

When WhoDo announced the Puppy Linux 4.2.1 bugfix release, I was very much looking forward to seeing my issues fixed, but much to my dismay, the wireless problem persists. The announcement and subsequent comments seemed to indicate some turmoil and much frustration between WhoDo and the community in the course of the development process and indicated that this bugfix release concludes WhoDo role as lead project developer. As such, it would be hard to imagine another bugfix update. My only choice might be to use 4.1.1. if functioning wireless is important to me. I did not yet test to see if 4.2.1 would allow unmounting of the CD following a boot after creating a pupsave file.

On a different issue, it has always been the Puppy developer's philosophy to always have Puppy run as the root user / account. While I have read and understand the rational, I do wish that he would make this modifiable and customizable for those who are performing a full (or frugal) hard drive install and would prefer to have a limited (secure) root account (or even disable root account as in Ubuntu) and a regular user account for routine use. While Ubuntu has the root account disabled and administrative access is gained through sudo, if any given user wants to change this on his/her installation, he/she sure may do so and enable the root account and log in as such (isn't choice part of the appeal and beauty of GNU/Linux freedom?) I understand that is it the developer's prerogative to implement this default behavior as he so chooses, but I do not understand the developer not allowing for this simple modification / customization (by a user who is not already a developer / coder.)

Still despite the issues, Puppy GNU/Linux is the best, most complete, most functional, lightweight GNU/Linux distribution around – bar none. I have used it for pre-partitioning using Gparted prior to an Ubuntu hard drive install, for data recovery, and for using my wife's work laptop so as not to leave a trace behind once I am finished and without needing to know any login usernames or passwords. Many thanks and kudos to Barry Kauler (and his helpers from the community) for sharing his (and their) work resulting in Puppy GNU/Linux through 4.1.1. Also, many thanks to Warren Willson (aka WhoDo) (and his helpers from the community) for sharing his (and their) work resulting in Puppy GNU/Linux 4.2 and 4.2.1 (although a further bug fix release would be much appreciates.)

Thanks for reading.



Add all PPAs to you Ubuntu with ppa-pkg

Gold Roger

Remember Gol D. Roger and his legendary treasure "One Piece" ?! :D ..

Yeah, I found the One Piece. But, that's not means "I created it!" or the first one who found it. But, I think that I'm the first one who said : "I left everything I own in One Piece! " in this case!!.

Here what I mean:
If very interested in update your softwares to the latest versions like me, you must to know about and its PPAs!.
there is houndeds of software PPAs you can keep your Ubuntu up-to-date with it.
but sometime founding this PPAs is difficult! and add it with GPG is much more harder!.. You must to do it manually!!
Now you don't!.. Just download this file: ppa-pkg_1.0_all.deb  and install it then go to Synaptic and update the repositories by clicking "Reload" icon. you may search about "ppa" in Synaptic to install some/all of the PPAs
see this screen-cast: Add all PPAs to you Ubuntu with ppa-pkg

<object width="425" height="344"><param name="movie" value=""></param><param name="allowFullScreen" value="true"></param><param name="allowscriptaccess" value="always"></param><embed src="" type="application/x-shockwave-flash" allowscriptaccess="always" allowfullscreen="true" width="425" height="344"></embed></object>

Debian, Upgrading to Lenny, ERROR, no public key available for the following...

I've spent one day crushing my head against a weird problem, never seen it on Debian, I was only updating four Debian "etch" to "lenny" and in two of them I've seen this:

han:~# apt-get update
Fetched 74.7kB in 0s (87.4kB/s)
Reading package lists... Done
W: There is no public key available for the following key IDs:
W: GPG error: lenny Release:
The following signatures couldn't be verified because the public key
is not available:
W: You may want to run apt-get update to correct these problems

So I did what I've read and issued the apt-get command again

han:~# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree... Done
Calculating upgrade... Done
Fetched 74.7kB in 0s (99.9kB/s)
Reading package lists... Done
W: There is no public key available for the following key IDs:
W: GPG error: lenny Release:
The following signatures couldn't be verified because the public key
is not available:
W: You may want to run apt-get update to correct these problems

But still no luck, the problem raised again
I was thinking: what should I do next ?

After some google searches and after reading about gpg keys I've decided to solve the problem in this way:

1) As first thing I've decided to import this missing key with gpg, so run:

han:~# gpg --keyserver --recv-keys 9AA38DCD55BE302B
gpg: directory `/root/.gnupg' created
gpg: can't open `/gnupg/options.skel': No such file or directory
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: requesting key 55BE302B from hkp server
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key 55BE302B: public key "Debian Archive Automatic
Signing Key (5.0/lenny) " imported
gpg: no ultimately trusted keys found
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)

Got it ! So replied my about authenticity of this Lenny key, so I've imported the newly created key to apt-get source packages, here's:

han:~# apt-key add .gnupg/pubring.gpg

Issued again apt-get update:

han:~# apt-get update
Fetched 1033B in 0s (1400B/s)
Reading package lists... Done


And everything worked like a charm

Hope it helps someone else, read blogs and save time


Andrea Ben Benini


Slackware Linux Tip-of-the-day: The alias command

The alias command allows you to setup a one line command to be run under an alias in bash. A simple example is : 


  • alias=ls, this allows you to invoke the ls command by typing dir (this can be useful for windows users). 


The alias command can be invoked within the command line, within a script or as part of your .bashrc file.

 The limitation is that the alias only exists within the shell that it was invoked in, if you run it as a command in a terminal the alias will be removed when the terminal closes. the exception is when you add it to you .bashrc file, when it is loaded into this file the alias will be present in all future bash terminal sessions. 

The site hasmore information and some examples to help you get comfortable with the functionality.

The base files is different for each shell type, but since bash is the most used I am covering it here.


Debian: Find package name from program name

Back again,
This time it's Debian's time, when managing multiple hosts and installations sometimes happens you need to know what package owns a certain utility.

Recently I've faced a quite common problem, I'll take it as an example so it's more clear, I had a common and popular program "pdftotext" and I wanted to have it into another debian installation, quite easy isn't it ? you only need to remember what package has it.

While fighting with Ghostscript program and PostScript files was quite easy to check where this utility is, just take a look at ghostscript related packages (with apt-get, aptitute, ...) and see where your program could be (guess it...)

In my particular case "pdftotext" (my example) wasn't inside some package called "ghostscript*" but inside "poppler-utils"; don't want to blame poppler maintainers but I don't really remember where the utility was

So while looking at dpkg (Debian father for all CLI packages utilities) command line I was captured by -S switch and here's my final solution:

mymachine:/# dpkg -S `which pdftotext`
poppler-utils: /usr/bin/pdftotext

And here's, easy and dirty trick to get information from an utility name, then poppler-utils was my package name and I've installed it in the other machine

This goes for Debian, Ubuntu and mainly Debian based distros


Easy, isn't it ?


Hope it helps, glad to hear your comments

Andrea (Ben) Benini




Slackware 12.2:

It's same old slackware  style -- a simple distro, but with a twist....

Aside from a new kernel that supports some new driverless web cams

It also packs an upgrade/patch tool in the form of slackpkg, which greatly simplifies getting the latest patches/upgrades.

 It also works with common wifi devices out of the box, so no need to search for and download  drivers for your wireless LAN devices

 Another thing to watch out for is the 64 bit Slackware, which may be coming out really soon...

check out 




Counting the days.

As I wait for the next release of Fedora in 6 days, recently I have been spending some time away from GNU/Linux and playing with OpenSolaris UNIX. And might I add that it is a very impressive distribution. From the implementation of ZFS (and the Time Slider feature in GNOME) to Dtrace along with some other nice features.

I have worked with Solaris for many years and while Sun has always been ahead of its time with features and functionality, they always lacked in usability over the GUI. Usability over the CLI was always great and always there, it is just the GUI never looked good as it traditionally defaulted to CDE until recently (GNOME).

Spending more time with ZFS just makes me look forward to seeing a stable Btrfs in the Linux kernel.

Page 16 of 18

Upcoming Linux Foundation Courses

  1. LFD312 Developing Applications For Linux
    16 Feb » 20 Feb - Atlanta - GA
  2. LFD331 Developing Linux Device Drivers
    16 Feb » 20 Feb - San Jose - CA
  3. LFS220 Linux System Administration
    16 Feb » 19 Feb - Virtual

View All Upcoming Courses

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board