Linux.com

Home Linux Community Community Blogs Business (or Enterprise) Mouse/Keyboard not responding on VMWare Player with Linux

Mouse/Keyboard not responding on VMWare Player with Linux

Many of you use everyday virtualization products to emulate other machines and run specific tasks on them.

As many of you already know I only use Linux machines at work, it ain't that easy if you need to survive in a corporate Windows forest (AD controller and windows environment) but I'm still fighting for it. Sometimes you need to use certain Windows apps or developer tools and you don't want to install WINE or something like that, as many of you I use customized and virtualized Windows machines. VMWare player outside "mainstream" distros have some lacks or troubles, expecially when you deal with GTK.

it happens to have mouse garbled, or if you move it inside VMPlayer window it disappears or acts in a weird mode, the same happens to the keyboard (not proper working), after a while I've figured how to solve it, it's not that strange or particular, it's a quite known problem and the fix is quite easily available if you use google for a while.

If you work with the latest version of Gnome your VMWare Player won't work well because it was supplied with previous version of GTK, even if you have "grab when cursor enters window" option set. It won't grab the pointer and it looks strange when moving it inside the VM Window, I hope this workaround will help you until VMWare solves compatibilities with the GTK library (and even release a VIC/vsphere like client for linux !!!).
You need to force VMPlayer to use shipped version of GTK. here's what you need to do:

  • locate vmplayer program path (`which vmplayer`), /opt/vmware/player/bin/vmplayer in my linux gentoo distro
  • It's a text file so you can edit it with your favorite editor (nano or whatever)
  • add a line with  `  export VMWARE_USE_SHIPPED_GTK="force"   ` after "set -e" line, so it will look like:
# is installed.
#

set -e
export VMWARE_USE_SHIPPED_GTK="force"

ETCDIR=/etc/vmware

line "export VMWARE_USE_SHIPPED_GTK="force"" is what you need to add, it works even with "export VMWARE_USE_SHIPPED_GTK=yes", choose whatever you like

 

Now when you run it you'll see an application with a bad look, the older GTK version is used there and it ain't that nice but at least it works fine

Now run your favorite virtual machine and you'll see no mouse garbling now. This solved my troubles on Gentoo but even with other distros. Hope it helps

 

Glad to read your comments

Andrea (Ben) Benini

 

 

Comments

Subscribe to Comments Feed
  • Steve Tarr Said:

    Solution still valid. Using VMplayer 5.0.2 hosted on Ubuntu 12.1 running Windows 7 as guest.

Upcoming Linux Foundation Courses

  1. LFS220 Linux System Administration
    05 Jan » 08 Jan - Virtual
    Details
  2. LFD331 Developing Linux Device Drivers
    12 Jan » 16 Jan - Virtual
    Details
  3. LFS520 OpenStack Cloud Architecture and Deployment
    12 Jan » 15 Jan - Virtual
    Details

View All Upcoming Courses


Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board