Home Linux Community Community Blogs

Community Blogs

How to get gorgeous looking fonts on ubuntu linux

Fonts on linux have long been an issue due to various reasons like the BCI patent by Apple, lack of free quality fonts etc. However over time things have changed and now its possible to get your linux system fonts look as good as, or even better than a mac or windows 8 as far as fonts are concerned. In this post I am going to show you couple of simple tricks that can make the fonts of your linux system look amazing!!


Read the full story here

How to get gorgeous looking fonts on ubuntu linux


Disable & Enable USB from terminal

Hello guys, i'm the new user in this community. Hope all of you guys take me as the familly in this community.

2013-07-05-232714 1024x600 scrotIn this article, i would share about "how to disable usb from the terminal". This article i take from my blog, but, I write the article in Bahasa. So, I just convert it into english. The concept is very easy. In this case, I use several command from linux to operate the usb on/off with the bash shell scripting. And you must use the root for the access user. I have tried in linux ubuntu and work normally.


Before we going into the topic, I would to say something about my purpose creating this article. So, i have modem and my modem can connect with linux by using wvdial service. Wvdial is package on debian variety, used to dial your modem by terminal with carrier.  So, i have problem after I dial with this modem. That is, whenever i didn't got signal and the modem automatically disconnect. And whenever I tried to connect again with wvdial without I pull out my modem, the wvdial will be error and I can't connect again. So, to fix the problem, I thinking something. Yes, and that is "How I can control the usb off and on by terminal?".  Here we go, this is way how to do it :

  1. First time, our modem must be plugged into our usb. 
  2. After that, we trying to connect with wvdial command. Ups, I cannot got carrier.The first solution for a long time is I pull out the modem from usb and wait a few second than I plug again into usb. it's very make me feel bored and angry.
  3. So, to fix the problem without do the really bad clue. First time, You must open the terminal and make access as super user : "sudo lsusb -t|less", this command will be give you list the active usb. And in the result is :
  4. """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""" 
         /:  Bus 05.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
         /:  Bus 04.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
         /:  Bus 03.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
        |__ Port 1: Dev 2, If 0, class="HID", Driver=usbhid, 1.5M
        /:  Bus 02.Port 1: Dev 1, class="root_hub", Driver=uhci_hcd/2p, 12M
        |__ Port 1: Dev 6, If 0, class="vend"., Driver=usbserial_generic, 12M
        |__ Port 1: Dev 6, If 1, class="vend"., Driver=usbserial_generic, 12M
        |__ Port 1: Dev 6, If 2, class="vend"., Driver=usbserial_generic, 12M
        |__ Port 1: Dev 6, If 3, class="stor"., Driver=usb-storage, 12M
    |__ Port 2: Dev 3, If 0, class="HID", Driver=usbhid, 1.5M
        |__ Port 2: Dev 3, If 1, class="HID", Driver=usbhid, 1.5M
        /:  Bus 01.Port 1: Dev 1, class="root_hub", Driver=ehci_hcd/8p, 480M
        |__ Port 6: Dev 5, If 0, Class='bInterfaceClass 0x0e not yet handled', Driver=uvcvideo, 480M     |__ Port 6: Dev 5, If 1, Class='bInterfaceClass 0x0e not yet handled', Driver=uvcvideo, 480M
  5. After we know the actived usb that connect with our modem. Do this command
       "echo '2-1' |sudo tee /sys/bus/usb/drivers/usb/unbind" <- to make usb disable/turn off
    NB : '2-1' is the process that we will be kill.
    after you do that command, the usb will be disable.
  6. Trying to dial again with wvdial. So we have the result  :
    eject: unable to find or open device for: `/dev/sr0'
    --> WvDial: Internet dialer version 1.60
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory
    *This is good information.That's have mean, the usb succesfully set as disable.
  7. We do again the command such as step number 5 but with different input at the end. So ,like this :
    echo '2-1' |sudo tee /sys/bus/usb/drivers/usb/bind <- to make usb active again // the different command just in the end of syntax.
    NB : '2-1' is process that will be make enable.
  8. Try again with the wvdial command like as before. And.... i no need to pull out and plug in again modem in usb. So, the mainly command is in step 5 and 7.


    e-mail : This e-mail address is being protected from spambots. You need JavaScript enabled to view it

Creating a Custom Linux OpenSuSE 11 EC2 S3 Backed AMI Using Kiwi

I finally got around to testing running opensuse on AWS!! To begin with I started by using SuSEstudio and plumbing in my EC2 credentials and getting the SuSEstudio platform to push the AMI to S3 for me and run from EBS. This was great and I messed around a bit with creating small installations of JeOS and OpenSuSE. But I wanted to be able to have the all same functionality without being dependant on an external service to push a new version of my AMI and so on.

Read more... Comment (0)

Dick MacInnis, Creator of DreamStudio, Launches Celeum Embedded Linux Devices

Celeum offers four unique embedded devices based on Linux:

  • 1.The CeleumPC, which dual boots Android and DreamStudio
  • 2.The CeleumTV, which runs Android with a custom XBMC setup
  • 3.The Celeum Cloud Server, which runs Ubuntu Server with ownCloud for personal cloud storage, and
  • 4.The Celeum Domain Server, a drop in replacement for Windows Domain Controllers, powered by Ubuntu Server and a custom fork of Zentyal Small Business Server.

The Celeum TV is currently available only in the Saskatoon, Canada area, while the other three devices are currently in crowdfunding phase, and can be preordered by making a donation to the Celeum Indiegogo campaign


Canonical Updates Ubuntu One Photos

Canonical announced a few days ago that they have updated the online ‘Photos’ feature of they’re Ubuntu One cloud storage service.

Read more... Comment (1)

Top 10 articles celebrating Creative Commons' very uncommon last 10 years

To a lot of people all over the world, Creative Commons is more than a license. The organization and their mission is a shining copyleft-light for work rendered by artists, designers, writers, and the list goes on. Here at all of our original content is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License

Read more... Comment (0)

Innovation Pure Python OS!

Let me introduce new Linux-based operation system written in Pure Python!

We think, that OS, written in simple interpreted language, like python, allows us to dominate desktop operating systems market.
Python is simple and nice. Our user will be able to easy modify any part of OS without compiling souce code. This is the real Open Source Freedom!


Ryan 'Icculus' Gordon explains game development for Linux

The following presentation video of Ryan 'Icculus' Gordon's talk is a must for those, who are interested in the modern game development, want to learn more about the technology behind it, or even going to port or develop a game to Linux. In his talk at the conference Flouish 2012 in Chicago Icculus presented some of the leading open source technologies that are used for the development of modern games like Crysis or World of Warcraft, and which he has used porting games to Linux and Mac OS X. Among other things, he talks about SDL, OpenAL, SQLite, LUA and many others.



Background loading in the GRUB boot menu?

I don't know if this is a practical improvement. The idea goes something something like this. If you
like me run a dual boot setup I get annoyed having to press the return button on my laptop during
boot to save time. So I thought why cant the default Linux distribution automatically start loading in
the background. At least put files in RAM. In the less likely event I want to start Windows, the
background loading should abort and start Windows as usual.
With this, if I set the wait-time to less than the distribution boot time. I know I don't have to bother
engaging the bootmenu to save time. Just leave it as it is.



Carmageddon: Reincarnation coming to Linux

Today is the last day of the crowdfunding campaign Carmageddon: Reincarnation on KickStarter. Although there are still a few hours until completion of the project financing and the goal of $600k set for the Linux and Mac versions of the game has not been reached yet, the indi games studio Stainless Games has confirmed the release of the Linux version today.



Happy Birthday - Phoronix Turns Eight Years Old

It was on 5 June 2004 that I founded, what has become the leading source for Linux hardware reviews, Linux / open-source graphics drivers, Linux gaming, and much more enthusiast information catered to the open-source world...

Read more... Comment (1)
Page 19 of 140

Upcoming Linux Foundation Courses

  1. LFD320 Linux Kernel Internals and Debugging
    15 Sep » 19 Sep - Virtual
  2. LFS220 Linux System Administration
    22 Sep » 25 Sep - Virtual
  3. LFS520 OpenStack Cloud Architecture and Deployment
    29 Sep » 02 Oct - Costa Mesa

View All Upcoming Courses

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board