Linux.com

openxenmanager installation problem

Link to this post 08 Jan 11

Hi,

I am trying to install openxencenter to control my VMs I followed the
instructions but when I tried to start it I got:

File "window.py", line 44, in <module>
import gtkvnc
ImportError: No module named gtkvnc

does any one face this problem before.
I tried to comment the import line and xencenter started but console
tab is not working and it is looking for gtkvnc module.
Note: I already installed all these packages, I was thinking that may
be one of them will work but no , I am still receiving the error.

Installed Packages
gtk-vnc.i386 0.3.8-3.el5
installed
gtk-vnc.x86_64 0.3.8-3.el5
installed
gtk-vnc-devel.i386 0.3.8-3.el5
installed
gtk-vnc-python.x86_64 0.3.8-3.el5
installed
gtk-vnc-devel.x86_64 0.3.8-3.el5
installed

any help please?

Inas

Link to this post 09 Jan 11

I'm hardly an expert and have never used openxencenter, but, could your problem be due to the mixture of i386 and x86_64 packages? Having -devel packages for both architectures could be the problem. I'm only guessing however.

Link to this post 09 Jan 11

thanks for your reply I already removed that one for i386 because: uname -i is x86_64 but still having a problem I tried every thing and I found when I run:
# python2.4 import gtkvnc there is no errors but when I tried
#python2.5 import gtkvnc
I got:
Traceback (most recent call last):
File "<stdin>", line 1, in <module>
ImportError: No module named gtkvnc
so I think it is python problem because python2.4 can import this package and 2.5 cann't.
Does any one know how to fix this.

Thanks in advance

Link to this post 01 Apr 12

I have solved same issue when I installed python-gtk-vnc

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board