virt-install becoming a headache

Link to this post 28 Apr 11

hi all!!
i want to try virtualization with kvm. i have a server that supports V-Tecnology. i installed all necessary packets so virt-install can work. i have a centOS 5.5 with no graphical interface with kernel 2.6.18-194(default kernel of this distro) , static ip. i have been looking lots of how-to's it seems very simple to do it, but i don't get well along with it, and i'm becoming a little bit feed up of it so i'm writting here.
the kvm % kvm-intel modules load fine.
FIRST QUESTION: in lots of how-to's tells that you need a version 2.6.20 or higher of kernel to have kvm support, but at the kvm-how-to page it tells that it wil work with version 2.6.17 or higher. i supose that if you don't have a friendly kernel kvm it will not work. am i right?
i want to create 3 VM, 2 centos5.2 of 64 & 32 bits, and one fedora of 32b for the coorp i work., each of them in text mode.
with this command:

virt-install -n BXVI \
-r 1024\
--os-type linux\
-l /data/dist_img/Centos_5.2_final.iso\ / * if i put instead -cdrom instead of -l it happens the same
--disk patj=/data/images/disk.img
-x "console=ttyS0"

before configuring networks and other things i want to create 1 VM and then i will think of adding network & other stuff.

so once i press enter after putting the command above. it starts the installation of the CentOS in text mode.
first appears the menu to select the language ---> no problem

second appears the menu called "Installation Method" with 5 options "Local CDRom, Hard Drive, NFS image, FTP, HTTP" and i get stuck here
because if i select the option of "Local CDrom" or "Hard drive" it tells me that for the first "it doesn't find the CentOS CD" and for the second tells me that "it seems that i don't have any hard drives on my system", and it asks me if i want to configure an additional device but if i put yes it prints an error telling that it failed to mount driver disk or saying that driver disk is invalid for this release of centos.
if i select http it tells me to configure ipv4 telling if it will be dhcp or manual config. but with this option i supose that i had to add the option of "--network Bridge:default" even with it it does nothing, well if i configure it manually it ask me an IP, Mask, Gateway, DNS. then i put the mirror direction and the path to the centos and it prints me an error
2 QUESTION: why the h__ it shows the second menu of "Installation Method" if i put where was the iso, the virtual disk to install the OS guest...¬ø?¬ø?¬ø
i don't now how to get to the next step of the installation can somebody please help me!!

Link to this post 28 Apr 11

I'm not sure if this is related, but could possibly be. I've been unable to install CentOS5.5 or 5.6 into VMWare, with similar error messages of being unable to find the CD.

Maybe try your Fedora installation, first, and see if that goes smoother.

Link to this post 28 Apr 11

I'm a command-line weenie myself, but in this case, I have to ask: why don't you try the graphical interface for creating virt systems?

In Fedora at least, you can run

which belongs to an RPM package of the same name. It launches an app wizard that helps you through all the steps. I'm not saying it'll work better, but maybe it will help you. I haven't done it on CentOS (to my recollection anyway), but I see that the virt-manager package is available for it.


Link to this post 29 Apr 11

hi atreyu ,dwclarke & all others!!
its not a thing that i like trying it without GUI but i'm told to do it in text based. the boss rules ;(.
now i will try installing Fedora but i'm not shure that is going to work
i also tried to crearte a br0(bridge). the ip of my server is static is and i'm not shure if putting in the virt-install command --network bridge:br0 will give a network interface to my VM. i followed what was written here(the static part) :

that made my host couldn't connect to internet
and then i entered this command:
virt-install -n BXVI\
-r 1024\
-network bridge:br0\
-f /data/images/disk.img
then i could see how it was downloading the necessary files to start the installation. after this it prompted the language menu. the next menu shown is the "Configuration TCP/IP" it shows the ipv4 & ipv6 with the options of automatically configure (dhcp) o manual. i disabled ipv6 because im not using it and did the manual conf of ipv4 i tried diferent ip's but i didn't get nothing.
is a bit wierd that if you attach a network interface to you guest then it shows the configuration TCP/IP when actually the br0 tells the VM how to connect or i'm mistaken¬ø?¬ø?¬ø?¬ø
if something is obvious i'm sorry but i'm a noob
i'm quite lost!!!

Link to this post 29 Apr 11

okay, i understand. on my CentOS box (ver 5.2) i first made sure i had the following packages installed:


then I did:

service libvirtd start

then, to create a test image, i did:

virt-install \
--os-type=linux \
-c /data/iso/Fedora-10-i386-DVD.iso \
-f /data/F10-virt-OS \

it asked me a couple questions (about file size, graphics, etc.) then launched the standard Fedora 10 boot menu you see when installing from the DVD.

in my virt-install command, i did not include a lot of your other parameters, b/c i just wanted to see if i could get an install to start.

Link to this post 29 Apr 11

hi again atreyu
i did what you posted but i had to add a couple of things like the name of the guest & -file (wich i created with qemu-kvm of type qcow2).
the -d (debug) went fine without any errors
with the large command it showed me:
Starting install ....
Retrieving file .treeinfo....
Rretrieving file vmlinuz....
Retrieving ....
creating domain
connected to domain BXVI
and then it enteres the text based installation but i get stuck in a part where i commented in the first post

with the command you put it only prints
Lots of debuging stuff
xml file
Creating domain...
2 debug lines
a big piece of XML
connected to domain BXVI
Escape character is ^]
it gets stuck here
it doesn't appear a text based installation as with the large command i tiped before. even if i add -x "console=ttyS0"

i have all those paquets installed and libvirtd appears to work fine
thanks for your response but i'm not getting further
any other idea¬ø?¬ø?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>