Linux.com

virt-install becoming a headache

Link to this post 05 May 11

thanks alot for helping me atreyu

i'm friendly with putty ;)
i have done what you told me connect to my server with putty enabling X11 forwarding.
doing echo $DISPLAY it print me a blank line.
then doing virt-install again it happens the same thing as before when it enters "Installation Method" i can't do nothing.
i have Xming in my system tray but it seems it does nothing. if i right click on it and enable root window it appears a full window white and black pixeled and nothing more

Link to this post 05 May 11

wikisb wrote:

thanks alot for helping me atreyu

i'm friendly with putty ;)
i have done what you told me connect to my server with putty enabling X11 forwarding.
doing echo $DISPLAY it print me a blank line.
then doing virt-install again it happens the same thing as before when it enters "Installation Method" i can't do nothing.
i have Xming in my system tray but it seems it does nothing. if i right click on it and enable root window it appears a full window white and black pixeled and nothing more

Something else i forgot about - on the CentOS machine, check for X11Forwarding in this file:
/etc/ssh/sshd_config
It should be set to yes, but might default to no. If you do have to change it, restart the SSH daemon when you're done:
service sshd restart

If it is already enabled, it must be something else...

EDIT: You might also need to make sure that the package xorg-x11-xauth is installed on your CentOS server.

EDIT2: On your CentOS server, keep a tail running of your messages and secure logs, to give you any additional clues, e.g.:

tail -f /var/log/messages
tail -f /var/log/secure

Link to this post 05 May 11

And you must make sure your X server listens on TCP connetions

Link to this post 05 May 11

marc wrote:

And you must make sure your X server listens on TCP connetions

Marc,
I thought the exact same thing, but I double-checked how X was launched on my Linux workstation and it was called with the -nolisten tcp flag, and yet it worked. Or is it some other setting?

Link to this post 11 May 11

Hi All,
You may wish to try building out a logical volume in order to get virt-install working. This may solve your blank "black screen" issues.
Cheers,
PB

Link to this post 12 May 11

atreyu wrote:

[b]marc wrote:[/b]
[quote]And you must make sure your X server listens on TCP connetions

Marc,
I thought the exact same thing, but I double-checked how X was launched on my Linux workstation and it was called with the -nolisten tcp flag, and yet it worked. Or is it some other setting?[/quote]

There probably is if you are using a session manager like KDM or GDM.

In fact, this is one of the few things I do not like in KDE software: kdm launches X reading options from a different place from the defaults...

Regards

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board