Linux.com

Home Linux Community Forums Linux System Administration Command Line/Scripting xscreensaver is NOT automatically starting as F14

xscreensaver is NOT automatically starting as F14

Link to this post 06 Feb 11

what file do I change?

locate xinitrc
/etc/X11/xinit/xinitrc
/etc/X11/xinit/xinitrc-common
/etc/X11/xinit/xinitrc.d
/etc/X11/xinit/xinitrc.d/00-start-message-bus.sh
/etc/X11/xinit/xinitrc.d/50-xinput.sh
/etc/X11/xinit/xinitrc.d/localuser.sh
/etc/X11/xinit/xinitrc.d/xdg-user-dirs.sh
/etc/xdg/xfce4/xinitrc

/etc/xdg/xfce4/xinitrc already contains:

# Launch xscreensaver (if available), but only as non-root user
if test $UID -gt 0 -a -z "$VNCSESSION"; then
if test x"`which xscreensaver 2>/dev/null`" != x""; then
xscreensaver -no-splash &
elif test x"`which gnome-screensaver 2>/dev/null`" != x""; then
gnome-screensaver &
fi
fi

I use kde on Fedora 14

I respect "X" windowing and video drivers as a deep career

Link to this post 07 Feb 11

Generally the screensaver settings in KDE are under, System Settings -> Desktop -> screensaver.

But if you wish to use xscreensaver instead you can append the screen you listed on the end of the /etc/X1/xinit/xinitrd.kde file, which will force it to start when any user logs into kde.

Link to this post 10 Feb 11

Generally the screensaver settings in KDE are under, System Settings -> Desktop -> screensaver.
sorry
nothing about screensaver there

But if you wish to use xscreensaver instead you can append the screen you listed on the end of the /etc/X1/xinit/xinitrd.kde file, which will force it to start when any user logs into kde.

close as I can get to that directory

[root@localhost xinit]# pwd
/etc/X11/xinit
[root@localhost xinit]# lsa
total 36
drwxr-xr-x. 5 root root 4096 Jan 9 15:45 ./
drwxr-xr-x. 7 root root 4096 Nov 17 01:08 ../
-rwxr-xr-x. 1 root root 2030 Aug 27 09:32 Xclients*
drwxr-xr-x. 2 root root 4096 Aug 27 09:32 Xclients.d/
-rwxr-xr-x. 1 root root 1486 Aug 27 09:32 xinitrc*
-rw-r--r--. 1 root root 1965 Aug 27 09:32 xinitrc-common
drwxr-xr-x. 2 root root 4096 Dec 25 13:00 xinitrc.d/
drwxr-xr-x. 2 root root 4096 Jan 9 15:44 xinput.d/
lrwxrwxrwx 1 root root 26 Jan 9 15:45 xinputrc -> /etc/alternatives/xinputrc
-rwxr-xr-x. 1 root root 3547 Aug 27 09:32 Xsession*

Link to this post 12 Apr 11

I've had problems w/Xscreensaver not loading automatically in the past and had to put "xscreensaver &" in one of these files:

~/.xsession (if using gdm/kdm/graphical login)

~/.xinitrc (if using startx from command line to start desktop GUI)

you can also use gconf-editor (GUI) or gconftool-2 (command line) to do it ...

-b

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board