Home Linux Community Forums Software Command Line Linux Dynamic library command help

Linux Dynamic library command help

Link to this post 10 Nov 10


i have created a program in c language to use dynamic libraries with it.

i have a main.c file in which i have created two functions(i.e. just calling those function from the lib.c file where they are fully defined) and lib.c which contain the full function implementation and have a iib.h which contain those two function declarations.

Now i have type the following command

gcc -fPIC -shared -o lib.c

gcc -o main main.c

After that i have copied the file to the /usr/lib directory

But now i am confused how do execute my program in a way that it calls the file in the /usr/lib at runtime and then my program works.

please help :) .



Link to this post 12 Nov 10

Two problem:

1. You need to name your shared library something other than Try where xyzzy is the name of your choice.
2. Your main problem is that you directly linked the .so file into your program, so it will look for it where it was when you linked the executable. You need to first copy the shared library to /usr/lib, and then use the option "-l xyzzy" to link the executable. IE: gcc -o main main.c -l xyzzy

Link to this post 16 Nov 10


Thanks for the reply, well its working now after renaming the file

here the steps i used to make it executable,

gcc -fPIC -shared -o libelectornic.c
gcc -o main main.c -L. -lelectronic -Wl, -rpath <path to the libraray>
chmod 777 main

Link to this post 17 Nov 10

Hi, again,

I am trying to do the makefile,

the files i currently have are main.c libelectronic.c libelectronic.h(this one is included in both main.c and libelectronic.c )

now i am not sure about the i.e. how do i define this shared library it for the make file.

please help me out.



Link to this post 18 Nov 10

Here is a quick example of a Makefile:

CC = gcc
HDRDIR = path-to-headers
LIBDIR = path-to-libraries
LIBLDFLAGS = -shared
LDFLAGS = -L $(LIBDIR) -l electronic

all: main

main: main.c
$(CC) $(CFLAGS) -o main main.c $(LDFLAGS) libelectronic.h libelectronic.c
$(CC) $(CFLAGS) $(LIBLDFLAGS) -o libelectronic.c

You don't need to run chmod on 'main' since the linker will make it executable for you. You don't need rpath. If you move, then you will need to put its location in the LD_LIBRARY_PATH environment variable, but you don't need to do that either if you put it in one of the standard library directories such as /usr/lib. Usually, for this sort of stuff you might want to put it in /usr/local/lib and set that in your LD_LIBRARY_PATH.

One final note. The indentations in the make file in the $(CC) lines HAS to be a tab character, not spaces, at least for most versions of make.

Link to this post 22 Nov 10

Thanks Rubberman for your reply, It helped me in understanding a lot :)

Also i make the makefile which is now working, here i am giving the path of the current directory where all the files are located and this is how i do it

all: program1

program1: main.c libelectronic.h
gcc -o program1 main.c -L. -lelectronic -Wl,-rpath . libelectronic.h libelectronic.c
gcc -fPIC -shared -o libelectronic.c

// Only here i am not sure how to do make install, since its in the same directory so i tried this but didn't worked

install : program1
mv testelectronic pwd

any idea about this.

Thank you


Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board