Linux.com

Home Linux Community Forums Software Command Line ssh X11 forward problem after reinstall

ssh X11 forward problem after reinstall

Link to this post 13 May 09

after Reinstalled my SLED10 the ssh X11 froward not work.
I try it:
connect : ssh root@remoted_computer
remoted computer: export DISPLAY="mycomputer:0"
om my computer: xterm remoted_computer

in my /etc/ssh/sshd_config file

X11 forwarding yes
X11 offset 10
:(
I tried with Xauth. not solve:(

Link to this post 14 May 09

Could be sytax; I'm not exactly sure how picky sshd is. Try changing the lines to:

X11Forwarding no
X11DisplayOffset 10

and restart sshd.

-mS

Link to this post 14 May 09

It sounds like something is backwards...

[local] $ ssh remote_host
[remote] $ xterm

The last line will display an xterm in your local computer. Your description sounds like you wish to display a window from your local computer in the remote computer, is that right? Also, ssh takes care of setting DISPLAY to the right value, you shouldn't need that.

Link to this post 14 May 09

use the -X (captial X) in your command. i.e: ssh -X root@remoted_computer

Link to this post 14 May 09

Based on what you wrote, you're trying to start a program on your local machine and have a program window show up on a remote computer. In order to do that, you have to allow external X11 connections on your remote system, you can use

on remote shell:> xhost + (will allow all hosts to connect)
or remote shell:> xhost (name of local system, must resolve correctly)

then on your local system, run

local shell:> export DISPLAY=`who am i | sed 's/.*(\(.*\)).*/\1/'`

after this, you should be able to run

local shell:> xterm

and it should pop up on your remote system.

Link to this post 14 May 09

after the export commands and display include xhost to allow server access of your computer

hope it helps. B)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board