Linux.com

Home Linux Community Forums Linux Distributions Debian Problem login in (LMDE) [SOLVED]

Problem login in (LMDE) [SOLVED]

Link to this post 29 Jan 11

Hi everybody, I searched on several forums and didn't find anything related to my problem so I hope someone here can help. I actually use Mint but it's the Debian edition s I hope this is the right forum.

I was trying to install japanese language support but I must have done something wrong because now I can't log in. At one point I had to restart the computer and now I get the login screen (when I used to login automatically), I type the password over and over again but I get the same login screen and can't get past that. I'm writing from my XP partition in the meantime but all my files and stuff from work are in the linux part so I can't get anything done.

Here's what I did, step by step, hoping someone can point out what I did wrong and how to get it right again.

Via synaptic installed anthy, scim, scim-anthy, scim-tables-ja, scim-bridge-agent and scim-bridge-client-gtk.
Then via terminal:

# dpkg-reconfigure locales

where I choose 'ja_JP.UTF-8' and hit enter. Then:
# gedit /etc/scim/global

and where it says 'SupportedUnicodeLocales' I added 'ja_JP.UTF-8'. Then:
# gedit /etc/scim/config

and where it says '/FrontEnd/X11/Dynamic = false' I changed false to true. Then:
# im-switch -s none

but as it turned out, 'im-switch' was not installed. I checked synaptic and instead I had 'im-config' installed so at the terminal I did:
# im-config -s none

This time a window showed up with options like 'use default', 'use scim', 'automatic', etc but rather than change something there I cancelled and went back to synaptic to install 'im-switch', which in turn had to uninstall 'im-config'. Then I went back to terminal and did:
# im-switch -s none

and apparently nothing hapenned so I thought it was okay, then restarted and that was it, now I can't log in.

Where did I go wrong? can someone help me correct it?

Thanks!

Link to this post 29 Jan 11

The first thing I would try would be to add a "3" to the kernel line at the grub screen, boot into run level 3, log in as root, then, try to undo the steps you listed here. Somehow, you probably changed the default language and when you type in your password it's not being recognized.
There may just be a conf file that needs to have a line changed, but, I haven't needed to switch or add languages for a while, so, I can't point you to that exact file.

Hopefully, someone else will see the post that can add more precise information.

Link to this post 30 Jan 11

Well, couldn't figure out what was wrong but undid my footsteps, uninstalled all that was related to scim, and now I'm able to log back in.

Thanks a lot for your reply.

Link to this post 30 Jan 11

Great news .. Have fun.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board