Home Linux Community Forums Hardware Drivers getting a USB2VGA to work

getting a USB2VGA to work

Link to this post 18 Sep 09

I recently bough a SheevaPlug Dev Kit and a USB2VGA adapter made by Startech in the hope of getting a cheap light PC to run at home for the very basics.

As i understand, these USBVGA devices are supported by the sisusbvga driver. The custom kernels for the Sheeva available online from various sources do not have the sisusbvga compiled into it. So i took the pain of compiling it myself.

But unfortunately I havent been able to get any kind of display on the USBVGA. Neither console nor X.

When starting X, it claims to not even find the device.

The for the device is "0711:5001 Magic Control Technology Corp. SVGA Adapter" (I added the SVGA Apater manually into the usb.ids file)

Could any one help me figure it out and get this thing working?


Link to this post 19 Sep 09

Moved one step further thanks to Mark Shinn from

Now the dongle gets detected on insertion and modules are autoloaded. However still no display :(

Off to explore more.. If any one can give any hints. Please do..

Link to this post 22 Sep 09

No Succes yet. but it seems like someone at OLPC managed to get their hands on the same identical piece of Hardware and has been trying to work on it with little success.

The developer (Samir) seemed to be discussing the drivers with some hardware vendors for more help in JAN

But there is no updates on it.

When I diffed his drivers they turned out to be sisusb driver with modifications.

Still No success.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board