Home Linux Community Forums Hardware Drivers Mounting USB wireless adapter and hard drive

Mounting USB wireless adapter and hard drive

Link to this post 23 May 10

Now my USB thumb drive will not mount and I have no sound, man,,,

And how do I post 2 images, every time I try I get 2 the same?

Link to this post 23 May 10

[file name=Screenshot_gnome_mount_2.png size=33078][/file]

Link to this post 23 May 10

Same message with my usb hard drive.

Link to this post 23 May 10

I'm glad the wireless is finally working! If you loaded a .inf-file with ndiswrapper, that means you made Linux load the Windows driver instead of using a native Linux driver. It seems like this solved your problems :-)

NetworkManager requires a system service in order to work; launch this system daemon before you try using NetworkManager again:

su -c "/etc/init.d/network-manager start"

As for the external harddrive, did you remember to install ntfs-3g? I'm not really sure why you're getting Access Denied errors, but since it's the second time we're having trouble with the automounting, I'm tempted to just create a static entry in /etc/fstab that explains once and for all how to mount your external harddrive ;-). Can you plug in the harddrive, and post the output of the following command:

ls -l /dev/disk/by-id/usb-*

There are two normal causes of audio problems. Install the package alsa-utils, and try running the command alsamixer in a terminal. If a volume control shows up, it means that your audio card is detected and probably just muted; in that case you can use the arrow keys to move between volume sliders (master, pcm, headphones, etc), and press the key "m" to mute/unmute and use up/down arrows to adjust the volume. If alsamixer fails, the problem is likely that the audio drivers aren't loaded yet.

OK, thanks so much for hanging in there with me.
No problem... And kudos to you too, you've been sticking at it for a week now. You don't seem like an easy quitter ;-)

Another possible reason you're having problems with the audio, is that you're not in the audio group. Try giving yourself these rights the same way you gave yourself rights to control network devices:

su -c "usermod -G audio jim"

Link to this post 24 May 10

debian:~# /etc/init.d/network-manager start
Starting network connection manager: NetworkManager.

still does not show up when I open the Network Manager Editor

This is not a BIG deal would just be nice to have it work.

Yes, I did install the ntfs-3g got that from the second or third reply here.

debian:~# ls -l /dev/disk/by-id/usb-*
lrwxrwxrwx 1 root root 9 2010-05-23 13:05 /dev/disk/by-id/usb-UT163_USB_Flash_Disk_00000000001055-0:0 -> ../../sda
lrwxrwxrwx 1 root root 10 2010-05-23 13:05 /dev/disk/by-id/usb-UT163_USB_Flash_Disk_00000000001055-0:0-part1 -> ../../sda1

still will not read my flashdrive or HD, it knows it is there, it IDs it fine even tells me the name of the drive.

Still does not work... it acts like it cannot find my sound card and this worked the first time I installed Linux.

debian:~# alsamixer
this seems to work.. but no sound.

When I click on the volume icon I get this.
[file name=Screenshot_gnome_volume_control_1.png size=11764][/file]

A quitter I am not, but do know when I have reached my end.. :cheer:
so am still hanging in here.....

Link to this post 24 May 10

BTW I am having real problems with adding pictures and files here, when I add 2 or 3 they all change to the last one I pick... what am I doing wrong?

[file name=Screenshot_Wireless_Networks_1.png size=22278][/file]

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board