Home Linux Community Forums Hardware Drivers Mounting USB wireless adapter and hard drive

Mounting USB wireless adapter and hard drive

Link to this post 16 May 10

We will need the model information for both device to help you. Also when they are plugged in can you please copy the results of the following commands for us to see what is detected.

sudo lshw
sudo lsusb
sudo lsmod
sudo fdisk -l

Link to this post 16 May 10

Very sorry.. Debian 5.0 I think not sure how to tell but I just loaded the current Debian install. Where can I find the exact install I have?

Thanks.. I installed the package called ntfs-3g. It still did not work, but the detail guide was great, the problem after installing package called ntfs-3g was the drive was not shutdown safely in windows, was using as a SATA drive. I hooked it up to windows as a USB and safely disconnected and then Linux found it and mounted not problem.

So the HD is is working thanks to this forum.

The USB wireless adapter
I thought I had it working but do not.. I am stupid and still have the cable plugged in LOL
The USB wireless adapter, is found by linux, it is identified, I can set up the configuration to my router, but it just sits there, it will not turn to try to connect, light does not even flash. I am getting no errors. Linksys WUSB54GC
It does everything, the wireless bars are at the top but it is just as if the adapter is not powered. This worked on this computer running windows, so I know it works.
Here is what the USB viewer shows me

Compact Wireless-G USB Adapter
Manufacturer: Cisco-Linksys
Speed: 480Mb/s (high)
USB Version: 2.00
Device Class: 00(>ifc )
Device Subclass: 00
Device Protocol: 00
Maximum Default Endpoint Size: 64
Number of Configurations: 1
Vendor Id: 13b1
Product Id: 0020
Revision Number: 0.01

Config Number: 1
Number of Interfaces: 1
Attributes: 80
MaxPower Needed: 300mA

Interface Number: 0
Name: rt73usb
Alternate Number: 0
Class: ff(vend.)
Sub Class: ff
Protocol: ff
Number of Endpoints: 2

Endpoint Address: 81
Direction: in
Attribute: 2
Type: Bulk
Max Packet Size: 512
Interval: 0ms

Endpoint Address: 01
Direction: out
Attribute: 2
Type: Bulk
Max Packet Size: 512
Interval: 0ms

Not sure to to look at for this.


Link to this post 16 May 10

I'm glad you got your harddrive working! So the problem was basically that the harddrive was not unmounted cleanly, and therefore Linux didn't want to mount it? (It is possible to force it to mount when this happens, but I think your solution of mounting it in Windows first is a better one.)

grammjr wrote:

Debian 5.0 I think not sure how to tell but I just loaded the current Debian install. Where can I find the exact install I have?
I think you've provided the information we needed, but for the record you can find the exact version you're using by running this command in a terminal:
lsb_release -d

As for the wireless, could you please try running the following in a terminal, and post the output here:

If the correct driver for your wireless adapter has not been loaded - meaning that Linux knows it is there, but not yet how to use it - all entries in the output should contain "no wireless extensions". If it has been loaded, the output might point us towards the source of error.

Link to this post 16 May 10

First I found the build info in the System Monitor. Sad thing is I had to take screen shot and then move it to my windows computer to convert it to a PDF so I could make it searchable to be able to copy and paste the info in here. :) Hopefully I will figure out to do that here in this Linux computer.
Release 5.0.4 (lenny)
Kernel Linux 2.6.26-2-686
GNOME 2.22.3
Memory: 504.1 MiB
Processor: Mobile I ntel(R) Pentium(R) 4 - M CPU 2.00GHz
System Status
Available disk space: 24.8 GiB

HD - yes once I installed the ntfs-3g, the issue then was the harddrive was not unmounted cleanly, it told me I could use the force unmount, but it was better to do a clean unmount from windows.

Wireless adapter.

debian:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


Link to this post 16 May 10

OK, that last output was very helpful. Apparently, Linux hasn't loaded the driver for your wireless adapter yet. According to a quick lookup on, the correct driver to load for WUSB54G adapters is p54usb. Can you open that terminal again, and try running the following command:

sudo modprobe p54usb
When you've done that, try rerunning iwconfig in your terminal to check if it worked. If it did, is it then possible to connect to your wireless router from the panel applet?

If the above works, you should make the driver load by default. To do that, first run the following command:

sudo gedit /etc/modules
That should bring up the file /etc/modules in gedit, a file that contains a list of drivers (kernel modules) to load when the system boots. To get the wireless driver mentioned above loaded automatically, add the following line to the end of the file and save it:

Hope this helps :)

Link to this post 17 May 10

debian:/home/jim/src# modprobe p54usb

debian:/home/jim/src# iwconfig

lo no wireless extensions.
eth0 no wireless extensions.
wmaster0 no wireless extensions.
wlan0 IEEE 802.11 ESSID:"Hey"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:BCFA-BDEA-CD
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

debian:/home/jim/src# gedit /etc/modules
cannot open display:
Run 'gedit --help' to see a full list of available command line options.
debian:/home/jim/src# gedit --help

I did get the p54usb in the modules file with the text editor, could not do it with the gedit command.
Rebooted and I get the same results.

Now what is missing.. :-) there is a space between gedit and /
also it acted like it was connecting, but the light still did not turn on and it did not connect.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board