Home Linux Community Forums Hardware Drivers Network interface is not recognized

Network interface is not recognized

Link to this post 16 Apr 12

Dear All
I searched a lot about my problem, but I have not found any solution about it. Would you please tell me what can I do or where should I ask this question?
I'm trying to install ZeroShell on a ClearBox(model: CAR-3000) but Zeroshell can not identify the network interface and says "No Network Interface".
I found no drivers for ClearBox network interface, so tried to install them, by copying /lib/modules files from ClearOS to Zeroshell, it did not work either.
Is there anyone who knows what should I do?

Link to this post 17 Apr 12

Can you please post the output of the command "uname -a" here so that we can identify the kernel and base system used on that appliance?

Link to this post 17 Apr 12

The whole results of running "uname -a":
Linux #1 SMP Thu May 14 23:12:00 CEST 2009 i686 GenuineIntel unknown GNU/Linux

Link to this post 17 Apr 12

Since you output has verified that it is a Linux based system, then the network card should be visible to all applications, so I would assume that the problem would be with the application or application configuration. I have no experience with zeroshell, so I think you should ask users of the application.

Have you tried asking the question in the zeroshell forum ( to get their input?

Link to this post 17 Apr 12

The OS can not recognize the Interface. It's a command base OS on server and when I want to see the interfaces, it says there is no interface!
Yes, I have posted on so different forum, includes that, but I have no got any answer yet.
Is there any global way to find drivers on an OS and copy them to another?

Link to this post 17 Apr 12

Thank you for that response, that gives much more information. You can use the "lspci -vvv" to list all motherboard and pci based hardware including the names of the kernel modules being used for each device. If the network card is not being recognized by the OS then it was not compiled into the kernel, which indicate that it was assumed to not be needed or that no kernel drivers are not available. If you can figure out the hardware chipset information for the lspci command then I will do my best to assist in locating the drivers.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>