Home Linux Community Forums Hardware Drivers problem with Wireless

problem with Wireless

Link to this post 18 Aug 09

yeah, you should read that

Link to this post 21 Aug 09

i try to use command ./load but it can't insert modules like this

tonjaa@tonjaa-desktop:~/Desktop$ cd module
tonjaa@tonjaa-desktop:~/Desktop/module$ ls
ieee80211_crypt_ccmp-rtl.ko ieee80211_crypt-rtl.ko ieee80211_crypt_tkip-rtl.ko ieee80211_crypt_wep-rtl.ko ieee80211-rtl.ko load r8187.ko unload
tonjaa@tonjaa-desktop:~/Desktop/module$ ./load
insmod: error inserting 'ieee80211_crypt-rtl.ko': -1 Operation not permitted
insmod: error inserting 'ieee80211_crypt_wep-rtl.ko': -1 Operation not permitted
insmod: error inserting 'ieee80211_crypt_tkip-rtl.ko': -1 Operation not permitted
insmod: error inserting 'ieee80211_crypt_ccmp-rtl.ko': -1 Operation not permitted
insmod: error inserting 'ieee80211-rtl.ko': -1 Operation not permitted
insmod: error inserting 'r8187.ko': -1 Operation not permitted
SIOCSIFFLAGS: Permission denied

what 's wrong how i can do it ?:huh:

Link to this post 21 Aug 09

You may not have support compiled into the kernel..
You may not be running the commands from root..
tonjaa@tonjaa:~/ < root?

to mount/umount a kernel module -- you need root.

1. Unpack source code of WPA supplicant:
tar -zxvf wpa_supplicant-0.3.8.tar.gz
cd wpa_supplicant-0.3.8

2. Create .config file:
cp defconfig .config

3. Edit .config file, uncomment the following line:

4. Build WPA supplicant:

-- you said you wanted to make it an 'access point' ?
you need to cd /usr/src/linux-2.x.x.x
ls -la | grep .config
if that's a good config
cp .config ../
make mrproper && make distclean
cp ../.config $PWD

make oldconfig && make menuconfig

-> Device Drivers -> Network Device Support ->
look around.. you May find your driver or generic support : )
'Wireless LAN support'.. might be worth doing this

Link to this post 25 Aug 09

thank you very much .

Link to this post 26 Aug 09

I have an Asus Mobo M2N32 Deluxe (wireless edition). When I purchased it I thought I could get the wifi working with Linux. It works like an access point, which I thought would be an interesting edition to my home network. I tried the 8187 driver (sorry, don't remember which one, but was never able to get it working properly. The disk that comes with the motherboard contains drivers, which I tried with ndiswrapper. I tried many 8187 drivers when using Debian and still didn't have luck. Maybe the Asus forums could help, but I think a Linux driver for this dongle is not available. Below is the info for the chip:

Bus 001 Device 003: ID 0bda:8187 Realtek Semiconductor Corp. RTL8187 Wireless Adapter

If anyone has any luck finding a driver that works with this, please let me know, I'd be happy to try it out.

Link to this post 29 Aug 09

on Ubuntu i try to install ndiswrapper by command
sudo apt-get install ndisgtk
and i find driver windows .inf for Realtek RTL8187 at first time
i think it's PCI type but i wrong. i find on web it's tell spec is USB.
and i find driver from web
then i add driver from windows wireless driver it's can use
in ad-hoc mode but it not have access point mode for choose .
i think it's ok . even through it's not good same use program on
windows i hope next time Linux can use all program from windows
thank you .;)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board