Home Linux Community Forums Linux Distributions Fedora wireless network is not working in fedora 14

wireless network is not working in fedora 14

Link to this post 30 Nov 10


I have installed fedora 14 two days back. Wireless netwrok is not working, but wired network is working fine. Could please help me on this.
Please let me know if any information is required.

[chakram@localhost ~]$ lspci | grep -i net
02:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)
[chakram@localhost ~]$

Thanks & Regards

Link to this post 30 Nov 10

It could be that you have not yet installed the necessary driver for the broadcom wifi card to work, please read the posts at which will tell you how to install the drivers.

Link to this post 01 Dec 10

As root,
yum install akmod-wl
Make sure you have the correct kernel-devel file installed first.
yum install kernel-PAE-devel if your using a PAE kernel.

Link to this post 03 Dec 10

On current systems, you may need either a driver, the firmware for the wireless chip set, or both. I had a similar problem with my Dell laptop. The wireless worked with Jaunty (9.04) out-of-the-box, but with Meerkat (10.10) I had to install the driver and firmware. Go figure! Possibly the issue was that the firmware is proprietary in many cases (Broadcom chip sets, for instance) and are not open sourced.

Link to this post 14 Dec 10

Have you tried a different network manager? I reccomend WiCD over gnome network manager. It has better options and its lighter. I love how it saves Wireless passwords and wireless settings, less hassel. google it!

Link to this post 16 Dec 10

Hi ,

I followed the below steps mentioned at the URL :

1 su -
2 yum install b43-fwcutter wget

Next, download the Windows driver:
3. wget

Next decompress, extract and copy firmware to /lib/firmware directory.
4. tar xjf broadcom-wl-
5. cd broadcom-wl-
6. b43-fwcutter -w /lib/firmware/ wl_apsta_mimo.o

Please find the detailed output below.

[chakram@localhost ~]$ su
[root@localhost chakram]# yum install b43-fwcutter wget
Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Setting up Install Process
Package b43-fwcutter-013-2.fc14.i686 already installed and latest version
No package get available.
Nothing to do
[root@localhost chakram]# wget
--2010-11-30 16:49:35--
Connecting to||:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3888794 (3.7M) [text/plain]
Saving to: “broadcom-wl-”

100%[======================================>] 3,888,794 15.4K/s in 5m 17s

2010-11-30 16:55:07 (12.0 KB/s) - “broadcom-wl-” saved [3888794/3888794]

[root@localhost chakram]# tar xjf broadcom-wl-
[root@localhost chakram]# cd broadcom-wl-
[root@localhost driver]# b43-fwcutter -w /lib/firmware/ wl_apsta_mimo.o
This file is recognised as:
ID : FW13
filename : wl_apsta_mimo.o
version : 410.2160
MD5 : cb8d70972b885b1f8883b943c0261a3c
Extracting b43/pcm5.fw
Extracting b43/ucode15.fw
Extracting b43/ucode14.fw
Extracting b43/ucode13.fw
Extracting b43/ucode11.fw
Extracting b43/ucode9.fw
Extracting b43/ucode5.fw
Extracting b43/lp0bsinitvals15.fw
Extracting b43/lp0initvals15.fw
Extracting b43/lp0bsinitvals14.fw
Extracting b43/lp0initvals14.fw
Extracting b43/a0g1bsinitvals13.fw
Extracting b43/a0g1initvals13.fw
Extracting b43/b0g0bsinitvals13.fw
Extracting b43/b0g0initvals13.fw
Extracting b43/lp0bsinitvals13.fw
Extracting b43/lp0initvals13.fw
Extracting b43/n0absinitvals11.fw
Extracting b43/n0bsinitvals11.fw
Extracting b43/n0initvals11.fw
Extracting b43/a0g1bsinitvals9.fw
Extracting b43/a0g0bsinitvals9.fw
Extracting b43/a0g1initvals9.fw
Extracting b43/a0g0initvals9.fw
Extracting b43/b0g0bsinitvals9.fw
Extracting b43/b0g0initvals9.fw
Extracting b43/a0g1bsinitvals5.fw
Extracting b43/a0g0bsinitvals5.fw
Extracting b43/a0g1initvals5.fw
Extracting b43/a0g0initvals5.fw
Extracting b43/b0g0bsinitvals5.fw
Extracting b43/b0g0initvals5.fw
[root@localhost driver]#

Now it is working fine. Thank you all.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>