Linux.com

Home Linux Community Forums New to Linux Getting Started with Linux apache make httpd cannot allocate memory

apache make httpd cannot allocate memory

Link to this post 18 Jan 12

I would assume that the linux-utils and utils-linux are the same, can you pleas tell us what distro you are using so we can confirm the contents?

As for the swapon command, can you please paste the error message or tell us what it does when that command fails?

can you please tell me the steps and errors messages that resulted when you followed by script? I am curious about the naming conventions you use and to verify that your instructions are all pointing to the same source.

Link to this post 19 Jan 12

Godaddy probable remove the suport for that in it's binaries. That's why I suggested to recompile linux-utils (or util-linux)

Regards

Link to this post 28 Apr 12

Hello! I got distracted from this for a while, but I'm getting back to it.

I'm looking up the util-linux package to learn what to do,but I have a question that I hope would save me some unnecessarily lost time.

On my server, I have util-linux-ng.i686 rpm package installed (it shows up in yum list installed; it came that way on the machine). So I think I ought to uninstall that package (yum remove), then compile and install the new util-linux (from https://github.com/karelzak/util-linux?) - correct?

Link to this post 29 Apr 12

See http://en.wikipedia.org/wiki/Util-linux

The util-linux-ng package is a standard package, installed by default on RHEL 6.x and clones. Your server indicates that. Don't bother, unless there is something that you really need from the one you are proposing to install.

Link to this post 25 Jul 12

Eh...so I learned how to compile util-linux. Then I figured I'd remove the one from the package manager, and then drop-in my new one. But when I ran yum, it removed everything! Well, it removed a lot of stuff, destroying my ability to sudo or remote terminal.

At the moment, I'm working on getting my machine back to normal, but in the mean time, is there an option or prompt for yum remove that I missed? Also, I suspect many programs may be expecting a certain version of the util-linux files, and therefore fail, but this I'm really uncertain of.

Link to this post 25 Jul 12

That package has a lot of stuff that other components of the operating system required for most normal use, so it is listed as a dependency in those other packages. As a result, when you removed util-linux, you removed all the dependent stuff as well, resulting in ... well, now you know. This is why yum, as a default, will list what it is going to install or remove and then ask if you want to continue the operation.

Unfortunately there is no quick fix for this except to reinstall the OS. You can install all the removed packages manually, but that will take a LOT longer than a simple reinstall/repair. Some installers will let you repair the installation, re-installing the default package set without munging current configurations of other stuff in /etc for example. In any case, you will have a lot of work to do to get back to where you were.

My recommendation in such cases is not to uninstall the package in question, but to install it in /usr (the default --prefix option for source packages is /usr/local, normally). If that causes problems, then you can fix that with a simple "yum reinstall util-linux" command. That will restore the default system version of those applications and such.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board