Linux.com

Linux refuses to install?

Link to this post 10 Jun 09

xaoxoa wrote:

please someone help!

I assume these are booting into graphical mode? Have you tried booting into text mode? With the F11 DVD, when the boot prompt first comes up, hit the <Tab> key and add " text" to the end of the line. Then hit [Enter] to boot. At least I can do this with the regular F10 Install DVD, not sure if the Live CD is different...

Also, can you get into a Virtual Terminal? You do that by hitting Ctrl-Alt-F2, Ctrl-Alt-F3, Ctrl-Alt-F4, etc. Maybe there is something more indicative of the problem there.

Link to this post 10 Jun 09

Well, I think I know what the problem is, but I don't know how to fix it. When I boot from a distro, I get an error message about the PCI and an error about updating the BAR or something, and then tow hex codes like ddf0000 and fdf0000 or something.

Link to this post 11 Jun 09

Hello again,

I would have to summize that it's a problem with that fedora's or Ubuntu's distro cd/dvd . Download something like Crunchbang it's based on Ubuntu but's it installs differently. I had the some problems myself with their dvd/cd's trying to install and freezing.
you could also try PClinuxOS or MINT they also booted fine on my machine.
Dam Small Linux also booted fine. There are as many Distro's out their as their are colors in the rainbow , don't get stuck on one distro. Heck Debian you can download the network installer and just download about 50 mgs and then install the rest over the internet.

Link to this post 11 Jun 09

Absolutely NO version of Linux wants to work. Should I try disconnecting my PCI's? (See my previous post)

Link to this post 11 Jun 09

It's a strong likelihood that you need to modify some bios settings in order to run linux. Also, the Compaq Presarios are known to be unfriendly to most systems except Windows. Also, you might want to go onto the HP web site and see if they have an updated bios/firmware package to install.

Link to this post 11 Jun 09

xaoxoa wrote:

Absolutely NO version of Linux wants to work. Should I try disconnecting my PCI's? (See my previous post)

Worth a shot - try adding this to the boot cmdline:

 pci=off

see the whole shlmeal of boot-time kernel parameters here:
http://www.kernel.org/doc/Documentation/kernel-parameters.txt

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board