No audio in 9.04

Link to this post 30 Aug 09


I recently bought a HP Pavilion dv3 2103tx laptop.

It has a IDT audio device. I managed to get the sound in 8.10 by using the following command
$ sudo echo "options snd-hda-intel enable_msi=1" >> /etc/modprobe.d/alsa-base

But what ever I did till now, there is no sound in 9.04!
I installed latest alsa in both the following options.
1$ ./configure --with-cards=hda-intel --with-isapnp=no
2$ ./configure --with-sequencer=yes

Still no sound.

Additional info follows...

$lspci | grep audio
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)

$cat /proc/asound/card0/codec#* | grep Codec
Codec: IDT 92HD75B2X5
Codec: Nvidia ID 3

Please suggest a way ASAP to get the sound in 9.04.

Thank you.

Link to this post 01 Sep 09

Just curious, have you tried switching from ALSA to OSS?

System -> Preferences -> Sound.

Change all the settings from ALSA to OSS.

Also, sometimes after an upgrade the ALSA ends up having the master channel mixer muted. Have you checked "alsamixer" to see what the sliders are set to?

What kernel version are you currently running? (uname -a)

There are a couple of things that have resolved the issue for people on the ubuntuforums...adding to the modprobe.conf:

options snd-pcsp index=-2
options snd slots=snd-hda-intel
options snd-hda-intel model=hp-m4
alias snd-card-0 snd-hda-intel
options snd-hda-intel enable_msi=1


options snd-hda-intel model=hp-m4 enable=1 index=0
options snd-hda-intel enable_msi=1


Hopefully that might help a little. :)

Link to this post 11 Sep 09

My kernel version is 2.6.28-15-generic
I tried the method you said. But there was no file in /etc with the name modprobe.conf. There are only modprobe.d directory and modules file

Link to this post 11 Sep 09

The files in modprobe.d are used to modify the modules now. modprobe.conf is depreciated.

I recommend checking out /etc/modprobe.d/alsa-base.conf

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>