Home Linux Community Forums Hardware I/O Devices Untraceable problem with minicom

Untraceable problem with minicom

Link to this post 09 Jan 11

Dear all,

I am facing an untraceable problem with minicom. Allow me to provide proper details so that it will be easier to provide assistance.

I am using a desktop PC with Ubuntu 10.10. It has only one serial port (ttyS0) and I have verified that using the command " dmesg | grep tty ".

My development board is called HDP6410, which is a clone of the SMDK6410. The processor is S3C6410 with ARM 1176 JZ(F)-S core. After I start minicom, when I connect the board to the pc using a null-modem cable and power up the board I am supposed to see booting updates on minicom, followed by a prompt that would allow me to access the board. However, I do not see anything. I know that the serial port on the pc and the serial cable are fully functional because I do get all the booting updates and prompt when I use a custom serial communication software provided with the board. However, I want to use minicom because the custom software provides no means of transferring files.

I added my username to the following groups : dialout, uucp and tty.

I have also checked that ttyS0 has read/write permissions.

My settings in minicom are as follows:

Serial Device : /dev/ttyS0
Lockfile Location : /var/lock
Bps / Par / Bits : 115200 8N1
hardware flow control : no
software flow control : no

I have tried running minicom both as normal user and root, but I still get no output on the console when I power up the board. I know for sure that the serial port on the board is working fine and it does send messages once I power up the board. Something is wrong on the PC side. For some reason when I run minicom, the connection is probably not established on the PC side.

Am I missing any essential configurations / settings ?

I would highly appreciated some guidance on this. I have been trying for a week now without any positive result. Please help.


Link to this post 10 Jan 11

Please do not post the same question in 2 different forums, it just makes more work for the moderators. I'll leave this post since it is hardware related and remove the other post. Thanks, hopefully, someone will come along shortly that has experience with your problem.

Link to this post 13 Jan 11

I have an ARM board that I use for embedded development that uses the serial port for console access. Are you sure that the port settings in minicom are correct. I have had to remember to set up the connection properly in the past for much the same reason as you are experiencing.

Also, you don't need to run minicom as root, normally. What does the board documentation say about baud rate, etc? In many cases, it may default to 9600 or 19200 instead of the 115200 that you are using.

Link to this post 14 Jan 11

To Rubberman,

The baud rate is correct; it is 115200. I know this because when I use the custom software the boot messages show that the baud rate for the UART on the board is 115200, hence the baud rate on minicom should be the same.

As for the other settings, I have already provided the details of the settings I make in minicom. Are there any mistakes there? Am I missing any other steps?

Link to this post 11 Apr 11

Have you set the device's baud rate manually? Check it first with:

stty -F /dev/ttyS0

it'll say speed 9600 baud, etc., etc.

If it doesn't look right, then set it w/the same utility, e.g.:

stty -F /dev/ttyS0 115200

If you then try minicom and it STILL doesn't work, i've found resetting the device with the following command sometimes helps:

stty -F /dev/ttyS0 sane



Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board