64-bit CPU confusion

Link to this post 18 Oct 11

I have hit a bit of a confusing point while trying to virtualize Gentoo and Slackware under QEMU+XEN and VirtualBox.
Whenever I try to run them, they report an error saying that my CPU doesn't support 64-bit instructions, yet I am using OpenSUSE 64-bit (Native) without any errors or issues.
Any thoughts on what I should do?

Link to this post 18 Oct 11

Maybe your qemu configuration is not 64bits ready?


Link to this post 18 Oct 11

Did enable virtualization in your bios?

Link to this post 18 Oct 11

I tried to append "-cpu qemu64" to the program and still no go. I also built qemu from source.

I don't think my CPU has virtualization instructions, but I have successfully virtualized 32-bit OSes before

FYI: I have a Intel Pentium D 820 dual-core CPU

Link to this post 18 Oct 11

Should I just burn a DVD and see what result I get? And if it works, install them naitive? (I have LOTS of disk space on my HDD)

Link to this post 18 Oct 11

You need to check your BIOS and see if you can find an option for virtualization and enable it if you do have this option. If you do not have this option than your cpu does not officially support virtualization and could be the reason your having weird issues such as being successful in 32 bit but not 64 bit.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>