Linux.com

apache 64??

Link to this post 29 Dec 11

is there a 64bit version of apache, or is there anyway to stop it from giving "unknown-linux-gnu" error ??

Link to this post 29 Dec 11

willettwork,

Are you running Fedora as your sig says?

If so is there a reason that you cannot use yum to install apache? That will get you a 64bit compatible httpd.

-MM

Link to this post 29 Dec 11

willettwork,
Please try the application packages from your distro's online repos before attempt to custom build an application from source and before trying the installers from the applications' websites.

Fedora does have a properly compiled apache-http package titles httpd (https://admin.fedoraproject.org/pkgdb/acls/name/httpd?_csrf_token=c60b0529c55e8ec97d714bae7654042a2e773205) , you can find it in the yum repos.

Link to this post 30 Dec 11

I must thank you for your responses. This is the best place for answers.

Mfillpot: I did try the distros for mysql php etc. and could not get php to work. I may have missed something so I'm still looking

MM you hit on part of the issue. If fedora has something else I will try to get that going. httpd ok

You may give me better answers if you know what my goal is. I hope to get back into php scripting, as well as other web stuff. I hope to be able to write php scripts and test them before FTPing them to a server. I need mysql and php, I don't need to set up a web server on my computer, unless I need it to get PHP to work.

Like I said I have loaded mysql, apache, and php from add/remove. It did not work. 'Ask Fedora' did not give any answers to what more I could do. I googled it and was following what I found. if you can give me a better path that is what I'm looking for.

thanx again for your responses.

Link to this post 30 Dec 11

Now that we know the goal it is easier to hep. I do not use fedora, but the steps used to configure lamp on slackware will be similar. You can find some instructions at http://www.linuxquestions.org/linux/answers/Applications_GUI_Multimedia/Slackware_guide_for_AMP_Apache_MySQL_and_PHP

I have a feeling that your php issues was from not uncommenting the line "Include /etc/apache2/mod_php.conf" in the httpd.conf file. That line is what tells httpd to use the php module.

Link to this post 30 Dec 11

where is the httpd.cnf file?
was the apache install suppose to make an apache2 directory, or httpd?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board