Home Linux Community Forums Software Installation Can not access slave drive

Can not access slave drive

Link to this post 13 Dec 12

I'm unable to access the slave drive on my desktop when I run Ubuntu 12.04. My desktop machine has 2 x 80Gig HDD. I ran Gparted and formatted and cleaned the drives before installing 12.04. However I can see it on my desktop but when I try and copy files to it it tells me I don't have permission. I'm new to Linux and want to learn.

Kind regards


Link to this post 17 Dec 12

Hey Jho,

I'm sorry that getting a reply to your question was this unbearably slow, but I didn't know how to answer your question and I was REALLY hoping a system moderator would come over and help you. (Not that they couldn't, they're probably just really busy.) I'll do my best, but I am NOT a Linux Guru, I've just played around with computers for a while. So my information may or may not be correct.

You have to understand that Linux does not treat permissions like Windows (or to a lesser extent, Mac). What's probably happening is that you don't have the authority to access another OS: it sees the second hard drive as its own independent computer. It doesn't know that it's really part of the same computer. You running Gparted is irrelevant, it just allows you to partition drives while the desktop is up. It doesn't "link up" the two drives together. So, really, you have no slave drive at all, just two separate independent drives.

What I would recommend is kind of the lazy man's out, but is SHOULD still work. I would only install Ubuntu on only one of the drives. (This will be your master drive), then only install an ext4 filesystem on the other WITH NO OS!

That way, your makeshift "master drive" can still operate as normal, and you can move files around on the other hard drive. Please let me know if this helps, I'd be glad to do what I can.


Link to this post 17 Dec 12

Each new partition defaults to giving only root write access to the contents unless you have set the fstab file to mount the file partition with user access that can fix your problem. However the simplest approach would be to use sudo to create a new directory within the partition and set the permissions to 777 which is read,write,executable for all users.

Link to this post 17 Dec 12

Mfillpot has spoken, my argument is invalid. LOL

Link to this post 17 Dec 12

I am sorry that I had not responded earler, I don't check the forum often.

Izzy, I am subscribed to get e-mails for all of your posts, if you think I can help call me out in a post and I will respond within a day. Thanks for trying to help everyone and I hope you learn a lot.

Link to this post 17 Dec 12

No problem, I'm glad I can help. I didn't know that you didn't check the forum often, I just thought that you got bogged down. I'll definitely flag you down the next time someone needs you. Have a good one.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>