Linux.com

Home Linux Community Forums Software Installation Error 18 with grub 0.97

Error 18 with grub 0.97

Link to this post 18 May 09

Hi Folks,

I've just installed ubuntu 9.04 for my mum, having spent a good couple of years pulling her in the right direction by getting her to use Open Source apps on Windows, but every second (or so) boot I get the dreaded 'Error 18'.

I refuse to believe the BIOS is old enough to suffer the 'trying to put executable code >1023 cylinders' problem, and there's no option to use anything freaky like Bit-Shifting, which seems to me that it's using (normal) LBA translation.

The board she's now using was working fine with grub installed after an 80GB Windows 7 partion (yeah, i know, but we have to know what to expect before the lusers get hold of it...) on a SATA disc, proving that it's not a >1023cyls problem.

I know grub in ubuntu has been updated recently, and i was wondering if anyone else is seeing this problem in other recent distros. It is reporting itself as being version 0.97.

It's an old PATA disk in the machine now, but surely this shouldn't matter as it's still disk 0x80 (and it wouldn't have got that far if that was the problem - only one disk in there anyway!) ?

Also, the ext3 is the first partition on the disk too.

This is an unfortunate show stopper for someone who is not technical at all (she will have to keep powring off and on the machine until it actually boots!), and potentially a huge barrier to getting folks on the platform :(

Link to this post 18 May 09

Richard,

Can you post the output of:

momsputer@ubuntu:~# fdisk -l

and

momsputer@ubuntu:~$ cat /boot/grub/menu.lst

That would be helpful.

Link to this post 18 May 09

It sounds more like a hardware problem than a coding problem. I'm not too awful sure that posting her grub configuration would solve much in that category.

If it is though; I'd be surprised.

Link to this post 18 May 09

new Linux user, for new linux system.

Reinstall fresh copy of ubuntu jaunty and it will be ok.

B)

Link to this post 19 May 09

I wanted to see the fdisk output to see what the partitions actually looked like. And I always like to see the menu.lst because quite often just a faulty partition entry (hd0,1 or whatever) will give an Error 18.

Link to this post 26 May 09

Ta for the offer of help Eric, but I tar'ed the system over to a new (SATA) disk, including a 512mb /boot partition (lots of copying and pasting of UUIDs, joy...), and it works perfectly now. Easier than a reinstall as i had done some custom config, plus I would have had to backup her home directory.

What prompted me to do that was that i suddenly started getting 'Error 16 : inconsistent Filesystem Structure', despite booting another system and doing fsck -fy. I dunno what was causing it, as like i said it should have been using LBA - it's an Intel 945GZ, so new enough to not suffer the >1023cylinders problem. Oh and it wasn't like i was trying to boot a logical partition either :/ So i think you are right Gossamer, it was some sort of hardware issue.

This sort of thing is a potential showstopper for noobs if it rears it's head on their config though :(.

You gotta wonder sometimes if folks like abrenar actually read your post :P

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board