how to install pacgen

Link to this post 21 Mar 10

I am a newbie to linux.I am trying to install pacgen to generate that have a programmable time interval between them.
The steps to install pacgen are as follows:
1. Make sure you have Libnet installed, pacgen was written with
installed. Goto or somewhere else and get it.

2. Read the README file

3. Compile via the libnet-config script (at least this is how I did it):

gcc `libnet-config --cflags --defines` pacgen.c -o pacgen \
`libnet-config --libs`

But when I type the command ,I get the following error
[sabagour03@sabanyupoly pacgen-1.10]$ gcc `libnet-config --cflags --defines` pacgen.c -o pacgen `libnet-config --libs`
bash: libnet-config: command not found
bash: libnet-config: command not found
/tmp/ccRE2XbO.o: In function `main':
pacgen.c:(.text+0x24): undefined reference to `libnet_init'
pacgen.c:(.text+0x214): undefined reference to `libnet_build_tcp'
pacgen.c:(.text+0x239): undefined reference to `libnet_geterror'
pacgen.c:(.text+0x2c9): undefined reference to `libnet_build_udp'
pacgen.c:(.text+0x2ee): undefined reference to `libnet_geterror'
pacgen.c:(.text+0x3d0): undefined reference to `libnet_build_ipv4'
pacgen.c:(.text+0x3ec): undefined reference to `libnet_geterror'
pacgen.c:(.text+0x450): undefined reference to `libnet_build_ethernet'
pacgen.c:(.text+0x46c): undefined reference to `libnet_geterror'
pacgen.c:(.text+0x4fc): undefined reference to `libnet_write'
pacgen.c:(.text+0x59c): undefined reference to `libnet_destroy'
pacgen.c:(.text+0x5a9): undefined reference to `libnet_destroy'
/tmp/ccRE2XbO.o: In function `load_ip':
pacgen.c:(.text+0xf49): undefined reference to `libnet_name2addr4'
pacgen.c:(.text+0xf6d): undefined reference to `libnet_name2addr4'
collect2: ld returned 1 exit status

I would be happy to receive any information or instructions on installing pacgen.Please can you suggest packet injection tools that have programmable time intervals between packets.

Regards to all

Link to this post 22 Mar 10

Ok, a few questions need to be answered for us to assist.

What linux distribution and version are you running?
what does the output of "gcc -v" (without quotes) show when run from the command line?

Link to this post 22 Mar 10

The distribution and version of linux I am using is:
Linux version (mockbuild@x86-07.phx2.fedoraproject.
org) (gcc version 4.4.3 20100127 (Red Hat 4.4.3-4) (GCC) ) #1 SMP Thu Feb 11 07:
39:11 UTC 2010

Output of gcc -v is:
[sabagour03@sabanyupoly ~]$ gcc -v
Using built-in specs.
Target: i686-redhat-linux
Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl= --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --enable-plugin --with-java-home=/usr/lib/jvm/java-1.5.0-gcj- --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch=i686 --build=i686-redhat-linux
Thread model: posix
gcc version 4.4.3 20100127 (Red Hat 4.4.3-4) (GCC)

Link to this post 22 Mar 10

Ok, you are using Fedora Core 12.0 and GCC 4.4.3.

The gcc version explains your issues, starting with gcc 4.4 the application is enforcing tougher coding requirements, issues which were ignored in prior releases are now stopping the build process. The primary issue with your attempt is that the developers of the app have not yet cleaning it to gcc 4.4 specs so the app will not build on gcc 4.4 until the code is cleaned up by the author(s).

The only way to install it now would be to find a package that was compiled on a previous version of gcc and install ti thought the package manager. I have checked google for a package and have not found one yet.

Can someone on Fedora either find a package for Saba or build it themselves and post a link to it here? This issue is quite widespread and a package will help several users.

Link to this post 23 Mar 10

Doesn't Saba also have the option of installing an older version of gcc?

Link to this post 23 Mar 10

gomer wrote:

Doesn't Saba also have the option of installing an older version of gcc?

That may be an option, it really matters if the Fedora project group has an older version available and if he has anything installed that explicitly needs gcc 4.4.X

I have the same issue with my Slackware-current installation, my answer for compiling packages such as that is to compile them on my slackware-13.0 system which is using an older version of gcc.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board