Linux.com

Home Linux Community Forums Software Installation Long delay before Acer welcome screen

Long delay before Acer welcome screen

Link to this post 24 May 10

Hi All,

have just made the changover to Linux and am having some problems. I hope someone here can shed some light on this for me.

Just bought a new laptop last week, an ACER Aspire 7741G, i5, 64 Bit, 4Gb RAM etc.. The first thing I did was to make the Win7 recovery cds, after which I installed linux UBUNTU 10.04 overwriting all partitions. UBUNTU works wonderfully, all hardware was recognised immediately without any problems. Here however is the situation I now have:

1- When powering on the laptop there is a delay of about 2 minutes before the ACER welcome screen is shown where I have the chance to get into the BIOS. After this the computer bots I would say normally. As this happens before I even get to the ACER welcome screen I can only assume that it has nothing to do with the OS but rather the BIOS. UBUNTU seems to have overwritten something here.

2- It is not possible to install windows from the recovery cds i made. It starts the installation but then just hangs. Have seen a few threads on the web where people have had the same problem.

Problem 2 is not so important for me, the priority is getting problem one solved, the elimination of this agonising 2 minute wait when booting.

Please try to keep any suggestions or explanations as simple as possible to avoid any confusion.


Thanks in advance for your support.
Martin

Link to this post 24 May 10

Martin,
Welcome to the site and thank you for moving the discussion here from our e-mail conversation, publicly working through this will help other who encounter the same issue.

The information below is exactly what I e-mailed to you, I posted it here so others know what I recommended.

I have been thinking further about your issue, it is definitely not associated with the operating system, installed another OS will not effect the issue in any way. Can you please tell me when this problem started happening and if any event is attached to the start of the issue?

The first things that you should do to attempt to find and correct the issue are:
[ol][li]Run memcheck from the ubuntu installer disk to test your RAM and see if it is corrupted or flawed.[/li]
[li]Get the 1.09a BIOS update and install it, there should be an option to install it from a USB driver or some other similar method, if the option does not exist then most likely it has an installer program that run in Windows.[/li]
[li]Enter the BIOS setup page and look for the options and fastboot and memory testing/verification and change the settings from the current settings.[/li][/ol]

Link to this post 24 May 10

Hi there, thanks for the quick response. Just a few comments on your points:

1- Running memcheck is no problem. Will do that first and will advise of the results.
2- BIOS Update. I have already downloaded the BIOS update from the ACER website, but have absolutely no idea how to install it. An idiots guide here would be appreciated. I now only have UBUNTU 10.04 on the laptop, no windows.
3- Sorry, did not understand this at all.

Thanks
MArtin

Link to this post 24 May 10

Update on the Memcheck.

I started from the UBUNTU 64 Bit install cd, but unfortunately there is not an option for Memcheck. The only two options I have are to try UBUNTU (live option), or a complete install.

Waiting for instructions on the BIOS update. The update 1.09 which I downloaded from the ACER site is titled windows. There is a readme included which says I should doubleclick on the .bat file included.

Regards
Martin

Link to this post 24 May 10

I found a blog post where someone was able to update the bios without
having windows installed, check out
http://chunkmedia.co.uk/2009/09/23/acer-aspire-one-update-bios-using-linux/
for information.

Ok, since memtest is not an option in 10.04, it may be an option in
the grub bootloader prompt that is already installed on your system,
if not then you may want to checkout ultimate Boot CD
(http://www.ultimatebootcd.com/), that disk contains memtest and many
other utilities that can help you to diagnose and potentially correct
many hardware issues.

Link to this post 28 May 10

Hi All, got alot to report, but still no solution. I can say what has NOT worked until now:

- since my last post I also had a response from ACER support. They told me this laptop does not support dual boot, or booting over an existing OS. They told me to use fdisk and completely delete all partitions, and reset the mbr. Did this, but has not helped.

- have upgraded the BIOS successfully but has not helped

- tried the ultimate boot cd, but cannot carry out a memory test. tried, but the computer reboots before the test is finished. tried this with all 4 different tests available on the cd. Have also tried a Memtest from Opensuse install dvd, same shutdown problem.

- looked in the bios, but there are no settings for starup selftest options to play with.

Still in the same boat im afraid. Any suggestions?

Thanks & Regards
MArtin

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board