Linux.com

Home Linux Community Forums Software Installation Problem installing ubuntu server

Problem installing ubuntu server

Link to this post 16 Jan 12

Yay had some success with this i have now got linux ubuntu server succesfully intalled on the tower although as earlirt suggested it seems i have no internet connectivity i have tried with dhcp and also with setting to static ip but nothing i do seems to get it online i have tried to ping google but it wont ping

i use these instructions to set to static

1. give your server a static ip. put this line in and press enter

nano /etc/network/interfaces

change the dhcp to static then under it put like this
address 192.168.1.78
netmask 255.255.255.0
broadcast 192.168.1.78
gateway 192.168.1.254

ofcourse these are my ips so please change to your own ips

once done hold ctrl+x press y then enter
now to restart network put this line in

/etc/init.d/networking restart

but the restart fails

Link to this post 16 Jan 12

It still sounds like the ethernet device either is not registering a driver or that the driver may have issues. Can you please try the command "sudo lspci -vvv|grep -i ethernet -A 35". This will check your pci hardware and output the 35 lines following lines matching the word ethernet, you can adjust the number 35 to how ever many lines are necessary to get to a blank line following the end of the description.

Once you get that information, please paste it here so we know what hardware you are using and what driver is in use.

Link to this post 16 Jan 12

yay have finally got this sorted the problem was a typo in the interfaces file

auto eth0
iface eth0 inet did read

auto eth0
iface eth0 unet static

so i changed it to inet and its all working now

thanks everyone who contributed in suggestions :)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board