Linux.com

Home Linux Community Forums Software Installation Suggested OS for Compaq Armada 1592 DMT, heavily trimmed down

Suggested OS for Compaq Armada 1592 DMT, heavily trimmed down

Link to this post 06 Nov 11

Another thing, if you are to use a gui, use openbox or fluxbox. Openbox is compatible with GTK+ with is what gnome is built on. So can run most apps designed for GnomeX.

Link to this post 06 Nov 11

I have the answer for you I believe. You need to look into a distribution called "Damn Small Linux" With a graphical user interface it has a system requirement of only 24 megabytes which your actually over that. Here is the site to the wiki with the system requirements: http://www.damnsmalllinux.org/wiki/index.php/Minimum_Hardware_Requirements

Here is the link to download DSL: http://www.damnsmalllinux.org/download.html

The goal of DSL was to remain no larger then 50MB and give people a light, easy to use interface. I have not used this personally, but with it having such a low system requirement WITH their GUI. I believe you should very well look into it and try it out.

Let me know how it works out for you.

Link to this post 06 Nov 11

Also, in your case i'd make sure I made my swap partition first on your drive and being as generous with it as possible.

Link to this post 08 Nov 11

I tried DSL on an OLD toshiba laptop with 128mb of ram. This was the one I couldn't remember. The GUI is not all that great, yet good enough. It's better used as a terminal.

Link to this post 12 Nov 11

DSL sounds great, except the links to the downloads are mostly shot. Most of them are gone, the other two expect me to know how to compile. I've yet to figure that out on my system, and it'd really be much easier if there were an already compiled version hanging around somewhere. Would you mind posting a link to that?
Also, there is a 128 mb ram chip that could be installed if the stupid machine would recognize it, though that may be a problem with the operating system and not actual hardware incompatibility. I prefer to use a GUI, having used Windows all my life the terminal's more than a little intimidating.

Link to this post 12 Nov 11

Here is a live link: http://ftp.belnet.be/packages/damnsmalllinux/current/

You want the dsl-4.4.10.iso and dsl-4.4.10.iso.md5.txt files, along with the 1-readme_first.txt file and probably the contents of the documentation folder. Burn the .iso file to a CD and use that to boot the system you are going to install it on. That is the installer, and no building should be necessary at this point to get a functioning system.

Also, here is the root to the DSL repository: http://ftp.belnet.be/packages/damnsmalllinux/
Note that the ibiblio site no longer hosts DSL, and AFAIK, the belnet.be site is probably the main host these days. So, any references to the ibiblio site for repositories and such will not work. Use the belnet.be URLs instead.

Finally, DSL is quite dated - the latest ISO files are 3 years old. However, that should not really be an issue for an older and underpowered system like you have.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board