Linux.com

Home Linux Community Forums Software Installation Update ManagerPackage Manager problem please help!

Update ManagerPackage Manager problem please help!

Link to this post 30 Mar 10

I'll start off by saying I'm rather new to linux.

So I encounter this error while trying to update and cannot get past it, tried some things from doing research but nothing has worked. I can't do a bunch of the terminal commands because somehow im not the 'owner.' Which makes no sense to me considering this is the only account on here.

Ubuntu 9.10 32bit here is the message I get when trying to run the Update Manager:
"
Could not initialize the package information

An unresolvable problem occurred while initializing the package information.

Please report this bug against the 'update-manager' package and include the following error message:

'E:Problem parsing dependency Depends, E:Error occurred while processing vlc-nox (NewVersion1), E:Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.'"

those stupid smilies^^ are ":" followed by a "P" and not intended

I can't install anything because of this, renders this instillation as useless as windows 98. I found out I can't do anything to the file because of permissions, which I dont have ownership to change the permissions. Maybe im an idiot, i dunno im not ruling that out but this seems WAY more complicated than it needs to be.

If anyone could help me resolve this I would be grateful.

Link to this post 30 Mar 10

Matt, this could very well be a temporary error with the Ubuntu repository servers. Just give it a day or so and make the attempt again. Let us know what happens, please.

Regards,

~Eric

Link to this post 30 Mar 10

If you are not the "owner" (root is the Linux term for that, by the way), you may not have access to the Update Manager without the root password.

One of the reasons Linux is so much safer than Windows is that you're not running in "Administrator mode" all the time. When you run an application that requires "administrator access" (such as the Update manager in Ubuntu I think, or Synaptic Package Manager), you are asked for the root password.

If you have done all that and it still won't update, it's probably just that the servers are temporarily down or busy. Try again in a little while.

Robin

Link to this post 31 Mar 10

Thank you for the replies. This problem started about a week ago - is it possible the server has been down for that long?

It used to ask for the root password for the update, however it hasn't since this error started.

Link to this post 31 Mar 10

Matt,

Unless you've manually enabled the root account on your Ubuntu, then there won't be a root account accessible to you. Ubuntu uses "sudo", which is a command that gives regular users temporary rights to perform what would normally be a root (administrator) chore.

When you open Synaptic (Add/Remove Software in the Menu), it should ask you for your password. It's asking for the password you created for your user account when you installed Ubuntu on your system.

Once in Synaptic, you should check to see that the repositories are set up correctly and have not been changed. One thing to always try to remember in situations like this is what did you do JUST BEFORE this problem started? Did you install something new? Did you update something? Did you make any other changes to the system? Et cetera... This will help you to troubleshoot where the problem began.

I'm not an Ubuntu guru. I haven't used it since '06 or so. I don't really remember the layout of the Synaptic package manager or how it works. I can tell you how to update manually, though...

In the command line (Terminal application from the Menu), type the following:

$ sudo apt-get update

This command will ask you for your password. Enter it and continue. The "apt-get update" command will check the repos for updated files. Once it's completed its thing, type:

$ sudo apt-get upgrade

This will again ask for you password. Enter it and go on. This command will upgrade all the software on your system for which there are updates available in the repos.

The two commands above "apt-get update" and "apt-get upgrade" are the actual commands underneath the pretty graphic Synaptic Package Manager that you use from the Menu in Ubuntu.

If there are any errors while running these commands, please post them here. They could help us to help you better to figure out what's wrong on your Ubuntu system.

Luck!

Link to this post 31 Mar 10

Thank you for the reply. Ok that gives me a bit of a better understanding of how the admin works. I will try the manual way when i get home in a few hours. I'm guessing ahead of time it will deny me and not prompt for a password, i'll post when i try it.

As far as programs installed before this started happening - the last thing I recall doing was installing adblock on firefox. Tried to install adobe flash player with 9.04 apt from adobe's site, and and began to notice this error beginning. never got flash player to install. It's a rather fresh install very little has been done on it.

some details i found out, maybe it will give someone an idea:

***'E: Problem parsing dependency Depends, E:Error occurred while processing vlc-nox (NewVersion1), E: Problem with MergeList /var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages, E:The package lists or status file could not be parsed or opened.'***

So in this error ^^ seems to be with 'vlc-nox' the only aspect of vlc on this machine is the plugin for firefox. the packet it specifies '/var/lib/apt/lists/us.archive.ubuntu.com_ubuntu_dists_karmic_universe_binary-i386_Packages' seems to be something about firefox, i opened it and one of the lines in it says it can be safely removed. (wont let me do anything to this file i tried, no prompts for any kind of password just a strict denial).

thanks again I hope someone can help me figure this out, its really bugging me and I'd like to learn it just for the purpose of knowing and becoming more familiar with this OS.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board