Home Linux Community Forums Hardware Multimedia installing and using a saa7231 TV card

installing and using a saa7231 TV card

Link to this post 02 Jan 10


I bought a new computer a few days ago and I have a lot of trouble in installing and using my TV card.
My card is a saa7231 triple capture device from CTX and lspci identifies the card as:

01:07.0 Multimedia controller: Philips Semiconductors Device 7231 (rev 11)
Subsystem: Creatix Polymedia GmbH Device 0002
Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 64 (1000ns min, 4250ns max), Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 11
Region 0: Memory at f9800000 (64-bit, non-prefetchable) Region 2: Memory at f9400000 (64-bit, non-prefetchable) [size=4M] Capabilities: [40] Power Management version 3 Flags: PMEClk- DSI- D1+ D2+ AuxCurrent=55mA PME(D0+,D1+,D2+,D3hot+,D3cold-) Status: D0 PME-Enable- DSel=0 DScale=0 PME- Capabilities: [48] Message Signalled Interrupts: Mask- 64bit+ Queue=0/4 Enable- Address: 0000000000000000 Data: 0000

I found something that seems to be a driver for that card on but I do not understand how to use it. I installed it using make -i && make install but I have no idea what to do next. Programs like tvtime oder kaffeine still do not get any signals.

So maybe someone can give me some hints on using this TV card.

Thanks a lot and a happy new year,


I am using Debian Lenny with a kernel version 2.6.26-2-amd64.

Link to this post 02 Jan 10
i found what i needed he i downloaded it and i did nil it just worked

Link to this post 02 Jan 10

its tv time u download

Link to this post 02 Jan 10

Thanks a lot for your tip, but I tried tvtime already. It just gives me a blue window with the text it cannot find /dev/video0. I checked it and this device does not exist. Unfortunately there is no device at all that looks like a TV card. I think the saa7231 driver is not installed or loaded correctly. My problem is, that I do not understand how to use this driver.

Link to this post 06 Jan 10

it seems that i have the same problem =(

driver from fails to compile:

*** No rule to make target `/root/saa7231-c6048b34be66/v4l/saa7231_pci.o', needed by `/root/saa7231-c6048b34be66/v4l/tda18271.o'. Stop.

slackware 13.0 x86_64 kernel:

Link to this post 06 Jan 10

I also got this error message. I could avoid it by using make -i instead of make all, but I do not think that this makes any sense because the driver didn't work either.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>