Home Linux Community Forums Hardware Networking Cant find any wireless networks

Cant find any wireless networks

Link to this post 16 Jun 10

madwifi is outdated now because the atheros kernel drivers are built right into the kernel with names such as ath5k, ath7k or ath9k. Can you please run "sudo lsmod|grep ath" and tell me if you see any of the module names I listed above or anything that starts with ath?

Link to this post 17 Jun 10

david@david-laptop:~$ sudo lsmod|grep ath
[sudo] password for david:
ath_pci 101024 0
wlan 207856 1 ath_pci
ath_hal 192592 1 ath_pci

Link to this post 17 Jun 10

That is odd, I am seeing that your wifi card is supported by the ath9k driver, but it does not appear to be loaded. Go into the terminal and enter "sudo modprobe ath9k" to load the driver, if that does not fix the issue then I would like you to post the output of "sudo lspci|grep -i ath" to this site.

Link to this post 18 Jun 10

It still doesn't work:

david@david-laptop:~$ sudo modprobe ath9k
[sudo] password for davidknipe:
FATAL: Module ath9k not found.
david@david-laptop:~$ sudo lspci|grep -i ath
02:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Link to this post 18 Jun 10

It looks like it may not be setup as a module in your kernel, have you tried going to the Hardware Drivers option in the administration menu to see if it detects the card and recommends drivers?

Link to this post 19 Jun 10

It lists 2 device drivers: "Atheros Hardware Access Layer (HAL)" and "Support for Atheros 802.11 wireless LAN cards". They both have ticks beside them to say they are both enabled and in use. I don't see any error messages.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board