Linux.com

Home Linux Community Forums Hardware Networking IPCop need help with ports *NO LONGER AN ISSUE*

IPCop need help with ports *NO LONGER AN ISSUE*

Link to this post 24 Jul 11

Hello, I seem to be failing to properly port forward. I recently installed IPCop onto a dell system I have for a firwall and DHCP server on my local home network.

I was not able to get onto the internet until I enabled proxies and assigned a proxy port, I don't know if this is how it normally works or not.

Everything was great until I tried connecting to Battle.net on starcraft 2, I tried using the ports blizzard recommends but was not successful in fixing this issue.

I really could use some help here, thanks guys.

*UPDATE* The IPCop software simply isn't ready for deployment. in my experience. Other plans are being made for the network setup instead.

Link to this post 25 Jul 11

As far as I know computers in the GREEN zone should access Internet without the use of proxy.

I guess you already have checked the guide:
http://www.ipcop.org/2.0.0/en/admin/html/services-dhcp.html
http://www.ipcop.org/1.4.0/en/admin/html/services.html#services_dhcp (old)

Port forwarding is only made to open for external access:
http://www.ipcop.org/2.0.0/en/admin/html/firewall-fwrules.html
http://www.ipcop.org/1.4.0/en/admin/html/section-firewall.html#section-port-forwarding (old)

What ports did you add? It's easy to miss that it's both UDP and TCP that needs to be added.
1119 both UDP and TCP seems to be required:
http://us.battle.net/en/faq/
"The Blizzard Downloader requires that TCP and UDP ports 3724, 4000, 6112, 6113, 6114 and 6881-6999 be forwarded."
http://us.blizzard.com/support/article.xml?locale=en_US&articleId=21073

Blizzard ftw! (me == Diablo 2 addict)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board