Linux.com

Home Linux Community Forums Hardware Networking Old Tale With a New Twist ...

Old Tale With a New Twist ...

Link to this post 12 Apr 10

Are any of you using KPPP with KDE 4?

I'm facing the same problem with Mandriva 2009, Open Suse v11 as well as with Slackware v13-64 ... I've been using Suse v10.0 for years and long ago solved the KPPP problem of "Modem Not Found" as well as "Modem Busy" but with this newer version of KDE, the v4 series, I just don't know where the KPPP file is so I can change the owner to "+s"; <chown +s>.

Any ideas?

Thanks.

tyc

Link to this post 12 Apr 10

You can type "which kppp" in the terminal to have it display the location of the executable in any distribution.

Link to this post 13 Apr 10

I appreciate your reply but what you have stated is NOT true with Slackware v13-64 ...


tyc

Link to this post 13 Apr 10

I am a slackware user running slackware-13.0, slackware64-13.0, slackware-current and slackware64-current and a slackbuild maintainer. The which command tells you where the executable is on any linux based system. In all recent versions of slackware kpp is located in /usr/bin/kppp.

You can verify it by checking the packages directory.

cd /var/log/packages
grep kppp *|grep "bin/"

by using the slocate database

locate kppp|grep "bin/"

or by using the which command that I tested on slackware64-13.0 prior to the first response.

Link to this post 13 Apr 10

I stand corrected!

You were right, I was wrong. The command "which" It does work - but proved useless as the KPPP file did show and after employing CHOWN ROOT.ROOT as well as CHMOD +S, I'm sitll getting "MODEM BUSY." Using CHOWN and ROOT as just shown does consistantly work when using Suse v10.0 but not with Slackware.

By chance, are you familiar with or know anyone who is using Slackware v13-64 with a HP G71 series laptop? I ask this as I've recently elected to try and make this Slackware work, which I suspect it should, as opposed to shoving it down Volkerding's throat. Been using Linux in a business eviornment for 9 or so years now and have never had so much trouble with a Linux OS.
Problems (no sound, failure to install OOo and modem/KPPP) are just unbelievable and while some are directly attributable to Slackware's makeup, the sound and KPPP problems may not be.

Again, thanks for getting back, it's appreciated.

tyc

Link to this post 13 Apr 10

Have you confirmed that the modem is properly detected and the correct driver module is loaded for your modem? As for the modification of the rights on kppp, I would recommend setting up the rights for only the necessary users in the sudoers file to launch it with root permissions rather than playing with the permissions. It you like you can also modify the executable path for the kppp desktop file for the effected user to launch it with kdesu, but that will still require the root password.

I recently got a Q61 (Compaq) laptop that has a audio chip that is supported, but not completed, I does not detect the headphones and automute the speakers. the reason is because the specific snd-hda_intel module that is used to make the audio work has not yet gotten that function working in a stable manner. The issue with your sound may be similar in which the chipset may be so new that the drivers and codecs have not been pushed in the kernel and also versions you are using. But alternately you can run alsoconfig or alsconf (I can't remember which) to see what cards are detected and tell alsa to use them.

THe OOo item seems new to me, where are you getting the OOo package or build from?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board