Linux.com

Home Linux Community Forums Hardware Networking Wireless Internet is trolling me again.

Wireless Internet is trolling me again.

Link to this post 06 Feb 12

So I asked for help on the Linux Mint forums and its been 2 full days so im asking over here. I hope you guys can help me. If you do not know how to help please give me links. Thank you
Everything under this line is the original message.
_______________________________________________________________________________
So I do need to explain from the very beginning.

I have a Toshiba Satellite Laptop. It came pre-installed with windows 7 Home edition. That crashed and I ended up switching to Linux, as it happened I installed Ubuntu 10.10 at the time. Meanwhile I had fixed my windows and my laptop enjoyed a dual boot for about a year with wireless and Ethernet working perfectly for the longest time. Than my windows crashed again. I was forced to re-install, and with my warranty gone i was forced to buy Windows 7 Ultimate, and this is were the problem begins.

After installing windows 7 with a 100 GB partition and Ubuntu (now 11.10) with a 200 GB partition. I noticed that while my Linux networking working just fine my windows 7 networking would not work at all. Being and Intermediate computer user i used my Linux to find the drivers manually, pass them over to my windows partition and install them. I rebooted into window 7 and huzzah my Ethernet works, from there it was a quick connection to automatically install my wireless driver.

Here is were the peculiar thing happens. Now my Linux Operating systems networking will not work at all. I downgraded from Ubuntu 11.10 to 10.10. After that being futile and getting sick of path Ubuntu was taking I switched to Linux Mint. Still the same problem. Now here is were the trolling part comes in.

When i go to my college campus my wireless Internet works perfectly fine (Ethernet not tested). I come home and none work. Please help.

Here are the results to

Sudo lshw -C networking

PCI (sysfs)  
*-network
description: Wireless interface
product: RTL8191SEvB Wireless LAN Controller
vendor: Realtek Semiconductor Co., Ltd.
physical id: 0
bus info: pci@0000:02:00.0
logical name: wlan0
version: 10
serial: 20:7c:8f:0c:61:dc
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rtl819xSE driverversion=0017.0507.2010 firmware=63 latency=0 link=yes multicast=yes wireless=802.11bg
resources: irq:16 ioport:7000(size=256) memory:f3100000-f3103fff
*-network
description: Ethernet interface
product: AR8152 v1.1 Fast Ethernet
vendor: Atheros Communications
physical id: 0
bus info: pci@0000:08:00.0
logical name: eth0
version: c1
serial: c8:0a:a9:85:61:ca
capacity: 100MB/s
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.0.2-NAPI firmware=N/A latency=0 link=no multicast=yes port=twisted pair
resources: irq:43 memory:f3000000-f303ffff ioport:6000(size=128)

Thank you all for your help in advance.

-Asad3ainJalout

Link to this post 07 Feb 12

If it works at college, and not at home, are you using the same connection and security level that was set up for school? Did you try redoing the wireless setup by scanning for the router in your home and setting up the password correctly so it connects to your home router?
If it works at school, then, your wireless driver must be setup correctly, so, the fault must be with the way it connects to the home router. You might have done this already, but, if you didn't, make a new connection in your Network Manager for home, and reinput all the pertinent info again and see if that helps.

Some of the Mods use Ubuntu, so, if you're patient, and, my answer didn't help, one of them might have more detailed instructions to help you.

It might also help if you run ifconfig in the terminal and post the results here. It might contain some hints as to why you're having the problem.

Link to this post 07 Feb 12

If it works at college, and not at home, are you using the same connection and security level that was set up for school?
They were both automatic connections.

Did you try redoing the wireless setup by scanning for the router in your home and setting up the password correctly so it connects to your home router?

Yes, multiple times including putting in all of the information manually.

Some of the Mods use Ubuntu, so, if you're patient, and, my answer didn't help, one of them might have more detailed instructions to help you.

I moved off of ubuntu and am currently using LinuxMint12

It might also help if you run ifconfig in the terminal and post the results here. It might contain some hints as to why you're having the problem.

These are the results from the ifconfig command,

eth0      Link encap:Ethernet  HWaddr c8:0a:a9:85:61:ca  
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:43

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:28 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1920 (1.9 KB) TX bytes:1920 (1.9 KB)

wlan0 Link encap:Ethernet HWaddr 20:7c:8f:0c:61:dc
inet6 addr: fe80::227c:8fff:fe0c:61dc/64 Scope:Link
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:24 errors:0 dropped:0 overruns:0 frame:0
TX packets:220 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3928 (3.9 KB) TX bytes:50287 (50.2 KB)

Link to this post 08 Feb 12

I'm wondering if Mint has your networking set up with both IPv4 and IPv6 and your home router is only set up for the IPv4 protocol. I've read forum thread where this has caused problems. Unfortunately, I'm not near a Mint install where I can check that out and tell you how to shut off the IPv6.
In the Network Manager on my Fedora KDE netbook, when I go in to edit the Wireless connection, I see that IPv4 is set to DHCP and the IPv6 is disabled. See if your IPv6 is disabled and if not, disable it and see if that makes a difference. That's the first thing I would check.

Link to this post 08 Feb 12

I went in and saw that the setting was set for automatic. There was no disabled option, the closest option to that was ignore. I selected that option, saved, disconnected, than attempted to reconnect with no results.

P.S.
On a side note I forgot to thank you for being the first person in 5 days to reply
Thank you for your Help.

Link to this post 09 Feb 12

Your problem is quite strange, but that is that intrigues us.

Since it is able to connect at school but not home I have to ask, when at home do you see any networks when you scan for active networks?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board