Linux.com

wvdial lost carrier

Link to this post 17 May 09

Hi !
I have the BIGGEST problem in the world (for sure because it's mine :p)

I can't connect to the internet under Ubuntu 8.10 and wvdial;
after that wvdial enter the phone number, it tell me that he has lost carrier. this is my wvdial.conf file:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Modem Type = USB Modem
ISDN = 0
New PPPD = yes
Phone = 195
Modem = /dev/ttyACM0
Username = MYUSERNAME
Password = MYPASSWORD
Baud = 460800

and this is what I have in the console

root@hadi-laptop:~# wvdialconf 
Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- failed with 2400 baud, next try: 9600 baud
ttyS0<*1>: ATQ0 V1 E1 -- failed with 9600 baud, next try: 115200 baud
ttyS0<*1>: ATQ0 V1 E1 -- and failed too at 115200, giving up.
Modem Port Scan<*1>: S1 S2 S3
WvModem<*1>: Cannot get information for serial port.
ttyACM0<*1>: ATQ0 V1 E1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 Z -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyACM0<*1>: Modem Identifier: ATI -- 5601
ttyACM0<*1>: Speed 4800: AT -- OK
ttyACM0<*1>: Speed 9600: AT -- OK
ttyACM0<*1>: Speed 19200: AT -- OK
ttyACM0<*1>: Speed 38400: AT -- OK
ttyACM0<*1>: Speed 57600: AT -- OK
ttyACM0<*1>: Speed 115200: AT -- OK
ttyACM0<*1>: Speed 230400: AT -- OK
ttyACM0<*1>: Speed 460800: AT -- OK
ttyACM0<*1>: Max speed is 460800; that should be safe.
ttyACM0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found an USB modem on /dev/ttyACM0.
Modem configuration written to /etc/wvdial.conf.
ttyACM0<Info>: Speed 460800; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
root@hadi-laptop:~# gedit /etc/wvdial.conf
root@hadi-laptop:~# wvdial
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Modem initialized.
--> Sending: ATDT195
--> Waiting for carrier.
ATDT195
CONNECT 44000/ARQ/V90/LAPM/V42BIS
--> Carrier detected. Waiting for prompt.
--> Connected, but carrier signal lost! Retrying...
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
ATDT195
NO CARRIER
ATDT195
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
ATDT195
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
ATDT195
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
ATDT195
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
ATDT195
--> No Carrier! Trying again.
--> Sending: ATDT195
--> Waiting for carrier.
NO CARRIER
ATDT195
--> No Carrier! Trying again.
^Z
[1]+ Stopped wvdial
root@hadi-laptop:~#

please help me!!!! I can't live without internet; so I can't work on linux now
:(

Link to this post 18 May 09

It looks to me like you are in an area with a lot of signal attenuation, which is why the signal keeps getting lost.

As for using wvdial, I upgraded a user with a mobile broadband card from ubuntu 8.10 to 9.04 and now the system auto-detects the device and auto-connects through the default network configuration application, I would recommend giving an upgrade a try, I think it should give you more information and fix any configuration problems that may exist.

Link to this post 18 May 09

It looks to me like you are in an area with a lot of signal attenuation, which is why the signal keeps getting lost.

Yes, there is a lot of noise but under window$, I have no connection problem

I think it's a configuration problem ...

Link to this post 18 May 09

Unfortunately since I don't know what kind of card you are using and I probably haven't worked with it, I don't think I can help much more.

But I strongly recommend trying Ubuntu 9.04 to see if their auto-configuration fixes your issues.

Link to this post 18 May 09

my card is a USRobotics 56K Usb Modem (USR5637)

I 'll try to upgrade, (but I can't do it now because currently I just have a 56K connection!)

thanks for all!

(but if you find a solution, don't forget to help me)

Link to this post 23 May 09

Hello,
I never cared for wvdial because I had to write a script to kill it, and I never was able to get diald working either. I did have good success with KPPP (since I use KDE), and so I'll post an old guide from 2005. It was written for Mandrake 10.0, but you should be able to use it as a guide.

Some internal winmodems can be made to work with Linux, but mostly not.
This is because they lack their own controller chip, and depend on MS
proprietary software to work. Most external modems have this chip, and
can be made to work.

Here is a procedure that I have successfully used in the past with
internal modems. I wrote it for Mandrake, so it is only meant to be a
guide. You will need to make necessary path adjustments for your
particular distribution.

This guide was written to setup the Archtek Telecom Smartlink
5634PCV Internal Modem for Mandrake Linux versions 9.0 through
10.0 inclusively. Note that other variations of this modem are winmodems only. This will only work on the 5634PCV.

Setting up KPPP on Mandrake 10.0

1. From the installation disks, install setserial and kppp.

2. Determine your modem type, IRQ number and I/O address with the
following command:

lspci -v

This lists all of your pci devices. In my case, this is:

Bus 0, device 9, function 0:
Communication controller: TOPIC SEMICONDUCTOR Corp TP560 Data/Fax/Voice 56k
modem (rev 0).
IRQ 5.
I/O at 0xd800 [0xd807].

Now I know that I am going to use ttyS2, that my IRQ is 5 and my
I/O address is 0xd800. Write those numbers down, you will need them
in a moment. Also, these numbers will change if you move your card to
another slot, or change modems.

3. Open a console and become superuser:

su
password: <your root password goes here>

4. cd to /dev and check your serial devices.

cd /dev
ls -l ttyS*
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS0 -> tts/0
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS1 -> tts/1
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS2 -> tts/2
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS3 -> tts/3
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS4 -> tts/4
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS5 -> tts/5
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS6 -> tts/6
lr-xr-xr-x 1 root root 5 Aug 7 06:04 ttyS7 -> tts/7

5. Depending on your modem, you are probably going to use ttyS2
(com2) or ttyS4 (com5). In my case, under Mandrake-10, the device
already exits. For any version of Mandrake 9, you will have to
create it. To do this you will need to know the major and minor
numbers for the serial ports.

Here is the list, from the Serial HOWTO:

/dev/ttyS0 major 4, minor 64 (dos com1)
/dev/ttyS1 major 4, minor 65 (dos com2)
/dev/ttyS2 major 4, minor 66 (dos com3)
/dev/ttyS3 major 4, minor 67 (dos com4)
/dev/ttyS4 major 4, minor 68 (dos com5)

6. If you're using Mandrake-10, don't do this. Serial devices are
setup differently under Mandrake-10. If you are using any version
of Mandrake 9, create the new device:

#COM2
mknod -m 666 /dev/cua2 c 5 66
mknod -m 666 /dev/ttyS2 c 4 66

#COM5
mknod -m 666 /dev/cua4 c 5 68
mknod -m 666 /dev/ttyS4 c 4 68

7. Enable the new serial device and create a link to /dev/modem
with the command:

# Here is where you need the numbers you wrote down before.

setserial /dev/ttyS2 uart 16550A irq 5 port 0xd800
ln -s /dev/ttyS2 /dev/modem # This creates /dev/modem

8. Now cd to the /etc/rc.d directory, and create rc.serial:
(Remember that your irq and port numbers will be different from mine)

cd /etc/rc.d # Change to /etc/rc.d
vi rc.serial # Create rc.serial with vim

#!/bin/sh # This is the shebang, do not leave it out
# rc.serial # This is file to execute
#
rm -f /dev/modem
setserial /dev/ttyS2 uart 16550A irq 5 port 0xd800
ln -s /dev/ttyS2 /dev/modem
echo "Modem Ready"

:wq # Type :wq to save the file and quit vim

9. Make rc.serial executable with:

chmod 755 rc.serial

10. Make a link from /etc/rc.d/rc.serial to /etc/rc.serial:

cd /etc
ln -s /rc.d/rc.serial

Reboot and start KPPP (Kicker > Internet > Remote Access > KPPP)
Click on Configure and enter your ISPs information and dial.

Depending on your version of Linux, rc.serial may not have executed on
boot. If not, you should add the following as the last line of
/etc/rc.d/rc.local:

/bin/sh /etc/rc.serial

This is not needed by Mandrake-10. You may start the modem without
rebooting with the command:

/etc/rc.serial (./rc.serial)

You can avoid all this by purchasing a decent external modem, we sell them for about $7.50 USD apiece at the store where I work. I switched to high speed wireless about a year ago, and it was well worth the shift to me.

HTH

Michael

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board