Home Linux Community Forums Linux Distributions openSUSE Desktop environment doesn't work

Desktop environment doesn't work

Link to this post 18 Feb 10


Today I discovered that I can't see my desktop (GNOME), but a terminal, text mode environment. I don't know why did that happen.

I want to use again GNOME, but what can I do to use it?

Link to this post 18 Feb 10

It sounds like your system rolled back to cli mode, have you tried typing startx?

Link to this post 18 Feb 10


I'll try that, and I'll inform about my results.

In fact, this is the first time I've heard that command :blink:

Link to this post 19 Feb 10

Did this happen after a software update? It's odd for it to just stop working. If startx fails, try manually starting gdm (maybe /etc/init.d/gdm start) and see if that works. If both fail, you'll probably have to check for error message in the X server's log file (probably /var/log/Xorg.log orsomething similar) and see if we can figure out what happened.

Link to this post 19 Feb 10

The startx command is used to start the X11 server from a CLI login, rather than starting the system in full CLI Mode.

The system has an init file that tells it to start in CLI or GUI mode, but I do not know the file name opensuse. If startx works the next step would be to check that file to make sure the right run level is set.

After that it would be about digging into log files to see exactly what went wrong as Adam stated.

Link to this post 19 Feb 10

Well, I don't know why happens that.

But it's strange. Because sometimes openSUSE starts well, and another times it starts with text mode :S

Because of problems with Internet on it, I downloaded some games from sourceforge with my Vista (Rigs of Rods, Vega Strike, No Gravity and Freeorion) and tried to install them on openSUSE. Maybe that is the cause.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board