Linux.com

Istimsak Abdulbasir

Istimsak Abdulbasir

  • Moderator
  • Posts: 590
  • Member Since: 05 Jan 10
  • Last Logged In: 5 hours ago

Latest Posts

Posted by
Topic
Post Preview
Posted
  • Istimsak Abdulbasir
    RE: Logging outgoing message content
    I have never used sendmail. Though I am saw there are good documentation that further explained the use of this package. I would first read the man page for sendmail and find any commands that will you do what you are requesting. Sendmail should have a configuration file that allows you to manipulate the the way the program works. I'll get back to you letting you know what can and cannot be done in regards to your request.
    Link to this post 5 hours ago

    I have never used sendmail. Though I am saw there are good documentation that further explained the use of this package. I would first read the man page for sendmail and find any commands that will you do what you are requesting.

    Sendmail should have a configuration file that allows you to manipulate the the way the program works.

    I'll get back to you letting you know what can and cannot be done in regards to your request.

  • Istimsak Abdulbasir
    RE: Ready to DUMP windows
    [quote="Fuzzy"] I recently learned that microsoft has made an agreement with Intel and AMD to only run Win 10 on their new cpu's. They never mentioned Linux. Will go out on a limb and assume that if true it will not affect Linux. With that said I'm ready to dump Windows, something I should have done a long time ago. Having never used Linux I have done a little research on the different operating systems. It looks like Ubuntu 15.10 or Mint 17.3 will be a good starting point for me. I will have to learn the new OS first then show my wife how to use it. What i want to do is load Linux on my second hard drive keeping Win 7 as the primary OS booting with Win 7 then switching to Linux. My current computer consists of an I7 3770K CPU, 16 gig of high speed ram and a G-Force GTX 760 graphics card. I do plan on doing some gaming on the computer as well as my wife who's gaming consists of playing on Pogo.com. Other than that its making purchases on the web, paying bills, banking and other tasks. I believe either of the Linux OS are new user friendly, but how compatible are they with my current system? Any thoughts on that?[/quote] The members who posted before me offered some great advice. Ubuntu, Mint, Zorin are good Linux distros for new linux beginners. You are able to hit the ground running. However, and I will always say this, everyone has a particular preference. I started my journey on Linux using Ubuntu and was able to transition to Fedora 23 and CentOS. From research, Ubuntu-based Linux systems are of the favorites to begin testing out the Linux waters. You can share files between Linux and Windows. You can even access your windows partitions from linux just not the other way around. Application compatibility is still in the laboratory. Some apps from windows work on Linux. However, if you are planning to use only windows based apps on Linux or expect the same functionality you gotten from MS apps from open source apps, you are better off sticking with windows. In the Linux world, you must be willing to adapt the open source mindset. Gaming is fun, just as much as trying to get a working gaming system built. Steam offers an all-in-one box for games that can run on PCs, Macs and Linux. However, building your own gaming system to be compatible with steam and all its features can be a major headache. Steam, lucky, offers pre-built steam gaming machines for this purpose. It has all the required hardware and game pads. You might want to check out their site. Good luck!! [url=http://store.steampowered.com/hardware/#Machines]http://store.steampowered.com/hardware/#Machines[/url]
    Link to this post 1 day ago

    Fuzzy said:

    I recently learned that microsoft has made an agreement with Intel and AMD to only run Win 10 on their new cpu's. They never mentioned Linux. Will go out on a limb and assume that if true it will not affect Linux. With that said I'm ready to dump Windows, something I should have done a long time ago. Having never used Linux I have done a little research on the different operating systems. It looks like Ubuntu 15.10 or Mint 17.3 will be a good starting point for me. I will have to learn the new OS first then show my wife how to use it. What i want to do is load Linux on my second hard drive keeping Win 7 as the primary OS booting with Win 7 then switching to Linux.
    My current computer consists of an I7 3770K CPU, 16 gig of high speed ram and a G-Force GTX 760 graphics card. I do plan on doing some gaming on the computer as well as my wife who's gaming consists of playing on Pogo.com. Other than that its making purchases on the web, paying bills, banking and other tasks.
    I believe either of the Linux OS are new user friendly, but how compatible are they with my current system? Any thoughts on that?

    The members who posted before me offered some great advice. Ubuntu, Mint, Zorin are good Linux distros for new linux beginners. You are able to hit the ground running. However, and I will always say this, everyone has a particular preference. I started my journey on Linux using Ubuntu and was able to transition to Fedora 23 and CentOS.

    From research, Ubuntu-based Linux systems are of the favorites to begin testing out the Linux waters. You can share files between Linux and Windows. You can even access your windows partitions from linux just not the other way around. Application compatibility is still in the laboratory. Some apps from windows work on Linux. However, if you are planning to use only windows based apps on Linux or expect the same functionality you gotten from MS apps from open source apps, you are better off sticking with windows. In the Linux world, you must be willing to adapt the open source mindset.

    Gaming is fun, just as much as trying to get a working gaming system built. Steam offers an all-in-one box for games that can run on PCs, Macs and Linux. However, building your own gaming system to be compatible with steam and all its features can be a major headache. Steam, lucky, offers pre-built steam gaming machines for this purpose. It has all the required hardware and game pads. You might want to check out their site.

    Good luck!!

    http://store.steampowered.com/hardware/#Machines

  • Istimsak Abdulbasir
    RE: Linux Lite Won't Install
    [quote="rgand"]OK, I'm ready to change distros for Linux. I suspect my computer just needs a system that is more friendly to this Asus. I'm looking at Linux Mint. There are several downloads, though. I'm used to Windows (up to 7) and have recently started working with Linux Lite. Lite was an easy switch. Which Mint version will give me the easiest transition from those systems? Remember I'm a newbie to Linux and just want a good OS, not something radically different than I'm used to. Thanks, Robert[/quote] Everybody has a preference. I have learned from experience, try out a linux distro that is very light on resource usage, is not graphic extensive or does not require a graphic accelerator and boots into a live session. Mint has a few that offers those features, Mint with [b]LXDE[/b], [b]XFCE[/b], and [b]MATE[/b]. [url=http://www.linuxmint.com/download.php]Linux mint[/url]
    Link to this post 1 day ago

    rgand said:

    OK, I'm ready to change distros for Linux. I suspect my computer just needs a system that is more friendly to this Asus. I'm looking at Linux Mint. There are several downloads, though.

    I'm used to Windows (up to 7) and have recently started working with Linux Lite. Lite was an easy switch. Which Mint version will give me the easiest transition from those systems? Remember I'm a newbie to Linux and just want a good OS, not something radically different than I'm used to.

    Thanks, Robert

    Everybody has a preference. I have learned from experience, try out a linux distro that is very light on resource usage, is not graphic extensive or does not require a graphic accelerator and boots into a live session. Mint has a few that offers those features, Mint with LXDE, XFCE, and MATE.

    Linux mint

  • Istimsak Abdulbasir
    RE: Linux Lite Won't Install
    [quote="rgand"]I'll keep this as short as possible. I'm fairly new to Linux and have very successfully put Linux Lite 2.6 with a dual boot on two older Toshiba laptops. Confident with what I'd done so far, I decided to finally go with the same on my main computer which is an Asus G75V. To avoid any chance of loosing all my personal data, I cloned the drive onto a new SSHD 1Tb drive I bought just to get this computer up with the best possible drive in it. When I had the computer apart to swap to the new drive, I installed a second HDD for extra data storage then booted to the install disk and gave LL a try. It worked OK from the disk boot with only one minor issue so I thought I'd install it and then work that out. This was a dismal failure. Nothing would boot up at all. The drive was dead. I changed back to the original drive (thank goodness I had the wisdom to start with a clone) and re-cloned the drive again. This time, I left the second HDD out in case it had been a problem. [/quote] When you had the Linux Lite running from the boot disc, what what the minor issue you encountered? Can you remember in detail what the issue was? Also, would it be possible to submit a screenshot of the your partition setup of your last harddrive. Partition schemes are tricky, and one partition in the wrong spot or removed can cause a system not to boot. Windows' partition layout is a landmine. It can have multiple partitions with only a few that can understood.
    Link to this post 1 day ago

    rgand said:

    I'll keep this as short as possible. I'm fairly new to Linux and have very successfully put Linux Lite 2.6 with a dual boot on two older Toshiba laptops. Confident with what I'd done so far, I decided to finally go with the same on my main computer which is an Asus G75V. To avoid any chance of loosing all my personal data, I cloned the drive onto a new SSHD 1Tb drive I bought just to get this computer up with the best possible drive in it.

    When I had the computer apart to swap to the new drive, I installed a second HDD for extra data storage then booted to the install disk and gave LL a try. It worked OK from the disk boot with only one minor issue so I thought I'd install it and then work that out. This was a dismal failure. Nothing would boot up at all. The drive was dead. I changed back to the original drive (thank goodness I had the wisdom to start with a clone) and re-cloned the drive again. This time, I left the second HDD out in case it had been a problem.

    When you had the Linux Lite running from the boot disc, what what the minor issue you encountered? Can you remember in detail what the issue was? Also, would it be possible to submit a screenshot of the your partition setup of your last harddrive. Partition schemes are tricky, and one partition in the wrong spot or removed can cause a system not to boot. Windows' partition layout is a landmine. It can have multiple partitions with only a few that can understood.

  • Istimsak Abdulbasir
    RE: Missing package compiling...
    [quote="chris_crunch"]I'm trying to build DIGITS from the src package I downloaded. But there's a problem... chris@chris-crunch:~/apps/DIGITS/DIGITS-master$ ./digits-server Traceback (most recent call last): File "/usr/local/bin/gunicorn", line 5, in from pkg_resources import load_entry_point File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3130, in File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3116, in _call_aside File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 642, in _build_master File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 943, in require File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 830, in resolve pkg_resources.DistributionNotFound: The 'gunicorn==17.5' distribution was not found and is required by the application So gunicorn=17.5 isn't found? What's the correct procedure here... [/quote] This may look like a dependency issued. gunicorn is a binary package not on your system. Before you attempted to compile, did you read the documentation or the README first. Most of these source programs do have README files or something that teaches you how to compile. Also, I would research gunicon through a browser to a full understanding of it. For instance, http://gunicorn.org/
    Link to this post 5 days ago

    chris_crunch said:

    I'm trying to build DIGITS from the src package I downloaded. But there's a problem...


    chris@chris-crunch:~/apps/DIGITS/DIGITS-master$ ./digits-server
    Traceback (most recent call last):
    File "/usr/local/bin/gunicorn", line 5, in <module>
    from pkg_resources import load_entry_point
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3130, in <module>
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3116, in _call_aside
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 3143, in _initialize_master_working_set
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 642, in _build_master
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 943, in require
    File "/home/chris/anaconda2/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 830, in resolve
    pkg_resources.DistributionNotFound: The 'gunicorn==17.5' distribution was not found and is required by the application


    So gunicorn=17.5 isn't found? What's the correct procedure here...

    This may look like a dependency issued. gunicorn is a binary package not on your system. Before you attempted to compile, did you read the documentation or the README first. Most of these source programs do have README files or something that teaches you how to compile.

    Also, I would research gunicon through a browser to a full understanding of it. For instance, http://gunicorn.org/

  • Istimsak Abdulbasir
    RE: Language
    [quote="abybaby87"]Hi The language changed from English to Spanish, and as a Chrome User, i cant open the LMS window, its possible through Firefox though, but i see Spanish! Regards Abel[/quote] Is everything working as expected?
    Link to this post 5 days ago

    abybaby87 said:

    Hi

    The language changed from English to Spanish, and as a Chrome User, i cant open the LMS window, its possible through Firefox though, but i see Spanish!

    Regards
    Abel

    Is everything working as expected?

  • Istimsak Abdulbasir
    RE: Knowledge check 8.1
    Here is a good article that explains how Linux detects and names devices connected to it. https://www.linux.com/news/hardware/peripherals/180950-udev There are other areas and methods in a Linux systems that will aid tracking down devices connected to your system. We know the first place to check is /dev. Linux does store devices it successfully detects in that directory. However, that is not the only place to located your devices.
    Link to this post 6 days ago

    Here is a good article that explains how Linux detects and names devices connected to it.
    https://www.linux.com/news/hardware/peripherals/180950-udev

    There are other areas and methods in a Linux systems that will aid tracking down devices connected to your system. We know the first place to check is /dev. Linux does store devices it successfully detects in that directory. However, that is not the only place to located your devices.

  • Istimsak Abdulbasir
    RE: Lab 4.1 fake_service.txt
    [quote="FToledano"] As I refer previously, english is not my native language, I want to mean something like this: [url=https://en.wikipedia.org/wiki/Sticky_post#Stickying]Stickying[/url] As is mentioned in other moderation messages, the material corrections can't be done "at the moment" because some reasons, and I only wanted to suggest that a post in the top of the forum showing this issues may be helpfull, something like: [code] Corrections: Lesson ...... Lesson 4 - If you experienced problems with the text showed in LAB 2.1 script code, download it from this site .......... (or whatever you want to explain or correct). Lesson 5 etc. [/code] All people would see this post before read the lesson and to be prevented. As you said, we can post questions in the forum but when I experienced problems trying to run [b]service fake_service start[/b], the first I thinked is that I was doing something wrong even more so when running [b]chkconfig[/b] the [b]fake_service[/b] appears ok and in the correct runlevels. After repeat the process a lot of times and read the lesson again several times I decide to test formating the file with [b]dos2unix[/b] and all works ok. After that I visit the forum to post it, but all was commented in this post. I added my comment yesterday only to show Brucecurcio user that after copy/paste the pdf code and formating the file with [b]dos2unix[/b] utility, [b]service[/b] can read the file without problems. I try not to bother anyone, the sticky post was only a suggestion because the original post with the problem is dated from 2015 summer and the material in the spanish course isn't corrected yet. I thinked (because moderators have said it in others posts) that the correction of the material is not an easy task and this can help. [/quote] Well, if we can created a new thread under this forum category, and update it with new material by editing the original post, it would seem possible. Perhaps an article or blog might be better with permanent link added to this thread.
    Link to this post 6 days ago

    FToledano said:



    As I refer previously, english is not my native language, I want to mean something like this:

    Stickying

    As is mentioned in other moderation messages, the material corrections can't be done "at the moment" because some reasons, and I only wanted to suggest that a post in the top of the forum showing this issues may be helpfull, something like:

    Corrections:
    Lesson ......
    Lesson 4
    - If you experienced problems with the text showed in LAB 2.1 script code, download it from this site .......... (or whatever you want to explain or correct).
    Lesson 5
    etc.

    All people would see this post before read the lesson and to be prevented.

    As you said, we can post questions in the forum but when I experienced problems trying to run service fake_service start, the first I thinked is that I was doing something wrong even more so when running chkconfig the fake_service appears ok and in the correct runlevels. After repeat the process a lot of times and read the lesson again several times I decide to test formating the file with dos2unix and all works ok.

    After that I visit the forum to post it, but all was commented in this post. I added my comment yesterday only to show Brucecurcio user that after copy/paste the pdf code and formating the file with dos2unix utility, service can read the file without problems.

    I try not to bother anyone, the sticky post was only a suggestion because the original post with the problem is dated from 2015 summer and the material in the spanish course isn't corrected yet. I thinked (because moderators have said it in others posts) that the correction of the material is not an easy task and this can help.

    Well, if we can created a new thread under this forum category, and update it with new material by editing the original post, it would seem possible. Perhaps an article or blog might be better with permanent link added to this thread.

  • Istimsak Abdulbasir
    RE: Lab 4.1 fake_service.txt
    [quote="FToledano"]Hi Brucecurcio, I waste 3 hours with this problem. The script code in the link of the 4.1 Lab in the spanish course is also unformated. If a copy/paste of the text in the pdf is performed, service utility throws that the file /etc/init.d/fake_service not exist, but the file is well placed and chkconfig shows the service in the correct runlevels. Some character must be hidden in the text and the file gives errors with service utility. A way to fix the copied text from the pdf is the dos2unix utility. [code]dos2unix name_of_the_corrupted_file[/code] Once the file is well formatted the script runs without problems. Would if be possible for the moderators to write a sticky post in the forum with the corrections to the material on each lesson?. It will be very hepfull. What do you mean by [b]"Sticky[/b] post in this forum"? If you experience a problem with one of your course materials, create a post under the related thread and past the material with all components there. Someone should be able to help as Jerry did. Thanks![/quote]
    Link to this post 02 Feb

    FToledano said:

    Hi Brucecurcio,

    I waste 3 hours with this problem. The script code in the link of the 4.1 Lab in the spanish course is also unformated. If a copy/paste of the text in the pdf is performed, service utility throws that the file /etc/init.d/fake_service not exist, but the file is well placed and chkconfig shows the service in the correct runlevels. Some character must be hidden in the text and the file gives errors with service utility.

    A way to fix the copied text from the pdf is the dos2unix utility.

    dos2unix name_of_the_corrupted_file


    Once the file is well formatted the script runs without problems.

    Would if be possible for the moderators to write a sticky post in the forum with the corrections to the material on each lesson?. It will be very hepfull.

    What do you mean by "Sticky post in this forum"? If you experience a problem with one of your course materials, create a post under the related thread and past the material with all components there. Someone should be able to help as Jerry did.
    Thanks!

  • Istimsak Abdulbasir
    RE: unexpand command not working
    [quote="adriabp"]Hi all, I don't know if I understood the command properly but I thought it was suppose to convert spaces into tabs in a file, here's how I'm using it: [code] [root@localhost people]# cat peoplelist1.txt 23 female Bianca Princeton 50 male George Yale 30 female Karen Harvard 35 male Andrew Berkeley [root@localhost people]# [root@localhost people]# unexpand peoplelist1.txt > peoplelisttab.txt [root@localhost people]# [root@localhost people]# cat peoplelisttab.txt 23 female Bianca Princeton 50 male George Yale 30 female Karen Harvard 35 male Andrew Berkeley [root@localhost people]# [/code][/quote] This command, [b]"unexpand"[/b] is a weird one. After experimenting, I found that if you do not set the number of characters (or spaces) for the tab to jump, the spaces will stick with the default value of 8. Meaning, the tab will be treated as the spacebar. This is what became interesting. I created a test file, wrote two sentences of two words each. After the first word in the sentence, i jumped 3 spaced to the right writing, using the space bar to write the second word. I used [b]"unexpand"[/b] in a terminal with no options. The results were printed to standard output and it looked the same. I even opened the file in gedit. No difference.I played further and used the [b]"-a"[/b] and the [b]"-t"[/b] options. When I set the [b]"-t"[/b] to 1, meaning "move tab 1 character across", the space between the words increased. I opened the file using gedit and again, the spaces were bigger in the file. Moving across the spaces with the arrow keys, it felt as if I was tabbing. Going back to what Matt said, I believe the character number means how many bytes to use to move across the space. So it you use "unexpand" with no options, then you are telling tab to use the 8 characters in a byte to convert the spaces to tabs which you. If you set the [b]"-t"[/b] option to one, you are telling "unexpand" to treat every number of a spaces as a whole byte increasing the space between words. Please correct me if I am wrong. [url=http://linux.die.net/man/1/expand]expand manpage[/url]
    Link to this post 02 Feb

    adriabp said:

    Hi all, I don't know if I understood the command properly but I thought it was suppose to convert spaces into tabs in a file, here's how I'm using it:


    [root@localhost people]# cat peoplelist1.txt
    23 female Bianca Princeton
    50 male George Yale
    30 female Karen Harvard
    35 male Andrew Berkeley
    [root@localhost people]#
    [root@localhost people]# unexpand peoplelist1.txt > peoplelisttab.txt
    [root@localhost people]#
    [root@localhost people]# cat peoplelisttab.txt
    23 female Bianca Princeton
    50 male George Yale
    30 female Karen Harvard
    35 male Andrew Berkeley
    [root@localhost people]#

    This command, "unexpand" is a weird one. After experimenting, I found that if you do not set the number of characters (or spaces) for the tab to jump, the spaces will stick with the default value of 8. Meaning, the tab will be treated as the spacebar. This is what became interesting.

    I created a test file, wrote two sentences of two words each. After the first word in the sentence, i jumped 3 spaced to the right writing, using the space bar to write the second word. I used "unexpand" in a terminal with no options. The results were printed to standard output and it looked the same. I even opened the file in gedit. No difference.I played further and used the "-a" and the "-t" options. When I set the "-t" to 1, meaning "move tab 1 character across", the space between the words increased. I opened the file using gedit and again, the spaces were bigger in the file. Moving across the spaces with the arrow keys, it felt as if I was tabbing.

    Going back to what Matt said, I believe the character number means how many bytes to use to move across the space. So it you use "unexpand" with no options, then you are telling tab to use the 8 characters in a byte to convert the spaces to tabs which you. If you set the "-t" option to one, you are telling "unexpand" to treat every number of a spaces as a whole byte increasing the space between words.

    Please correct me if I am wrong.

    expand manpage

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>