Linux.com

bhagwatn

bhagwatn

  • Linux.com Member
  • Posts: 4
  • Member Since: 30 Sep 10
  • Last Logged In: 04 Oct 10

Latest Posts

Posted by
Topic
Post Preview
Posted
  • bhagwatn
    RE: Swap space is never used, are my settings correct
    The issue just happened, so after fours days of up time the server memory shows following: top - 09:03:38 up 3 days, 22 min, 2 users, load average: 0.00, 0.03, 0.00 Tasks: 104 total, 1 running, 103 sleeping, 0 stopped, 0 zombie Cpu(s): 0.2% us, 0.2% sy, 0.0% ni, 98.6% id, 0.8% wa, 0.0% hi, 0.1% si Mem: 3089396k total, 3059924k used, 29472k free, 137096k buffers Swap: 2031608k total, 0k used, 2031608k free, 2526236k cached So, at this time when any client tries to copy that 200mb file, it hangs. So, somehow it never starts using the swap space. (which its supposed to start using when RAM is near full!) I am now rebooting the server to avail all the 3gb RAM!
    Link to this post 04 Oct 10

    The issue just happened, so after fours days of up time the server memory shows following:

    top - 09:03:38 up 3 days, 22 min, 2 users, load average: 0.00, 0.03, 0.00
    Tasks: 104 total, 1 running, 103 sleeping, 0 stopped, 0 zombie
    Cpu(s): 0.2% us, 0.2% sy, 0.0% ni, 98.6% id, 0.8% wa, 0.0% hi, 0.1% si
    Mem: 3089396k total, 3059924k used, 29472k free, 137096k buffers
    Swap: 2031608k total, 0k used, 2031608k free, 2526236k cached

    So, at this time when any client tries to copy that 200mb file, it hangs. So, somehow it never starts using the
    swap space. (which its supposed to start using when RAM is near full!)
    I am now rebooting the server to avail all the 3gb RAM!

  • bhagwatn
    RE: Swap space is never used, are my settings correct
    I tried changing the swapiness to 100 but it did not showed any swap usage via top; although I'm waiting for observing it when same problem is seen again. I'll check if its a full CPU issue and record top details with full load. Another thing is that this particular server is a VM. (sorry, forgot to mention this earlier). I'll keep updating.
    Link to this post 02 Oct 10

    I tried changing the swapiness to 100 but it did not showed any swap usage via top; although I'm waiting for observing it when same problem is seen again. I'll check if its a full CPU issue and record top details with full load.

    Another thing is that this particular server is a VM. (sorry, forgot to mention this earlier). I'll keep updating.

  • bhagwatn
    RE: Swap space is never used, are my settings correct
    Thanks for the help. More background: This machine is a server machine. There are seven to eight other client machines in the intranet which copies data from this server; upto 400MB data is copied by each client. Each client continously writes data to the server machine. So it may happen that 400MB * 7; this much data is transferred from the server!!! Plus non-stop writes to server!! Problem: Many times, when the client machine is trying to access html pages via the browser, it takes few minutes (upto 5 minutes) to deliver the data. For this slowness I suspected that since the swap space is not used we are getting this slow response. I want to know how to improve the performance and if unused swap space is the cause.
    Link to this post 01 Oct 10

    Thanks for the help.

    More background: This machine is a server machine. There are seven to eight other client machines in the intranet which copies data from this server; upto 400MB data is copied by each client. Each client continously writes data to the server machine. So it may happen that 400MB * 7; this much data is transferred from the server!!! Plus non-stop writes to server!!

    Problem: Many times, when the client machine is trying to access html pages via the browser, it takes few minutes (upto 5 minutes) to deliver the data. For this slowness I suspected that since the swap space is not used we are getting this slow response.

    I want to know how to improve the performance and if unused swap space is the cause.

  • bhagwatn
    Swap space is never used, are my settings correct
    I'm on GNU/Linux and top command always show that swap space is always 0k used! How to make sure that its used. I changed its priority from -1 to 1. Its still not used. Please help me out. Following are the various stats: <<<<<<<<<<<<<<<<<<<<<< top - 04:30:55 up 1 day, 1:35, 2 users, load average: 1.04, 0.47, 0.46 Tasks: 106 total, 2 running, 104 sleeping, 0 stopped, 0 zombie Cpu(s): 1.0% us, 3.4% sy, 1.3% ni, 85.2% id, 6.4% wa, 0.0% hi, 2.7% si Mem: 3089396k total, 1954548k used, 1134848k free, 157268k buffers Swap: 2031608k total, 0k used, 2031608k free, 1290560k cached %cat /proc/sys/vm/swappiness 60 %swapon -s Filename Type Size Used Priority /dev/mapper/VolGroup00-LogVol01 partition 2031608 0 1 # cat /etc/fstab # This file is edited by fstab-sync - see 'man fstab-sync' for details /dev/VolGroup00/LogVol00 / ext3 defaults 1 1 LABEL=/boot /boot ext3 defaults 1 2 none /dev/pts devpts gid=5,mode=620 0 0 none /dev/shm tmpfs defaults 0 0 none /proc proc defaults 0 0 none /sys sysfs defaults 0 0 /dev/VolGroup00/LogVol01 swap swap defaults 0 0 /dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0 /dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0 >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
    Link to this post 30 Sep 10

    I'm on GNU/Linux and top command always show that swap space is always 0k used!
    How to make sure that its used. I changed its priority from -1 to 1. Its still not used.
    Please help me out.

    Following are the various stats:

    <<<<<<<<<<<<<<<<<<<<<<
    top - 04:30:55 up 1 day, 1:35, 2 users, load average: 1.04, 0.47, 0.46
    Tasks: 106 total, 2 running, 104 sleeping, 0 stopped, 0 zombie
    Cpu(s): 1.0% us, 3.4% sy, 1.3% ni, 85.2% id, 6.4% wa, 0.0% hi, 2.7% si
    Mem: 3089396k total, 1954548k used, 1134848k free, 157268k buffers
    Swap: 2031608k total, 0k used, 2031608k free, 1290560k cached

    %cat /proc/sys/vm/swappiness
    60

    %swapon -s
    Filename Type Size Used Priority
    /dev/mapper/VolGroup00-LogVol01 partition 2031608 0 1

    # cat /etc/fstab
    # This file is edited by fstab-sync - see 'man fstab-sync' for details
    /dev/VolGroup00/LogVol00 / ext3 defaults 1 1
    LABEL=/boot /boot ext3 defaults 1 2
    none /dev/pts devpts gid=5,mode=620 0 0
    none /dev/shm tmpfs defaults 0 0
    none /proc proc defaults 0 0
    none /sys sysfs defaults 0 0
    /dev/VolGroup00/LogVol01 swap swap defaults 0 0
    /dev/hda /media/cdrom auto pamconsole,exec,noauto,managed 0 0
    /dev/fd0 /media/floppy auto pamconsole,exec,noauto,managed 0 0
    >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board