Linux.com

designer

designer

  • Linux.com Member
  • Posts: 11
  • Member Since: 29 May 12
  • Last Logged In: 01 Jun 12

Latest Posts

Posted by
Topic
Post Preview
Posted
  • designer
    RE: rpmError
    Well, well, I'm wrong. I just try use rpm on debian, maybe that is impossible, but I think somebody like me also will try.If there is a miracle, perhaps I could encounter. Have not tried, how do you know will not succeed. If the answer is not compatible, I would like to develop an rpm's people and the same can not be reconciled. What do you think?Compatible is a problem, but not all. I think if I get a right solution, I can run rpm on my debian, right? After all, THANKS!!!!!!!!!!!!!!
    Link to this post 01 Jun 12

    Well, well, I'm wrong. I just try use rpm on debian, maybe that is impossible, but I think somebody like me also will try.If there is a miracle, perhaps I could encounter. Have not tried, how do you know will not succeed. If the answer is not compatible, I would like to develop an rpm's people and the same can not be reconciled. What do you think?Compatible is a problem, but not all. I think if I get a right solution, I can run rpm on my debian, right?

    After all, THANKS!!!!!!!!!!!!!!

  • designer
    RE: yumError
    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!! After listening to so many, I don't want to install yum on my debian system, but I want to know how to resolve the problem above. Thanks everyone, you are kindly. Linux's open source idea is good, but needs a lot of improvements, more humane job.
    Link to this post 01 Jun 12

    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!!


    After listening to so many, I don't want to install yum on my debian system, but I want to know how to resolve the problem above. Thanks everyone, you are kindly. Linux's open source idea is good, but needs a lot of improvements, more humane job.

  • designer
    RE: rpmError
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-45) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Sun May 6 04:00:17 UTC 2012 new debian package, version 2.0. size 993282 bytes: control archive= 3562 bytes. 933 bytes, 20 lines control 5563 bytes, 90 lines md5sums 248 bytes, 14 lines * postinst #!/bin/sh 190 bytes, 12 lines * postrm #!/bin/sh Package: rpm Version: 4.9.1.3-2 Architecture: amd64 Maintainer: Michal 膶iha艡 Installed-Size: 1231 Depends: libc6 (>= 2.4), libelf1 (>= 0.131), libpopt0 (>= 1.14), librpm2 (>= 4.9.0), librpmbuild2 (>= 4.9.0), librpmio2 (>= 4.9.0), librpmsign0 (>= 4.9.0), perl, rpm2cpio, rpm-common (= 4.9.1.3-2) Suggests: alien, elfutils, rpm-i18n Breaks: man-db (<< 2.5.0-1), manpages-pl (<< 20051017-1) Replaces: manpages-pl (<< 20051017-1) Section: admin Priority: optional Homepage: http://rpm.org/ Description: package manager for RPM The RPM Package Manager (RPM) is a command-line driven package management system capable of installing, uninstalling, verifying, querying, and updating computer software packages. . On Debian and derived systems it is recommended to use "alien" to convert RPM packages into .deb format instead of bypassing the Debian package management system by installing them directly with rpm. This is my debian and my rpm package's information. Do you know they are neither compatible or not? Why linux have so many dependency problem and the microsoft window don't?
    Link to this post 01 Jun 12

    Linux version 2.6.32-5-amd64 (Debian 2.6.32-45) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Sun May 6 04:00:17 UTC 2012

    new debian package, version 2.0.
    size 993282 bytes: control archive= 3562 bytes.
    933 bytes, 20 lines control
    5563 bytes, 90 lines md5sums
    248 bytes, 14 lines * postinst #!/bin/sh
    190 bytes, 12 lines * postrm #!/bin/sh
    Package: rpm
    Version: 4.9.1.3-2
    Architecture: amd64
    Maintainer: Michal 膶iha艡 <nijel@debian.org>
    Installed-Size: 1231
    Depends: libc6 (>= 2.4), libelf1 (>= 0.131), libpopt0 (>= 1.14), librpm2 (>= 4.9.0), librpmbuild2 (>= 4.9.0), librpmio2 (>= 4.9.0), librpmsign0 (>= 4.9.0), perl, rpm2cpio, rpm-common (= 4.9.1.3-2)
    Suggests: alien, elfutils, rpm-i18n
    Breaks: man-db (<< 2.5.0-1), manpages-pl (<< 20051017-1)
    Replaces: manpages-pl (<< 20051017-1)
    Section: admin
    Priority: optional
    Homepage: http://rpm.org/
    Description: package manager for RPM
    The RPM Package Manager (RPM) is a command-line driven package
    management system capable of installing, uninstalling, verifying,
    querying, and updating computer software packages.
    .
    On Debian and derived systems it is recommended to use "alien" to
    convert RPM packages into .deb format instead of bypassing the Debian
    package management system by installing them directly with rpm.


    This is my debian and my rpm package's information. Do you know they are neither compatible or not? Why linux have so many dependency problem and the microsoft window don't?

  • designer
    RE: yumError
    Other, if the debian system can't install yum package, why debian website have a yum package?!!!!!!!!!!
    Link to this post 01 Jun 12

    Other, if the debian system can't install yum package, why debian website have a yum package?!!!!!!!!!!

  • designer
    RE: yumError
    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!!
    Link to this post 01 Jun 12

    But when i use the dpkg -i package install package, i often met the dependency problem. I have to one by one download the package i need. You this is so boring?!!!!!!!!!!Is it have a easy way to install package?!!!!!!!!!!

  • designer
    RE: yumError
    Linux version 2.6.32-5-amd64 (Debian 2.6.32-45) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Sun May 6 04:00:17 UTC 2012 new debian package, version 2.0. size 633956 bytes: control archive= 3464 bytes. 185 bytes, 7 lines conffiles 984 bytes, 25 lines control 5414 bytes, 79 lines md5sums 507 bytes, 17 lines * postinst #!/bin/sh 178 bytes, 7 lines * postrm #!/bin/sh 462 bytes, 16 lines * prerm #!/bin/sh Package: yum Version: 3.2.25-1 Architecture: all Maintainer: Thomas Goirand Installed-Size: 2120 Depends: python, python-support (>= 0.90.0), python (>= 2.5) | python-celementtree, python-libxml2, python-urlgrabber, rpm (>= 4.4.1), python-rpm, python-sqlitecachec, python-sqlite Section: admin Priority: extra Homepage: http://yum.baseurl.org/ Description: Advanced front-end for rpm Yum (Yellow dog Updater, Modified) is an automatic updater and package installer/remover for rpm systems. It automatically computes dependencies and figures out what things should occur to install packages. It makes it easier to maintain groups of machines without having to manually update each one using rpm. . Features include: . * Multiple Repositories * Simple config file * Correct dependency calculation * Fast operation * rpm-consistent behavior * comps.xml group support, including multiple repository groups * Simple interface I can give everything you want, if you can resolve this problem. thanks.
    Link to this post 01 Jun 12

    Linux version 2.6.32-5-amd64 (Debian 2.6.32-45) (dannf@debian.org) (gcc version 4.3.5 (Debian 4.3.5-4) ) #1 SMP Sun May 6 04:00:17 UTC 2012

    new debian package, version 2.0.
    size 633956 bytes: control archive= 3464 bytes.
    185 bytes, 7 lines conffiles
    984 bytes, 25 lines control
    5414 bytes, 79 lines md5sums
    507 bytes, 17 lines * postinst #!/bin/sh
    178 bytes, 7 lines * postrm #!/bin/sh
    462 bytes, 16 lines * prerm #!/bin/sh
    Package: yum
    Version: 3.2.25-1
    Architecture: all
    Maintainer: Thomas Goirand <thomas@goirand.fr>
    Installed-Size: 2120
    Depends: python, python-support (>= 0.90.0), python (>= 2.5) | python-celementtree, python-libxml2, python-urlgrabber, rpm (>= 4.4.1), python-rpm, python-sqlitecachec, python-sqlite
    Section: admin
    Priority: extra
    Homepage: http://yum.baseurl.org/
    Description: Advanced front-end for rpm
    Yum (Yellow dog Updater, Modified) is an automatic updater and package
    installer/remover for rpm systems. It automatically computes dependencies
    and figures out what things should occur to install packages. It makes it
    easier to maintain groups of machines without having to manually update
    each one using rpm.
    .
    Features include:
    .
    * Multiple Repositories
    * Simple config file
    * Correct dependency calculation
    * Fast operation
    * rpm-consistent behavior
    * comps.xml group support, including multiple repository groups
    * Simple interface


    I can give everything you want, if you can resolve this problem. thanks.

  • designer
    RE: rpmError
    Do you mean this problem can not be resolved? Linux package dependency with various versions of the difference between no one wanted it solves?!!!!!!!!!!!!!!!
    Link to this post 01 Jun 12

    Do you mean this problem can not be resolved? Linux package dependency with various versions of the difference between no one wanted it solves?!!!!!!!!!!!!!!!

  • designer
    RE: yumError
    What are you want? Tell me! I'll give you. But this error has shown a message "rpmdb: Program version 4.8 doesn't match environment version 5.1", do you seen?!!!!!!!!!!!!!!!Can you fix it?
    Link to this post 01 Jun 12

    What are you want? Tell me! I'll give you. But this error has shown a message "rpmdb: Program version 4.8 doesn't match environment version 5.1", do you seen?!!!!!!!!!!!!!!!Can you fix it?

  • designer
    RE: rpmError
    rpmdb: Program version 4.8 doesn't match environment version 5.1 If I use alien, I get the above error. That's say the rpmdb's version is 4.8 but the environment requirements 5.1, then how can i fix this?
    Link to this post 01 Jun 12

    rpmdb: Program version 4.8 doesn't match environment version 5.1

    If I use alien, I get the above error. That's say the rpmdb's version is 4.8 but the environment requirements 5.1, then how can i fix this?

  • designer
    rpmError
    root@debian:/home/linjieli# rpm -i linuxqq*.rpm rpm: RPM should not be used directly install RPM packages, use Alien instead! rpm: However assuming you know what you are doing... rpmdb: Program version 4.8 doesn't match environment version 5.1 error: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch error: cannot open Packages index using db3 - (-30971) error: cannot open Packages database in /root/.rpmdb rpmdb: Program version 4.8 doesn't match environment version 5.1 error: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch error: cannot open Packages database in /root/.rpmdb How can I do ?
    Link to this post 31 May 12

    root@debian:/home/linjieli# rpm -i linuxqq*.rpm
    rpm: RPM should not be used directly install RPM packages, use Alien instead!
    rpm: However assuming you know what you are doing...
    rpmdb: Program version 4.8 doesn't match environment version 5.1
    error: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
    error: cannot open Packages index using db3 - (-30971)
    error: cannot open Packages database in /root/.rpmdb
    rpmdb: Program version 4.8 doesn't match environment version 5.1
    error: db3 error(-30971) from dbenv->open: DB_VERSION_MISMATCH: Database environment version mismatch
    error: cannot open Packages database in /root/.rpmdb


    How can I do ?

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board