Linux.com

Ian_Martin

Ian_Martin

  • Linux.com Member
  • Posts: 3
  • Member Since: 14 Jun 09
  • Last Logged In: 12 Sep 13

Latest Posts

Posted by
Topic
Post Preview
Posted
  • Ian_Martin
    RE: mint 11 wireless adapter driver
    Hi, There's a whole lot of possibilities here. These are some of the common problems (and I'm assuming you have a wired interface): First up, confirm you have some hardware and the system is aware of it. In a terminal, [code]lshw -C network[/code] will give you a list of what network drivers are running, and whether they're connecting. You may need to install the lshw command with [code] sudo apt-get install lshw [/code] You're looking for something that starts with "description: Wireless interface". The command [code]rfkill list[/code] (you may need to install it with [code] sudo apt-get install rfkill [/code] ) will show you if you've got a hardware or software switch turned off. Sometimes you can flick a switch or use rfkill to turn it on. If you've turned the card off in Windows, however, that can be a show stopper; for some laptops there's no way of turning it on in Linux. If the wireless card is visible to the system, then you'll need to look at why it's not connecting. This can be for a variety of reasons. Have a look at the output of the lshw command again, and see if there's anything obvious. If the card is turned on, then it needs a network to talk to. The network settings icon down on your system tray is one way to access network settings; otherwise go through the System settings menu. You'll need the SSID ("name" of the network), and any security settings. If it's an unsecured network and you own the router, I'd strongly suggest you change that before you set it up. Good luck!
    Link to this post 04 Oct 12

    Hi,
    There's a whole lot of possibilities here. These are some of the common problems (and I'm assuming you have a wired interface):

    First up, confirm you have some hardware and the system is aware of it. In a terminal,

    lshw -C network
    will give you a list of what network drivers are running, and whether they're connecting. You may need to install the lshw command with
     sudo apt-get install lshw 

    You're looking for something that starts with "description: Wireless interface".
    The command
    rfkill list
    (you may need to install it with
     sudo apt-get install rfkill 
    ) will show you if you've got a hardware or software switch turned off. Sometimes you can flick a switch or use rfkill to turn it on. If you've turned the card off in Windows, however, that can be a show stopper; for some laptops there's no way of turning it on in Linux.

    If the wireless card is visible to the system, then you'll need to look at why it's not connecting. This can be for a variety of reasons. Have a look at the output of the lshw command again, and see if there's anything obvious.

    If the card is turned on, then it needs a network to talk to. The network settings icon down on your system tray is one way to access network settings; otherwise go through the System settings menu. You'll need the SSID ("name" of the network), and any security settings. If it's an unsecured network and you own the router, I'd strongly suggest you change that before you set it up.

    Good luck!

  • Ian_Martin
    RE: An easy way to compile and Install GTK + C Headers
    Hi, If you install the gtkmm dev files through synaptic you should be right. Have a look in the gtkmm manual (at http://gtkmm.org/documentation.shtml ) for more details.
    Link to this post 18 Oct 09

    Hi,
    If you install the gtkmm dev files through synaptic you should be right. Have a look in the gtkmm manual (at http://gtkmm.org/documentation.shtml ) for more details.

  • Ian_Martin
    RE: Make error
    Looks like the line >all: >$(MAKE) -C $(KDIR) SUBDIRS=$[b](PWD) modules[/b] is being interpreted out so $PWD modules is not coming out the way you want. Change it to $(MAKE) -C $(KDIR) SUBDIRS=$[b](PWD)/modules[/b] (ie get rid of the space, and replace it with a /) and you should be OK.
    Link to this post 20 Sep 09

    Looks like the line
    >all:
    >$(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
    is being interpreted out so $PWD modules is not coming out the way you want. Change it to

    $(MAKE) -C $(KDIR) SUBDIRS=$(PWD)/modules (ie get rid of the space, and replace it with a /) and you should be OK.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board