Home Linux Community Forums Software Productivity NEdit and disabling auto indent

NEdit and disabling auto indent

Link to this post 05 Mar 11


Any NEdit pros out there? I have a NEdit issue and google has not helped me (rare). I checked the NEdit forum at sourceforge, but it looks inactive so I thought i'd try here. There is no NEdit users group here (first place i checked), so i created one (pending approval or something right now).

Anyway, my problem is with auto-indent. I can manually disable it via Preferences > Auto Indent > Off, but I cannot make the change persistent. If I do Preferences > Default Settings > Auto Indent > Off, the little Off radio button is checked and then I do Preferences > Save Defaults > OK and close NEdit. The next time I fire up NEdit, though, auto indent is back on. The weird thing, though, is that under Preferences > Default Settings > Auto Indent, it still reports as Off. What the dilly-o?

I tried running nedit from the command line with the -noautoindent option, too, but that does not seem to work: i still have to manually disable auto indent.

I'm on Fedora 8. I'm using nedit from This is the output of nedit -version:

NEdit 5.5
Sep 30, 2004

Built on: Linux, 386, GNU C
Built at: Oct 1 2004, 15:55:40
With Motif: 2.1.30 [@(#)Motif Version 2.1.30]
Running Motif: 2.1 [unknown]
Server: The X.Org Foundation 10300000
Visual: 32-bit TrueColor (ID 0x6b)
Locale: en_US

I also tried the nedit package made for Fedora 8, but it behaves exactly the same way.

I could find nothing about indent in my ~/.nedit/nedit.rc file either. Is there some X resource I can use for this?


Link to this post 05 Mar 11

I have been using NEdit for about 20 years - my wife is a staff scientist at Fermi Lab and we were friends with the original developer(s) there. I just tested my version 5.5 on SL6 (Scientific Linux 6 - a clone of RHEL6) and it saved and restored the auto-indent context properly. Since the default settings are stored in ~/.nedit/neditrc it is possible that for some reason either the directory or file is owned by someone else, has the wrong permissions, or whatever. Check that out.

Link to this post 05 Mar 11

my ~/.nedit/nedit.rc file ownership and permissions are okay.

Per your comment about using a RH clone, I tried it out on a CentOS box and sure enough, the auto indent setting is properly retained! This issue appears to be specific to Fedora, or at least occurs in Fedora 8. There is an updated version of the nedit package for F8, so i tried it, but no luck - same behavior.

I do not want to switch OSs just to get this to work!

Link to this post 07 Mar 11

Well, there may be a problem with the version built on FC8. Download the sources from and rebuild on your FC8 system to see if that resolves the problem.

Link to this post 08 Mar 11

I've tried rebuilding nedit from source in the past (to address other UI-issues) and it was a pain. But I'm desperate, so i tried again - recompile failed again (can give the details if anyone is interested).

However, I thought I'd try to recompile the nedit SRPM from my CentOS box on which nedit is behaving, since I figured that more likely to successfully recompile (since it's already "Fedora-ized"). I eventually got it to recompile into a binary RPM (had to get openmotif-devel first). Then I removed my old nedit binary and ~/.nedit/nedit.rc and installed the newly compiled nedit RPM...still no luck.

Thanks for your input, btw.


Link to this post 12 Mar 11

Well, since FC8 is pretty much an "antique" in internet terms, why not upgrade the OS? Yeah, I know, you probably have applications that won't take the upgrade that you need... :-)

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board