Linux.com

Home Linux Community Forums Linux Distributions Red Hat blacklisting modules in anaconda

blacklisting modules in anaconda

Link to this post 11 Mar 10

I'm attempting to blacklist a specific kernel module (lpfc, for an emulex fc hba) and have not found a way to do it.

I'm using the vmlinuz and initrd from the rhel5.3 iso (doing a usb install) and have modified the kernel boot parameters to include blacklist=lpfc (found it on a fedora forum) but anaconda is not honoring the parameter.

Any ideas?

-Ryan

Link to this post 11 Mar 10

If you are running a redhat based distro, you should be able to just edit /etc/modprobe.conf and add a line akin to:


alias lpfc off

Link to this post 11 Mar 10

Thanks for the reply. I do use this module after the machine has been kickstarted, what I'm hoping to accomplish is to prevent anaconda from loading that module during installation as it auto-maps the luns so I can't predict the dev node for the usb drive (which I need to specify the ks.cfg location).

-Ryan

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board