Linux.com

Home Linux Community Forums Linux Distributions Red Hat DNS reverse lookup not working..

DNS reverse lookup not working..

Link to this post 07 Sep 09

I have done all that correctly. but the problem exists. Now i tried to re-configure it all--

Now My internal IP is 192.168.70.1
I wanna configure DNS for users in my subnet (internally).
The hostname is -- myserver.dypcoe.com
domainname-- dypcoe.com

entries in named.conf are:--

options {
listen-on port 53 { any; };
# listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
query-source port 53;
query-source-v6 port 53;
allow-query { any; };
};

zone "." IN {
type hint;
file "named.ca";
};

zone "localdomain" IN {
type master;
file "localdomain.zone";
allow-update { none; };
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};

zone "dypcoe.com" IN {
type master;
notify no;
file "dypcoe.com.zone";
allow-query { any; };
};

zone "0.168.192.in-addr.arpa" {
type master;
notify no;
allow-query { any; };
file "192.168.0.zone";
};


The zone file for dypcoe.com (forward lookup) is--

$TTL	86400
@ IN SOA myserver.dypcoe.com. root.dypcoe.com. (
42 ; serial (d. adams)
3H ; refresh
15M ; retry
1W ; expiry
1D ) ; minimum
IN NS www
myserver.dypcoe.com. IN A 192.168.70.1

The zone file for 192.168.0.x is---


$TTL	86400
@ IN SOA myserver.dypcoe.com. root.myserver.dypcoe.com. (
1997022700 ; Serial
28800 ; Refresh
14400 ; Retry
3600000 ; Expire
86400 ) ; Minimum
IN NS myserver.dypcoe.com.
1 IN PTR myserver.dypcoe.com.

dhcp is configured accordingly in dhcpd.conf file as-- :

ddns-update-style interim;
ignore client-updates;

subnet 192.168.70.0 netmask 255.255.255.0 {

option routers 192.168.70.1;
option subnet-mask 255.255.0.0;

option nis-domain "dypcoe.com";
option domain-name "dypcoe.com";

option time-offset -18000; # Eastern Standard Time

range dynamic-bootp 192.168.70.128 192.168.70.254;
default-lease-time 21600;
max-lease-time 43200;
}
#


now when i do

#host 192.168.70.1

i get error msg as:--


Host 1.70.168.192.in-addr.arpa not found: 3(NXDOMAIN)

Please help me out!!

Link to this post 28 Sep 09

Is your address rang 192.168.70.x or 192.168.0.x? your reverse zone is setup as 192.168.0.x I bet 'host 192.168.0.1' will work. basically you have the reverse setup incorrectly.

Link to this post 13 Oct 09

Please check that you have defined 192.168.0. network in the config file and you are tryig to resolve 192.168.70.1 which is not configured .

You change the line

zone "0.168.192.in-addr.arpa" {
type master;
notify no;
allow-query { any; };
file "192.168.0.zone";
};

to

zone "70.168.192.in-addr.arpa" {
type master;
notify no;
allow-query { any; };
file "192.168.70.zone";
};

and the subnet-mask to 255.255.255.0 in dhcpd.conf

It Should work Perfectly

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board