Home Linux Community Forums Hardware Storage How to enable Joliet file system support?

How to enable Joliet file system support?

Link to this post 13 May 11

Ok, I`m fairly new to linux having been a Windows user for as long as there has been a windows operating system around and DOS before that even. My problem is that like a great many Windows users I have a large collection of burned CD`s & DVD`s that use the Joliet file system. But apparently the distro of Linux I`m using now (Kubuntu 10.10 32 bit) does not have support for reading the Joliet file system enabled by default and I don`t know how to enable it. So here I am asking if anyone knows how to enable it? I`m well aware that I could make an ISO image of the discs in question and then mount them as the various mounting utilities all seem to support reading the Joliet file system, but this isn`t really a viable solution since I have a few hundred discs now in my collection from my pre-Linux days and in terms of disk space this would pretty much fill my entire hard drive and then some if I were to take this approach. What I really need is to just be able to put the disc into the drive and open Dolphin and be able to access it just like I can any other disc or drive.

I did some digging around and discovered that kernel support for reading the Joliet file system has apparently been around for quite a while now, but apparently nobody ever considered the fact that it would be very beneficial to those users coming over to Linux from Windows to enable this support by default. As such, users like myself are essentially left without a reasonable means to access the multitude of discs we may have accumulated before making the move to Linux.

Anyway I am hoping someone here can help me figure out how to enable this so I can access my old CD`s & DVD`s.

My system specs are as follows:
CPU: Pentium 4 2.8ghz w/hyperthreading (32 bit)
Motherboard: Intel D865GLC socket 478
Memory: 3Gb RAM (2 1Gb sticks and 2 512Mb sticks running in Dual Channel mode)
Graphics: nVidia 7600GS 8X AGP w/512M RAM
Hard Drives:1.0TB Hitachi Deskstar (hosting Windows XP Pro 32bit) & 500Gb Hitachi Deskstar hosting Kubuntu 10.10 32bit (fully updated)

And yes I know it`s about time to consider an upgrade, I`m planning on it soon, but still would need to be able to enable Joliet file system support in my Linux install.

Thanks for any help anyone can provide,

Link to this post 13 May 11

Well, the short answer to "How to enable joliet fs support" is - recompile your kernel. But that may not be necessary, it might already be enabled. If it isn't, maybe there is a kernel package for your Linux distro that contains that module (I think Joliet is an MS extension to ISO9660). But first, try to confirm whether or not it is enabled already.

Run this command to see if this file exists on your system:

ls /proc/config.gz

This file contains the configuration of your currently running kernel. If it is there, try this:
cat /proc/config.gz|gunzip|grep -i joliet

On my system, for example, (Fedora 8), it returns:

If that file is not in /proc, you can also try this command to see if a static copy of your kernel config exists in /boot:

ls /boot/config-`uname -r`

If this file exists, then try:
cat /boot/config-`uname -r`|grep -i joliet

If you do indeed have Joliet support, I'm not sure what is going on. If you have neither of those files, maybe an Ubuntu pro here can help you determine whether or not you already have support.

If you definitely do NOT have support enabled, then you need to either recompile your kernel, or find a Linux distro that already has support built into the kernel provided (as I mentioned, Fedora apparently does).

One other thing to note, Joliet/ISO9960 support can either built into the kernel, or built separately, as a module. Look in this directory for filesystems supported by your kernel:

/lib/modules/`uname -r`/kernel/fs

In there you might see a directory named iso9660. If so, you can try this command and see what happens:

modprobe iso9660

but that should be done automatically for you when you inserted a CD.

If you decide to recompile your kernel, don't be too daunted - it's not so gory these days and we can help.

I just booted Kubuntu 10.10 Live and sure enough, there does appear to be Joliet support built into the kernel. To try and emulate your problem, I attempted to create an ISO image with Joliet extensions, then I burned it to CD. I was able to mount it in the Kubuntu system, though. Perhaps you could explain more precisely how you've written these CDs - ie., what OS, what app did you use, etc.

Link to this post 13 May 11

First thank you for taking the time to reply to my post. I ran the commands to check for the presence of my kernel in /boot and sure enough it`s there (the first method returned a `No such file or directory` error) and the next command to check to see if Joliet file system support was enabled returned:


So apparently it is enabled (I never knew how to check, I just know it`s never worked with a lot of my discs and the only thing I could find to explain it was that the discs in question all used the Joliet filesystem only), I`m not sure what`s going on then. As to the discs themselves they were burned over the last dozen or so years with various versions of Windows ranging from Windows 95 (and both releases of 98, ME, & 2000) all the way to my current Windows XP Pro install, and with a variety of software ranging from Nero 4 and up, EZ CD Creator 5 and up, to Imgburn to CDBurnerXP, to InfraRecorder, to the builtin CD/DVD burning support in XP and a few others in there too that I can`t even remember the names of unfortunately I`m not sure what discs were burned with what software even at this point, what I do know though is that they work in my XP install on the same machine so I know it`s not a hardware issue, but I`m really trying to move away from Windows for all but some of the rare software that I use that isn`t supported by WINE yet or doesn`t have a similar Linux equivalent with a GUI (while I`m competent enough to use a CLI I much prefer point and click simplicity).

I appreciate the help, at least now I know it`s probably something else interfering with it. What that is or how to determine what it is is a whole different matter all together now I guess. Again thank you and hopefully someone else might be able to chime in here with some more tips, that is unless you have some more thoughts on the matter.

EDIT: I tried navigating to `/lib/modules/`uname -r`/kernel/fs` as you suggested and there was no iso9660 folder or file in that folder, nor was there any file named joliet either (not that I know if there should be or not though). And manually running modprobe iso9660 as root after inserting one of the problematic discs appears to have no effect, the system still apparently won`t recognise the disc. Also I just noticed that one of the affected discs is reported by Imgburn (running under WINE) as having ISO9660, Joliet, and UDF (1.02) filesystems/extensions present. You`d think that withl all of that Linux should be able to see at least one of the filesystems present on that disc. Imgburn also reports only one session on the disc and that it is complete. I know I`ve seen problems on some systems with using discs that were left open so that more files could be added later, so that was one thing I checked for when I first encountered this problem.

Link to this post 13 May 11

just curious, have you tried mounting one of the CDs manually, versus letting the desktop/file manager, etc, doing it? something like:

sudo mount -v -t iso9960 -o ro /dev/sr0 /media/cdrom

what errors do you get from that command, if any? Anything related in /var/log/messages or in the output of dmesg?

Link to this post 13 May 11

I can manually mount the problematic discs using that command just fine (no errors reported when I do), I can then browse it from the console/terminal just fine, but it doesn`t show up in my file manager at all unless I manually type the location into the file manager as /media/cdrom or manually browse to /media/cdrom (had to create the /media/cdrom mountpoint manually though, but I ran dolphin as root and set the permissions to allow anyone to read or write to it just like I`ve done for other drives that I`ve added through fstab). So it looks like the problem is with whatever process is supposed to automount the disc using the iso9660 filesystem module I`m guessing.

Link to this post 13 May 11

Check the contents of your /etc/fstab for an entry for the cdrom. If there is one, post it. Maybe it is wrong, or needs to be commented out.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>