Home Linux Community Forums Linux System Administration System Management Disk space gone after upgrade - Howto see it?

Disk space gone after upgrade - Howto see it?

Link to this post 19 Jun 11

Hi Linux / *nix experts

I have been a Linux user since redhat 4.2 - and have lately upgraded from fedora 14 to 15 - by PreUpgrade command.

All went nice and easy .... but somehome 45G is now GONE from my / partition?


Before upgrade:

I had


And on /media I had the following


After upgrade:


But my dirctories

have GONE

But the SPACE is STILL in use - (from du/df commands)


How to "mount" these dir once more - or alternativly - free up the space (would like to mount the folders once more as photos exist on these I would like to have)


Total DISK size= 160GB

->[root@valhalla /]# df -H
Filesystem Size Used Avail Use% Mounted on
rootfs 53G 49G 4.3G 92% / <--- 49G used on / - OK if /media is avaliable - but checking / ONLY shows
udev 1.1G 0 1.1G 0% /dev
tmpfs 1.1G 541k 1.1G 1% /dev/shm
tmpfs 1.1G 742k 1.1G 1% /run
53G 49G 4.3G 92% /
tmpfs 1.1G 0 1.1G 0% /sys/fs/cgroup
tmpfs 1.1G 742k 1.1G 1% /var/lock
tmpfs 1.1G 742k 1.1G 1% /var/run
tmpfs 1.1G 0 1.1G 0% /media
/dev/sda1 508M 96M 386M 20% /boot
100G 82G 14G 86% /home
[root@valhalla /]#
[root@valhalla /]# du -hc --max-depth=1
0 ./media
231M ./opt
528K ./dev
6.5G ./usr
333M ./lib
37M ./etc
720M ./var
0 ./sys
du: cannot access `./proc/16477/task/16477/fd/4': No such file or directory
du: cannot access `./proc/16477/task/16477/fdinfo/4': No such file or directory
du: cannot access `./proc/16477/fd/4': No such file or directory
du: cannot access `./proc/16477/fdinfo/4': No such file or directory
0 ./proc
du: cannot access `./home/jan/.gvfs': Permission denied
76G ./home
14M ./sbin
12K ./mnt
12K ./.dbus
0 ./selinux
724K ./run
16K ./lost+found
4.0K ./srv
4.6M ./root
232K ./tmp
81M ./boot
8.7M ./bin
4.0K ./cgroup
84G .
84G total


[root@valhalla /]# cat /etc/fstab

# /etc/fstab
# Created by anaconda on Tue Dec 7 19:55:40 2010
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or blkid(8) for more info
/dev/mapper/vg_valhalla-lv_root / ext4 defaults 1 1
UUID=bb16e6e2-11a6-4c8b-9406-4163227ace85 /boot ext4 defaults 1 2
/dev/mapper/vg_valhalla-lv_home /home ext4 defaults 1 2
/dev/mapper/vg_valhalla-lv_swap swap swap defaults 0 0
tmpfs /dev/shm tmpfs defaults 0 0
devpts /dev/pts devpts gid=5,mode=620 0 0
sysfs /sys sysfs defaults 0 0
proc /proc proc defaults 0 0
[root@valhalla /]#

[root@valhalla /]# cat /proc/partitions
major minor #blocks name

8 0 156290904 sda
8 1 512000 sda1
8 2 155777024 sda2
253 0 52428800 dm-0
253 1 4128768 dm-1
253 2 99188736 dm-2
[root@valhalla /]#

/dev/ram0 [ 16.00 MiB]
/dev/root [ 50.00 GiB]
/dev/ram1 [ 16.00 MiB]
/dev/sda1 [ 500.00 MiB]
/dev/vg_valhalla/lv_swap [ 3.94 GiB]
/dev/ram2 [ 16.00 MiB]
/dev/sda2 [ 148.56 GiB] LVM physical volume
/dev/vg_valhalla/lv_home [ 94.59 GiB]
/dev/ram3 [ 16.00 MiB]
/dev/ram4 [ 16.00 MiB]
/dev/ram5 [ 16.00 MiB]
/dev/ram6 [ 16.00 MiB]
/dev/ram7 [ 16.00 MiB]
/dev/ram8 [ 16.00 MiB]
/dev/ram9 [ 16.00 MiB]
/dev/ram10 [ 16.00 MiB]
/dev/ram11 [ 16.00 MiB]
/dev/ram12 [ 16.00 MiB]
/dev/ram13 [ 16.00 MiB]
/dev/ram14 [ 16.00 MiB]
/dev/ram15 [ 16.00 MiB]
3 disks
17 partitions
0 LVM physical volume whole disks
1 LVM physical volume
[root@valhalla /]#


1 LVM physical volume
[root@valhalla /]# blkid
/dev/root: LABEL="_Fedora-14-i686-" UUID="45e0398e-7cd1-4e42-a13a-a496831df311" TYPE="ext4"
/dev/sda1: UUID="bb16e6e2-11a6-4c8b-9406-4163227ace85" TYPE="ext4"
/dev/sda2: UUID="g4C8io-e6Tp-hDP8-TwTh-Hzzp-mE4D-MF3lN6" TYPE="LVM2_member"
/dev/mapper/vg_valhalla-lv_swap: UUID="69b2090c-9456-494b-8be9-83d71b3ddc74" TYPE="swap"
/dev/mapper/vg_valhalla-lv_home: UUID="aa00c0f6-2414-4015-963b-7fe04f54c3f0" TYPE="ext4"
[root@valhalla /]#

Link to this post 20 Jun 11

I hate to say this, but, /media in root is for the temporary placement of info concerning what hardware media (i.e., cdrom, floppy, external usb drive etc.) is active in your current session.
Open the /media folder in Nautilus or Dolphin, insert a usb stick, and you'll see the stick appear. Safely remove the stick, and it disappears.
Photos and Videos should be kept in ones /home directory, or on a separate partition, not in a root directory.

BTW - One would have to use administrator rights to write to a file in the root folder, or, change the access rights to that folder to allow user privileges. Did you do either to store or look at the videos/photos? If not, maybe these items are stored on a separate partition somewhere. I'm also not a fan of LVM (at least on the desktop), so, my fedora installs don't use it, so, if something is hidden in an LVM, maybe someone can come along that may have some better news about locating your lost /media file.

Link to this post 20 Jun 11

thanks for the info

I did make the dir - r/w for all - and it worked as expected when inserting usb drives, etc--
All was seen in /media - including my /media/photo folders.

But after the "upgrade" they was gone - but the "space" is still used.

Any idea to check where the "used" space is - if the "/media/photos" is not seen how come du/df displays info as this space is STILL in use ?

Best Regards

/Jan J

Link to this post 20 Jun 11

It may be the way fedora is mounting that space. Maybe by trying a rescue disk like Partition Magic (or actually any live CD) you can mount that particular partition and see if you can recover the data from those folders. If in fact the files are still there, and, from the info you've supplied, it seems they are, maybe just using a live CD would allow the partition to be mounted again showing the lost folders.
I help test an app called inxi that shows all the partitions in its output, but, recently, after installing Fedora 15, we've noticed that some of the partitions are being duplicated in the output. There are duplicate mounts for /home for example. Reading through some of the threads on the various fedora mailing lists, I've found mention of these same mounting problems. The answers I've read point to the way fedora mounts things now, especially with the way systemd works during boot. One of the ways around this problem was to, instead of using mount, we should use findmnt, which doesn't show the duplicate mount, but, shows a structured readout of how things are mounted. This is not an answer to your problem, but shows that some partitions get mounted differently now, and I'm told it's basically for security purposes.
I don't know if the findmnt command will show you the missing folders in /media, especially using fedora 15. It shows /media as being mounted as tmpfs on my machine. But, if you use a LiveCD with a Debian base, which doesn't use systemd, the missing folders might show up when root/media is mounted, and thereby, let you retrieve your files.
There is no findmnt on Fedora 13, and, /media is not mounted as tmpfs (I just looked), so, my guess at this point is to try to look at it with something other than F15 and see if your missing folders appear.

Geez, I hope this helped. It certainly taught me a few things looking at it. I had no idea that the way things are mounted in fedora 15 were so different from earlier fedora releases.

Link to this post 21 Jun 11

Thanks - did just that -
Rescue CD - mv /media/photos to /opt/photos

And voila - files is back ;-)

/Jan J

Link to this post 21 Jun 11

I glad that worked out, and I'm happy to have helped. I also got to see a few new things that weren't explicitly provided in distro changelogs.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>