Linux.com

linux cannot mount disk

Link to this post 25 Jul 10

i have centos 5.x server operating system.
my sata disk is full and file system (ext3) goes read-only.
i run FSCK than after filesystem is corrupted
i dont see anything (files or folder) ls command
"cd /var/lib/mysql" command worked but i dont see folder, file names

reboot machine so server cannot mount disk

what can i do

Thanks to any help

Link to this post 27 Jul 10

try to use a live cd (mandriva-ubuntu) to access your root partition then try to access your /tmp directory to empty it, that may free up loads of space

Link to this post 07 Jan 11

Find a computer will a lot of disk space, twice as much than you primary disk. OR, find an empty hard drive not formatted or has a lot of space and connect it to your server system. Boot the system using a liveCD, ubuntu, fedora etc. Once in, mount the new drive and your primary drive and rsync the data from your primary drive to your new harddrive.

You disk it full so nothing else can be added, that is why you are getting the read only prompt. Running any filesystem check will require space on your harddrive to run properly. If not it will crash and take your drive with it.

Or download a disk cloning software and clone your primary drive to another one.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board