GUI is not working

Link to this post 12 Jun 09

Hi ,

I installed Ubuntu in my system two months back and it is running fine. But now i am not able to login to GUI. The moment when i select Ubuntu ( Windows XP also running in the system) it is directly going to CUI. Can you please help me to solve this problem, what happened to GUI suddenly.

Thanks in advance.


Link to this post 12 Jun 09

Try at the commandline :startx

see if there is an error. If there isn't, you'll have to change the /etc/inittab file at this line:

# The default runlevel is defined here

Make sure it says id:5:initdefault

then reboot

Link to this post 13 Jun 09

Thanks very much.

After I ran the startx command it was enter to GUI mode. But i got an error also(Error: The panel encountered a problem while loading "OAFIID:GNOME_FastUserSwitchAPPLET") .

There is no inittab file under /etc/ . Please find the out put of ls command under /etc/ below.

room1@room1-desktop:/etc$ ls -lrt inittab
ls: cannot access inittab: No such file or directory
room1@room1-desktop:/etc$ [file name=Screenshot_Error.png size=17045][/file]

Link to this post 15 Jun 09

The missing applet probably won't stop the GUI from running. The missing inittab is more problematic since it is needed to properly start the system. Here is an example (/etc/inittab from my CentOS system):

# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
# Author: Miquel van Smoorenburg, <>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
# id:3:initdefault:

# System initialization.

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Run xdm in runlevel 5
x:5:respawn:/etc/X11/prefdm -nodaemon

Link to this post 18 Jun 09

I searched in internet and most of the places it was mentioned that there is no /etc/inittab file in Ubuntu because Ubuntu uses /etc/event.d/rc-default file, but when i look in to the file rc-default it is refering to inittab file under etc.

I created inittab file under /etc and copied the same contents provided above. I rebooted the system still it is going to CMD only. Please find the rc-default file contents below.

room1@room1-desktop:/etc$ ls -lrt inittab
-rw-r--r-- 1 root root 1737 2009-06-18 09:52 inittab

room1@room1-desktop:/etc/event.d$ ls -lrt rc-default
-rw-r--r-- 1 root root 485 2008-04-11 19:19 rc-default

room1@room1-desktop:/etc/event.d$ more rc-default
# rc - runlevel compatibility
# This task guesses what the "default runlevel" should be and starts the
# appropriate script.

start on stopped rcS

runlevel --reboot || true

if grep -q -w -- "-s\|single\|S" /proc/cmdline; then
telinit S
elif [ -r /etc/inittab ]; then
RL="$(sed -n -e "/^id:[0-9]*:initdefault:/{s/^id://;s/:.*//;p}" /etc/inittab || true)"
if [ -n "$RL" ]; then
telinit $RL
telinit 2
telinit 2
end script

I ran the sed command line present in the rc-default file at the command prompt and it gives the out put as 5. Please find the sed command and its out put below.

room1@room1-desktop:/etc/event.d$ sed -n -e "/^id:[0-9]*:initdefault:/{s/^id://;s/:.*//;p}" /etc/inittab

Please help me to resolve this problem.

Link to this post 19 Jun 09

Is X maybe trying to start up, but failing for some reason and then Ubuntu is just dropping you to a login prompt?

See if you can have a look at /var/log/Xorg.0.log for errors.
Although the fact that you can run startx and it launches (with some applet errors) leads me to believe there's nothing wrong with X.

Just need to poke around the system to see if you can get an indication as to what's erroring out.

check output of
dmesg | more
more /var/log/messages
more /var/log/Xorg.0.log
more /var/log/syslog

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board