Linux.com

Networked Sound

Link to this post 19 Jun 09

I already got your help with the PXE Boot situation and here i am again with a question!

Now i have the LTSP server running fine and all works quite fast i must say. The only thing i miss is the sound. When checking the soundsystem in Gnome, it only show the soundcard of the server, on which ALSA runs, even in the image i have included ALSA, but it outputs the same config.
What i would like is to play the sound over the network, e.g. have some music on the server, and got that mounted via NFS and i want to play it on the thin client and hear the audio on the thin client. Now what happens when i open up a mp3 file is that the music starts playing on the server, meaning, the sound comes out of the speakers connected to the server.

Already searched a bit and came along PulseAudio altho i couldn't get that to work properly and there was a program in Ubuntu called "nas" and so far i haven't got that working either...

So, anybody some ideas or some handy links?

Thanks in advance!

Link to this post 19 Jun 09

That's an interesting topic, and not a new one (I mean I remember hitting the same problem with IP Telephony application on Citrix back at the beginning of this century.

When I first read your post I thought VLC: Video LAN Client sounds about just right for what you need.

So you can stream audio out of your Server session using VLC, as long as you have all the required codecs.

But then you need to be able to receive or read the stream from your thin-client...

Can you access the console using Alt+F1 or Ctrl+Alt+F1?

If you can then you could check some of the VLC documentation that explains how to setup streaming for both the client and server (http://www.videolan.org/doc/streaming-howto/en/ch04.html#id311798).

I hope this helps!

Link to this post 23 Jun 09

langerak wrote:

I already got your help with the PXE Boot situation and here i am again with a question!

Now i have the LTSP server running fine and all works quite fast i must say. The only thing i miss is the sound. When checking the soundsystem in Gnome, it only show the soundcard of the server, on which ALSA runs, even in the image i have included ALSA, but it outputs the same config.
What i would like is to play the sound over the network, e.g. have some music on the server, and got that mounted via NFS and i want to play it on the thin client and hear the audio on the thin client. Now what happens when i open up a mp3 file is that the music starts playing on the server, meaning, the sound comes out of the speakers connected to the server.

Already searched a bit and came along PulseAudio altho i couldn't get that to work properly and there was a program in Ubuntu called "nas" and so far i haven't got that working either...

So, anybody some ideas or some handy links?

Thanks in advance!

What type of hardware is your thin client? Does it have a sound card? What distro is the thin client?

If I understand what you are trying to do, I do it at home - the only difference is I use SMB (SaMBa) instead of NFS. The Linux fileserver that hosts my MP3s doesn't even have a sound card. But all my SMB clients that attach to it to listen to music do have sound cards. It is just a matter of getting sound working on my clients, and then accessing the network share, and playing the files with some player (e.g., i use WinAmp on my Windows boxes and XMMS on my Linux boxes). The server does not actually play/stream the music.

Is there some reason why this approach would not work for you?

Link to this post 24 Jun 09

SMB (SaMBa)

SMB actually stands for Server Message Block :p.

Link to this post 24 Jun 09

ludovic.ferre wrote:

[quote]SMB (SaMBa)

SMB actually stands for Server Message Block :p.[/quote]

yeah, I know, but when we're standing around the coffee machine, we say "the Samba server locked up again", not the "the Server Message Block server locked up again" :P

Link to this post 14 Aug 09

* bump *

It's been a while since i've been here and tried figuring this mess out and got some changes.

At work we stopped using the LTSP Boot server, because server wasn't good enough ;). But now we are running the server, which allows XDMCP connections (GDM) and all works fine now, can stream little video (no sound) on the 100 Mbits line. But still there is no sound throughput. The clients connecting to the server are Ubuntu 9.04 64-bit AMD's and one Windows client running X-Ming (is slower too). The server is also running Ubuntu 9.04 64-bit AMD.

For networked sound i have seen some solutions on the net and was wondering which one works best in my case, seen alot of howto's as well, but are soooo outdated i won't dare my hands on it, like aRTs, which isn't being developed anymore.

The choices are:
- PulseAudio
- NASD
- ESD
- aRTs
- Using Gstreamer, altho no info available about that it seems :(

I know aRTs used to work a couple of years ago (in my KDE memories :P), but now it won't, so that's bad :(.

The reply about samba networking sound, i have found little info on it, so is that option still possible in Samba?

I hope i can get a good advice from the community about this as i am becoming a bit irritated that it's still not working lol :D.

As for the rest, the whole network runs smooth, sharing printers, directory's and connecting with XDMCP as well, only the sound problem still remains...

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Join / Linux Training / Board