Home Linux Community Forums Linux Distributions Ubuntu [finished] No graphical interface (stops booting at: "starting timidity alsa midi emulation")

[finished] No graphical interface (stops booting at: "starting timidity alsa midi emulation")

Link to this post 15 Mar 12

Alright, I did it. ;)

My Kubuntu doesn't load the login screen or the graphical interface anymore but stops booting when it prints "Starting TiMidity++ ALSA midi emulation... [ OK ]".

However, I can't tell exactly which action has caused this:
Before some parts of my workspace have crashed and restarted, and afterwards the workspace was rather slow.
Yet before I restarted the system, I've also changed the owner of the folders /var and /etc to root (stupid idea? ^^) in order to fix another problem (message was sth like "... is owned by uid 1000, should be 0").

So I was wondering now, if there's a way to fix this problem without a complete reinstallation.

Thanks in advance and just ask if you think you need to know some more things. :)

Link to this post 16 Mar 12

The folders /etc and /var are owned by root, although the user (you) has access to some of the files in these folders. Did you try installing some midi software that could have changed permissions? Were the permissions listed for /etc and /var shown to be owned by someone other than root and that's why you had to change them back to root? UID 1000 is usually the UID given to the first user (you). If some system files were changed to give you as the user access, I don't see why that would cause the system to fail, but, I have never changed the access of my system files, I've only accessed them as root.
Maybe you could tell us what you were doing/installing in regards to the midi device that may have caused your problems to start. Permissions for the /etc and /var folders should not have been changed from root in the first place, but I don't know what could have caused that error.

Link to this post 16 Mar 12

Hi, I received the permissions error when I tried to run the plasmapkg-command in order to install a plasmoid (with sudo, of course). Strangely this has worked out fine a few times before even though I can't remember to have changed any configurations in the mean time.
So I think I actually did not do anything that seemed to me to have something to do with the main error...

Link to this post 16 Mar 12

I do not use kubuntu, but is there a recovery menu item in the bootloader option that you can try to see if it can buypass the error and get you to a working state?

If that can be located, then you can check the files in /var/log to determine the point of failure.

Link to this post 17 Mar 12

Thank you very much for your help, but unfortunately I did not manage to solve this problem. And because I did not really know whether this was actually possible, I took this as the occasion to switch from Kubuntu to OpenSUSE.
So this issue can be seen as "solved". :)

Link to this post 17 Mar 12

Oh well, I guess better luck next time. I can't say I have taken bad situations as an excuse to move on myself.

Who we are ?

The Linux Foundation is a non-profit consortium dedicated to the growth of Linux.

More About the foundation...

Frequent Questions

Linux Training / Board

/** BC-056 Ameex changes to add tracking code - 2016-01-22 **/ ?>